LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 10-29-2003, 03:10 PM   #1
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
how to get mandrake 9.0 shut down the computer without pushing the power button?


when shut down mandrake,
once you see: system halted [ok]
power down.

thats it!!! u gotta reach your hand to the back of the box and switch that power switch, or u gotta press the power button in front and a few sec to shut it down.

i thought it was "normal" for a while, until i installed rh9, rh9 can shut down the system by itself without having me push anything. so i realized there must be a code or something i can edit to shut down my system, without having me push that power switch.

thank you
 
Old 10-29-2003, 03:16 PM   #2
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
You'll have to enable apm or acpi, which are power management systems. For acpi, Mandrake often includes a 'acpi=off' entry in the kernel options, in the config file for the bootloader. Try removing it.
 
Old 11-24-2003, 02:23 AM   #3
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Original Poster
Rep: Reputation: 30
thank you for your reply aaa.

would you mind please walk me (newbie) through how to enable acpi under console?

i tried your suggestion under GUI (using kde3 here), but it doesn't seem to be working. and i heard a lot people telling me lilo.conf under kde is kindda buggy.

thank you
 
Old 11-24-2003, 08:28 AM   #4
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Well you don't have to use KDE's configuration tool to configure lilo in KDE. Just open any editor as root: 'Go' button>'Run Command'>Type in your favorite editor>Click 'Options'>Check 'run as different user'>Enter 'root' & the password>Press Enter. Use the editor to open the /etc/lilo.conf file.

In the terminal:

user@localhost$su -
Password:
(type the password at the above prompt)

root@localhost$pico /etc/lilo.conf

(The pico editor will now show up with lilo.conf ready for editing. Use any editor you like/have, it could be something like nano or joe or vi.)
In lilo.conf, look for a set of line like this:
Code:
image=/boot/vmlinuz
label="linux"
root=/dev/hda4
initrd=/boot/initrd.img
append="quiet devfs=mount acpi=off"
vga=788
read-only
In here are a bunch of options for the kernel, most of which are in the 'append' line. Note the 'acpi=off' here. Remove this, because it stops acpi from working. If you have apm, you should use it instead of acpi. Also take a look at these threads:
http://www.linuxquestions.org/questi...=acpi+mandrake

http://www.mandrakeusers.org/index.p...t=0#entry78118
 
Old 11-25-2003, 02:31 AM   #5
unwrittenlaw
Member
 
Registered: Sep 2003
Distribution: Slackware FreeBSD Gentoo Novell
Posts: 73

Rep: Reputation: 15
ok i have mandrake 9.2 and i have this on my /etc/lilo.conf and i have the same problem after it says halted or something like it just stops and i get very lazy to press the on button i just leave like that and i also thought it was normal too but i guess is not cuz on my friends comp it works fine and i was wondering if it could also work on mandrake 9.2 and where do i have to edit things i would really appreciated thank you lates
boot=/dev/hda
map=/boot/map
default="linux"
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda1
initrd=/boot/initrd.img
append="devfs=mount hdc=ide-scsi acpi=ht resume=/dev/hda5"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda1
initrd=/boot/initrd.img
append="devfs=nomount hdc=ide-scsi acpi=on resume=/dev/hda5
failsafe"
read-only
other=/dev/fd0
label="floppy"
unsafe
 
Old 11-25-2003, 02:47 AM   #6
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Original Poster
Rep: Reputation: 30
after done some research, this is what i've found (hope would get any of us a bit closer to solution)

1) your motherboard must support acpi, or apm, if it doesn't, then even having apm or acpi won't help
2) either apm or acpi works, both can't work together
3) motherboard probably support either apm or acpi also. may need to search online to see what your motherboard support.
4) if support acpi, then enable acpi, and i believe acpi=power_off should help. search on google with keyword: acpi mandrake power or acpi mandrake shut
5) same goes to amp

i've been follow these few rules, and i believe my motherboard support acpi, add thing was, when i try enable acpi, i got this error msg at boot:

acpid: can't open /proc/acpi/event: No such file or directory

i download my acpid through mandrake install, and i got a feeling this is a wrong one.

i'm not sure, hopfully i'm at the right path.... but seems like acpid need to compile with kernel. so can't just install like a normal software.

if you use mdk 9.2, mostly it come with acpi, next u gotta do is to figure out what your motherboard support and go through there.

p.s: plz slap the back of my head to the correct direction to solve this problem, if my method and understanding isn't correct.

thanks
 
Old 11-25-2003, 06:45 AM   #7
zedrob
Member
 
Registered: Aug 2003
Location: Italy
Distribution: Gentoo, Fedora, Ubuntu
Posts: 30

Rep: Reputation: 15
Hi Unwrittenlaw
do you have an smp or ht processor?
I got the same problem with an P4 HT processor and I solved it adding into lilo.conf (append section) the string
append="apm=smp ....."
Hope this helps.
Regards
 
Old 11-25-2003, 12:55 PM   #8
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
MDK 9.2 needs more than just removing 'acpi=off', you have to force it with 'acpi=on' or something. When acpid says there is no /proc/acpi/event, it means that mobo doesn't support acpi or it's not enabled from bios, or that the kernel doesn't have acpi and needs to be recompiled (Mandrake shouldn't need this, it probably has it in a module). If you have APM, use it, because it works better in Linux.
 
Old 11-25-2003, 01:11 PM   #9
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Original Poster
Rep: Reputation: 30
even if i found out my motherboard support acpi, and my mdk only got apm, no acpi. am i still able to shut down my computer using apm??

i looked thru all my apm conf, and i have it on append="apm=on apm=power_off" under lilo.conf
doesn't look like i can shut down my box. but i can get it shut down using redhat.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there any way to turn off the computer power without pushing the button? Necronomicom Slackware 11 02-27-2006 04:50 AM
Power button shuts down computer? kaega2 Linux - Software 0 01-08-2004 07:32 PM
power button turns computer off kaega2 Linux - Hardware 8 12-15-2003 09:59 AM
ACPI: shutdown computer by pushing power button... elluva Mandriva 10 12-15-2003 04:57 AM
power off the computer after shut down gary.chan Linux - Software 1 01-05-2003 11:35 AM


All times are GMT -5. The time now is 11:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration