LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-19-2004, 05:45 AM   #1
Mike Healan
Member
 
Registered: May 2004
Distribution: SuSe 10.0
Posts: 31

Rep: Reputation: 15
How do I enable the kernel for HIGHMEM?


I just installed a gig of DDR RAM on Mandrake 10 2.4.25-2mdk. Windows and BIOS both see 1024MB but Mandrake only sees 896MB.

I edited lilo.conf to add "mem=1024M" and that didn't help. I ran dmesg and see an error message saying I need a HIGHMEM enabled kernel in order to use the rest of the RAM.

So..... umm........... I do that how?



[mike@localhost mike]$ dmesg
Linux version 2.4.25-2mdk (nplanel@no.mandrakesoft.com) (gcc version 3.3.2 (Mand
rake Linux 10.0 3.3.2-6mdk)) #1 Tue Mar 2 07:39:08 CET 2004
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000003fff0000 (usable)
BIOS-e820: 000000003fff0000 - 000000003fff8000 (ACPI data)
BIOS-e820: 000000003fff8000 - 0000000040000000 (ACPI NVS)
BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
BIOS-e820: 00000000ffee0000 - 00000000fff00000 (reserved)
BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
user-defined physical RAM map:
user: 0000000000000000 - 000000000009fc00 (usable)
user: 000000000009fc00 - 00000000000a0000 (reserved)
user: 00000000000f0000 - 0000000000100000 (reserved)
user: 0000000000100000 - 000000003fff0000 (usable)
user: 000000003fff0000 - 000000003fff8000 (ACPI data)
user: 000000003fff8000 - 0000000040000000 (ACPI NVS)
user: 00000000fec00000 - 00000000fec01000 (reserved)
user: 00000000fee00000 - 00000000fee01000 (reserved)
user: 00000000ffee0000 - 00000000fff00000 (reserved)
user: 00000000fffc0000 - 0000000100000000 (reserved)
Warning only 896MB will be used.
Use a HIGHMEM enabled kernel.
896MB LOWMEM available.

Last edited by Mike Healan; 05-19-2004 at 05:47 AM.
 
Old 05-19-2004, 06:48 AM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
You compile yourself a new kernel and this time turn on the appropriately labled "HIGHMEMORY SUPPORT"

That's about it?

If you cant find enough posts here explaining how to compile a kernel then your in need of serious help.
 
Old 05-19-2004, 08:52 AM   #3
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
No you don't have to recompile a new kernel. Use the software installer look for the kernel that supports 1 gig of memory or more. Such as kernel-i686-up-4GB-2.4.25.2mdk. If this doesn't work you can add an option to your lilo.conf file to specify the exact am out of memory(The system Ive built with one gig of mem didn't need this option just the new kernel). If it Mandrake you don't have to recompile the kernel every time you want to change hardware.
 
Old 05-19-2004, 09:35 AM   #4
Mike Healan
Member
 
Registered: May 2004
Distribution: SuSe 10.0
Posts: 31

Original Poster
Rep: Reputation: 15
Oh cool. Thanks. I see it in the installer now.

I was running around looking for "How-To"s to recompile. I've only switched from Windows to Linux for about a week, so "recompiling your kernel" sounds like some sort of witchcraft.
 
Old 05-19-2004, 12:18 PM   #5
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
Recompiling a kernel isn't that bad but Ive only had to recompile a kernel once in 4 yrs and that was 2yrs ago.
 
Old 05-19-2004, 12:40 PM   #6
Mike Healan
Member
 
Registered: May 2004
Distribution: SuSe 10.0
Posts: 31

Original Poster
Rep: Reputation: 15
That did it. Installed it and rebooted and it detected most of it. It sees 1008MB instead of 1024, but I'm not gonna argue with it about 16MB.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FGLRX + Highmem - was working before, not a newbie, help needed... cosmyco Linux - Hardware 1 10-06-2005 11:53 AM
Error when recompiling 2.4.31 Kernel for SMP and HIGHMEM mjgould Slackware 15 09-28-2005 04:11 PM
Not all RAM is used - Highmem? Tim Johnson Slackware 6 05-05-2005 08:41 AM
Enable Kernel Modules tr0gd0O0r Linux - General 19 05-03-2004 08:08 AM
kernel recompiled with highmem-- still can't use all 2GB RAM nknowles Linux - General 0 12-04-2003 07:35 PM


All times are GMT -5. The time now is 01:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration