LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   How can I get KDE4 to automount all vfat usb-sticks with the "flush" mount option? (http://www.linuxquestions.org/questions/mandriva-30/how-can-i-get-kde4-to-automount-all-vfat-usb-sticks-with-the-flush-mount-option-782089/)

ssenuta 01-13-2010 10:06 PM

How can I get KDE4 to automount all vfat usb-sticks with the "flush" mount option?
 
My /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi has a "strlist">flush</append> entry under <!-- allow these mount options for vfat -->. However, the "flush" mount option is not being used according to /etc/mtab but it is available.
cat /etc/mtab:
/dev/sdc1 /media/KINGSTON vfat rw,nosuid,nodev,uhelper=hal,uid=500,utf8,shortname=mixed 0 0

mount -o remount,flush /media/KINGSTON
cat /etc/mtab:
/dev/sdc1 /media/KINGSTON vfat rw,nosuid,nodev,uhelper=hal,uid=500,utf8,shortname=mixed,flush 0 0

I am running Mandriva-2009.1, KDE-4.2.2, Kernel-2.6.32-2 & HAL-0.5.12 & read somewhere that KDE allows the mount options to be set only on a per-volume basis, not per-filesystem.
If that is true, maybe it isn't possible to have a "global" flush mount option that would apply to "All" vfat filesystems when using KDE4.

Anyways, if anyone has a good solution or workaround, I'd appreciate hearing from you. Also, is it true that HAL is being replaced by a new device manager called "DeviceKit".??
If so, I hope it can be disabled without disabling "X" like my HAL does. I tried disabling HAL & couldn't even login to KDE4.

Thanks for reading this post.

ssenuta 01-15-2010 12:14 AM

I finally figured out how to force KDE4 to mount all my usb-sticks with the vfat filesystem using the "FLUSH" mount option. All I had to do was create a entry in my /etc/fstab file for the usb-stick & add both the FLUSH & NOAUTO mount options like the following:

/dev/sdc1 /mnt/pendrive vfat rw,noatime,umask=000,utf8,uid=500,shortname=mixed,flush,noauto,users,exec,suid,dev 0 0

Contrary to what I read, KDE4 will still automount this pendrive even though it has a listing in the fstab file. This is probably due to the "NOAUTO" option. I guess KDE4 automount reads mount option from the /etc/fstab & then adds its own mount options if they are missing. There is a system of priorities when it comes to applying mount options.

Here are some problems with this solution:
1.) usb-stick drives (pendrives) that are not formated with the vfat filesystem & are identified as /dev/sdc1 by Linux will not automount.
This is because the FLUSH mount option is only valid with vfat....You will have to manually mount /dev/sdc1 with an ext2/3 filesystem on it.

2.) If you plugin multiple usb-stick drives your vfat usb-stick may not get identified as /dev/sdc1 by Linux & it will not get the FLUSH option.
It will only mount with the regular automount options.

If anyone sees more problems with my workaround feel free to respond.


All times are GMT -5. The time now is 04:29 AM.