LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Help: Moved ide hard drive to different computer and now it won't complete boot (http://www.linuxquestions.org/questions/mandriva-30/help-moved-ide-hard-drive-to-different-computer-and-now-it-wont-complete-boot-672166/)

rbonafied 09-24-2008 08:13 PM

Help: Moved ide hard drive to different computer and now it won't complete boot
 
Hi,

I have Mandriva 2008.1 installed on a 40gig harddrive in a Dell Precision Desktop. Recently I came into possession of an Asus p4s800d without a harddrive. After moving the 40G drive to the Asus, booting won't work.

I get past the Grub menu and select a kernel image. It makes it's way past the initial boot stuff and then displays:

mount: could not find filesystem '/dev/root'
setting up other filesystems.
setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
error mounting /proc
.
.
.
switchroot: mount failed: No such file or directory
Booting has failed.


Thank you!
Rick

rbonafied 09-25-2008 09:03 AM

Hi,

I just wanted to post a few more facts. When booting the system with knoppix I'm able to "see" the drive's partitions just fine. Also, when I tried another older hard drive in the same system it booted off that hard drive just fine. I'm really stumped.

I've tried adjusting bios settings. No change.
I've tried swapping from primary to secondary ide interface. No change.
I've tried fiddling in grub and it's finding /boot just fine. (hd0,0)

Ug :)


All times are GMT -5. The time now is 07:07 AM.