LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 06-16-2007, 05:21 AM   #1
kno712
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Rep: Reputation: 0
hard drive clunk when shutting down


After happily trying ubuntu for some time, I've decided to give a try to some other distro. Mandriva (kde version) looks very good, but I'm having a problem that stops me using it: when I shut down, the drive emits a sort of "bark" when the power turns off, which I can only assume comes from not being shut down previously.

I had the same problem in ubuntu, but I manage to solve it (this thread
https://launchpad.net/ubuntu/+source....17/+bug/67810 )

my concerns are:
- can it lead to problems regarding hardware lifetime ?
- is there a way to get a smoother shutdown process ?
- anyone noticed similar behaviour ?

Thanks a lot

Last edited by kno712; 06-16-2007 at 08:51 AM.
 
Old 06-16-2007, 07:44 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
What is your kernel version? I guess that since 2.6.20, pata drives are treated in the kernel as scsi drives. That may be at the heart of the problem.
 
Old 06-16-2007, 08:47 AM   #3
kno712
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Hi, jschiwal, thanks for your help


It is 2.6.17. My laptop is a Toshiba, with a SATA drive.

Last edited by kno712; 06-16-2007 at 08:48 AM.
 
Old 06-16-2007, 04:48 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Then the sata drivers would be used in any case. Could it some sort of thrashing to various parts of the drive as the disk caches are being emptied out?

It might be instructive looking at the diskparm settings for the drive. As an experiment, try A) running "sync; sync" and B) sudo /sbin/hdparm -f </dev/sd#> before rebooting. The first one will empty the Linux hard disk caches. The second will empty the on drive cache. Do you still hear that sound when shutting down? If so, my guess is probably wrong.

Also look at the output of "sudo /sbin/hdparm -I /dev/<sd#>". Does anything stand out as being wrong. For example, if the current settings are far off from the supported settings, like using udma0 when udma5 is supported.

Is there a package you can install so that you can monitor S.M.A.R.T. messages? Or if smart support is enabled, do you see any problems reading /var/log/messages?

A drive making clicking noise could be an indication that the drive is going bad. You might consider purchasing a commercial program such as GRC's SpinRite. If the drive is going bad, it may be trying to park at a location that it can't find, or relocating an excessive number of blocks before shutting down.
 
Old 06-16-2007, 06:57 PM   #5
kno712
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks a lot for your help. I really want Mandriva to give a try.

The laptop is new (only 6 months); of course it still could be a faulty drive, but I manage to solve it in Ubuntu, following the instructions that I found here so I think it is more likely to be a linux problem (windows has a gently shutdown as well)

I tried to apply the same solution in Mandriva, but they did not work.

The instructions in the above link are as follows:

write a file at "/etc/rc0.d/S00hdd-shutdown-workaround" which includes this two lines:

#!/bin/sh
echo 1 > /sys/class/scsi_disk/0\:0\:0\:0/stop_on_shutdown

then make it executable ("chmod +x filename")

Last edited by kno712; 06-16-2007 at 07:01 PM.
 
Old 06-17-2007, 02:29 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Look in:
ls /sys/class/scsi_disk/0\:0\:0\:0/
and see if stop_on_shutdown exists. Your kernel may not have the patch.

http://www.nabble.com/-PATCH--sd:-im...-t3040866.html
 
Old 06-25-2007, 01:59 PM   #7
kno712
LQ Newbie
 
Registered: Aug 2006
Posts: 4

Original Poster
Rep: Reputation: 0
hi, there. I've been on holidays for the last week. I'll check if stop_on_shutdown exists... and if not, how can find a solution? will a kernel upgrade solve the problem? how can I upgrade the kernel?
 
  


Reply

Tags
harddrive, noise, shutdown


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Copy Fedora 5 Hard Drive to another Hard Drive Using Knoppix 5.1.1 lud477 Linux - Software 2 03-17-2007 05:06 PM
Copying files from internal Hard drive to USB 2.0 Hard Drive is NOT Behaving tubatodd Ubuntu 4 02-19-2007 04:32 PM
Installing grub to external USB hard drive for later use as internal hard drive dhave Linux From Scratch 2 12-10-2005 08:48 AM
Grub to access new hard drive and old multi os hard drive ? gedi1 Linux - Hardware 0 06-03-2004 12:01 PM
Shutting off hard drive ebh1 Linux - Hardware 2 10-02-2003 08:36 PM


All times are GMT -5. The time now is 01:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration