LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 01-30-2004, 11:23 PM   #1
lynnsbomb
LQ Newbie
 
Registered: Jan 2004
Location: lynn massachusetts
Distribution: kubuntu
Posts: 17

Rep: Reputation: 0
grub bootloader : saving a new configuration file?


That bug is listed on their errata mandrakelinux dot com/en/errata.php3


Error scenario: CD-RW devices are listed seven times (sr0 through sr6) by the kernel.
Why: A bug in the kernel lists CD-RW devices causes this problem; it has no effect on the useability of the device.
Solution: Modify the kernel options used in your boot loader and append "hdclun=0" if /dev/hdc is your CD-RW device (use "hdXlun=0" for /dev/hdX).


i added this hdclun=0 to my /boot/grub/menu/lst file ... so that each different bootup style has a notation of it
ex:

title linux-smp
kernel (hd0,4)/boot/vmlinuz-smp root=/dev/hda5 devfs=mount hdc=ide-scsi
hdclun=0
acpi=ht splash=silent
initrd (hd0,4)/boot/initrd-smp.img


i edited the file as root and saved changes my question is there anything i have to do to get the changes to take affect.... i rebooted and nothing changed so im not sure its taken yet.... please help
 
Old 02-02-2004, 06:44 PM   #2
teval
Member
 
Registered: Jul 2003
Location: Toronto, Canada
Distribution: Gentoo
Posts: 720

Rep: Reputation: 30
Put them all in 1 line

kernel (hd0,4)/boot/vmlinuz-smp root=/dev/hda5 devfs=mount hdc=ide-scsi
hdclun=0
acpi=ht splash=silent


No nother else should matter.
You won't see changes in the menu itself if that's what you're asking about.
 
Old 02-02-2004, 09:01 PM   #3
lynnsbomb
LQ Newbie
 
Registered: Jan 2004
Location: lynn massachusetts
Distribution: kubuntu
Posts: 17

Original Poster
Rep: Reputation: 0
same thing happens

After I made that change to menu.lst I rebooted and still get the same response.. It shows trying to mount cdrom1 - cdrom6 and i dont have them... I umounted the cdrom's and removed the directorys and when i reboot it still shows the system trying to load the cdroms i dont have and it errors out because the directorys dont exist. If anyone knows something i need to do please let me know
 
Old 02-03-2004, 04:10 PM   #4
teval
Member
 
Registered: Jul 2003
Location: Toronto, Canada
Distribution: Gentoo
Posts: 720

Rep: Reputation: 30
Just get the newest 2.6 kernel. I'm positive this bug has been fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Saving Alsa Configuration Permaximus Slackware 2 11-17-2005 08:24 PM
How can I disable the grub bootloader and enable the lilo bootloader? abefroman Linux - General 1 08-06-2005 08:53 AM
Grub configuration file Buruma Linux - Newbie 10 06-20-2005 09:29 PM
Where to find the GRUB configuration script file? piggysmile Red Hat 2 10-09-2004 03:15 PM
How to change the GRUB configuration file with kernel 2.6.7 Bassam Linux - Software 2 06-22-2004 02:44 AM


All times are GMT -5. The time now is 10:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration