LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 04-11-2005, 03:52 PM   #1
landroni
Member
 
Registered: Feb 2005
Distribution: Xubuntu 12.04 LTS
Posts: 150

Rep: Reputation: 15
failure installing libSDL


I cannot install libSDL. Getting the following error message.

Installation failed:
file /usr/lib/libSDL-1.2.so.0 from install of SDL-1.2.8-1 conflicts with file from package libSDL1.2-1.2.7-9mdk

I do not know what should be the code to attempt an upgrade. In fact I cannot make trigger work, nor practiclly any other game on Linux.

Well, now i get the following error.
file /usr/lib/libSDL-1.2.so.0.7.1 from install of SDL-1.2.8-1 conflicts with file from package libSDL1.2-1.2.8-3mdk

and
configure: error: Please install libsdl >= 1.2.5

when installing trigger. I am already tired of this, because when i try
rpm -q libSDL1.2-1.2.7-9mdk.i586.rpm

i get
package libSDL1.2-1.2.7-9mdk.i586.rpm is not installed

and when
rpm -q libSDL1.2-1.2.8-3mdk.i586

i get
libSDL1.2-1.2.8-3mdk

hmm. This means that libSDL1.2-1.2.8-3mdk is installed, but then why does it require libSDL 1.2.5? I cannot find the rpm for Mandrake or source for libSDL 1.2.5. Well, i'm lost.
 
Old 04-11-2005, 07:31 PM   #2
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 45
I'm assuming that you have setup your Urpmi sources correctly judging from your other posts to the forums. I also see that you have started a new thread for the same problem. It's not helpful to do this as those trying to help need to know what you have tried and what you haven't as sometimes it may not be possible to give a one reply answer. I'm not trying to annoy you, just thought you might like to know for the future.

As for your rpm problem, are you able to uninstall the orginal libSDL rpm? What happens when you try:
Code:
urpmq libSDL
Are you able to work out which versions of libSDL are available to install? Also, I assume that to install libSDL you have used
Code:
urpmi libSDL
as root?

Your problem does not sound impossible to solve, just a bit of a dependancy nightmare. I'm sure we can get this working.
 
Old 04-12-2005, 03:31 PM   #3
landroni
Member
 
Registered: Feb 2005
Distribution: Xubuntu 12.04 LTS
Posts: 150

Original Poster
Rep: Reputation: 15
CragStar, first of all thank you for trying to help. I agree that it was not nice to start a new thread. It is just that i have noticed that on several occasions, when it was considered that the answer was answered and it was not, there were no other persons to try to answer. While on a new thread the answer comes. I will try not to do it in the future, at least not in a short period of time.

I am on a MDK 10.1 Official Edition. My two big problems on this are: Internet Connection and Installing.
Internet Connection: only Opera works as I need to use a proxy server that requires authentification (ie username and password). This is why i cannot use easy urpmi (at least i believe this is the cause).
Installing: i managed to install several sources and rpms (finally i fiugured out how it works ). Others, like expat-1.95.8, libSDL, openal-0.0.7-1mdk.src.rpm do not want to get installed. The rpmdrake does not work properly. When chosing Update media and chosing the CD1 (all are by default not chosen, including ), i get the following error: "Unable to update medium; it will be automatically disabled. Errors: unable to access the medium "Installation CD1 (x86) (cdrom1). This could happen if you mounted manually the directory when creating the medium". When trying to enable plf-free (i believe this is the easy urpmi), i am also getting an error (impossible to retrieve the list of new packages).

I did not uninstall the original libSDL because there are too many programs dependent on it.

rpm -ve libSDL1.2-1.2.8-3mdk.i586
error: Failed dependencies:
libSDL-1.2.so.0 is needed by (installed) libSDL_net1.2-1.2.5-3mdk
libSDL-1.2.so.0 is needed by (installed) libSDL_image1.2-1.2.3-3mdk
libSDL-1.2.so.0 is needed by (installed) piave-0.2.3-9mdk
libSDL-1.2.so.0 is needed by (installed) libdirectfb0.9_20-0.9.20-2mdk
libSDL-1.2.so.0 is needed by (installed) xine-plugins-1-0.rc5.8mdk
libSDL-1.2.so.0 is needed by (installed) supertux-0.1.2-1mdk
libSDL-1.2.so.0 is needed by (installed) lbreakout2-2.5-2mdk
libSDL-1.2.so.0 is needed by (installed) libsmpeg0.4-0.4.4-24mdk
libSDL-1.2.so.0 is needed by (installed) chromium-0.9.12-23mdk
libSDL-1.2.so.0 is needed by (installed) libSDL_mixer1.2-1.2.5-4mdk
libSDL-1.2.so.0 is needed by (installed) gnomemeeting-1.0.2-12mdk
libSDL-1.2.so.0 is needed by (installed) csmash-0.6.6-4mdk
libSDL-1.2.so.0 is needed by (installed) crack-attack-1.1.10-10mdk
libSDL-1.2.so.0 is needed by (installed) perl-SDL-1.20.0-10mdk
libSDL-1.2.so.0 is needed by (installed) frozen-bubble-1.0.0-6mdk
libSDL-1.2.so.0 is needed by (installed) armagetron-0.2.6.0-3mdk
libSDL-1.2.so.0 is needed by (installed) libSDL_ttf2.0-2.0.6-4mdk
libSDL-1.2.so.0 is needed by (installed) libSDL_gfx11-2.0.11-3mdk
libSDL-1.2.so.0 is needed by (installed) libopenal0-0.0.7-1mdk

When trying urpmq libSDL, i get the following:
The following packages contain libSDL:
libSDL1.2
libSDL1.2-devel
libSDL_gfx10
libSDL_gfx10-devel
libSDL_gfx10-static-devel
libSDL_image1.2
libSDL_image1.2-devel
libSDL_image1.2-test
libSDL_mixer1.2
libSDL_mixer1.2-devel
libSDL_net1.2
libSDL_net1.2-devel
libSDL_ttf2.0
libSDL_ttf2.0-devel
libSDL_ttf2.0-test

I was not able to work out which versions of libSDL are available to install.
Initially libSDL was installed by MDK 10.1 (my guess). Then i tried to upgrade it using sources or rpms from the net, and the result is already known.

When trying urpmi libSDL, i get:
Everything already installed
or
urpmi database locked

These are two consecutive (in matter of seconds it changed the message) messages that i cannot explain.

Well, i believe this is more than you wanted to see . Hope to hear from you soon
 
Old 05-03-2005, 01:51 PM   #4
alcibiades
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Rep: Reputation: 0
I have a similar maybe related problem. I am trying to install WXpython. It fails because of missing libSDL. I use the uninstaller in Mandrake, and like the previous poster, find too much depends on it. I then go into the command line and try to replace it using rpm, and am told it doesn't exist. If I do 'find' it also shows file not found. I rebuild the rpm database, nothing changes. I now try to install it, and am told it already is installed. If I check on what has been installed recently using -qa --last, there it is. So I cut and paste the name, and try to replacepkgs, but this also fails saying the file doesn't exist.

Obviously something has gone wrong between what is actually in /lib and what the rpm database thinks is there. But if rebuild doesn't work, how to fix it?

Al
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
libSDL installation failure landroni Mandriva 2 04-09-2005 03:43 PM
libsdl vs libsdl-devel Micro420 Linux - Software 3 01-13-2005 12:19 PM
Installing ZSNES and a libSDL problem.! HELP! toolfan Linux - Software 2 05-24-2004 06:03 AM
Failure Installing Bootloader jatkins35 Mandriva 1 02-26-2004 04:18 AM
installing eth0 failure xcdweller Linux - Software 2 10-04-2001 11:00 PM


All times are GMT -5. The time now is 08:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration