LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 01-13-2004, 06:26 PM   #1
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
failed install lilo during install process


hi, here's story in short: 2 hds, first got xp, second got slack 9.1 w/ lilo installed in MBR. i decided to remove slack, and put mdk back on. here's the steps that i took:

1) insert win98 startup disk (this is xp machine btw!) started computer, and i typed: fdisk /mbr
2) restart computer w/ mdk disc in cdrom
3) follow the process of install until to the point of conf lilo.


error:
lilo failed:Can't read hda::Output/input

right there... i couldn't move forward, so i had to complete the installation anyway, what i did was went to "installation summary" and take care the rest of the little work such as DSL, user acct, etc.


now when i start my computer, it goes to xp, without going to lilo (or linux)

plz adv how can i wipe out slack's lilo and put mdk lilo? thanks
 
Old 01-13-2004, 08:05 PM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Have you got a lilo.conf file in /etc/ ??

If so - boot from the 1st Mandrake cd

press F1

type rescue

and re-install LILO to the MBR of the "1st" hard drive.

Last edited by Skyline; 01-13-2004 at 08:06 PM.
 
Old 01-13-2004, 08:48 PM   #3
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Original Poster
Rep: Reputation: 30
thanks skyline, i will try that tonight after work
 
Old 01-14-2004, 01:37 AM   #4
di11rod
Member
 
Registered: Jan 2004
Location: Austin, TEXAS
Distribution: CentOS 6.5
Posts: 207

Rep: Reputation: 32
removing slack entry in LILO

When you have booted off the Mandrake CD as the other poster suggested, be sure to mount your hard drives before going to <console> in the rescue menu.

Also, you can hand-edit the /etc/lilo.conf file to alter what options you have listed. You can totally remove the slackware entry if you like.

good luck.

di11rod
 
Old 01-15-2004, 12:23 AM   #5
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Original Poster
Rep: Reputation: 30
thanks guys, using mdk cd1 w/ rescue option, then choosing reload boot loader did the trick heheh.


1 more thing, say if i wanna install slack on my hdb (i have xp on hda, mdk on hdb,) am i gonna keep using mdk's lilo? or will i have to use slack's? or it really doesn't matter?

thanks
 
Old 01-15-2004, 12:51 AM   #6
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Just use "Mandrake's" lilo.conf for both - ie when installing Slackware, don't install a LILO bootloader from Slack (ie choose to skip) - then when you reboot after installing Slack, go into Mandrake and create a mount point for Slack's partition which contains the Slack kernel (typically the Root partition)

mkdir /mnt/slackware

then mount the partition into this mount point in Mandrake:

mount -t ext3 -o ro /dev/hda6 /mnt/slackware

then put an entry into Mandrake's lilo.conf file for Slackware - it'll be similar to this (using a mount point of /mnt/slackware and having mounted Slack's Root partition into it in Mandrake) - (I've got Slack on /dev/hda6 - obviously substitue yours in)

image=/mnt/slackware/boot/vmlinuz
label="Slackware9.1"
root=/dev/hda6
append="devfs=mount hdc=ide-scsi acpi=off quiet"
read-only

then type

/sbin/lilo

to re-install lilo and the new map file,

then reboot and choose whichever OS you want.

Last edited by Skyline; 01-15-2004 at 12:58 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo failed to install? MDesigner Slackware - Installation 6 02-23-2005 03:08 PM
Lilo install failed gmartin Slackware - Installation 6 02-01-2005 09:56 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 05:00 PM
Netscape install failed how can remove old file and install again? nuwanguy Linux - Software 3 09-10-2003 07:33 AM
I install Slackware on small HDD with LILO, can't boot LILO? kleptophobiac Slackware 4 08-10-2003 04:50 PM


All times are GMT -5. The time now is 04:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration