LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 06-10-2007, 05:33 AM   #1
rm_-rf_windows
Member
 
Registered: Jun 2007
Location: Europe
Distribution: Ubuntu
Posts: 204

Rep: Reputation: 23
Error message when launching volume control - no volume


I'm on Mandriva 2007.0 ('2007 Free'). There are several user accounts, and on one of them we get no sound. When I open the volume control, I get an error message (in French), here it is:
Quote:
Une erreur est survenue lors du chargement ou de l'enregistrement des informations de configuration de gnome-volume-control. Certains de vos paramètres de configuration ne fonctionneront peut-être pas correctement.
Quote:
Rough translation: "An error occured when loading or saving gnome-volume-control configuration information. Certain configuration parameters might not work properly."
I get the same message when trying to launch the 'Volume monitor' (or Vu-meter?)(again, this is a translation from the French), however, here there are two with two pop-up window warnings. The second one says the following:
Quote:
(translation) "Impossible to connect to the sound daemon. Please launch esd from a command line."
I've done that, I hear a few beeps, but still get no sound when opening multimedia files or logging on (there's usually a short snippet of music immediately when logging on).

The sound works fine on other user accounts. Any idea why I'm getting these messages and why there is no sound on the one user account?

Many thanks.
 
Old 06-10-2007, 05:58 AM   #2
stzein
Member
 
Registered: Mar 2004
Location: Antwerp, Belgium
Distribution: Gentoo
Posts: 65

Rep: Reputation: 15
I'm guessing something went wrong with that user's config file. Maybe the rights were reset or something like that?
those personal config files are usually located in /home/{username}/.{program_name} . this is a hidden directory, you can list them with
Code:
ls -al ~/.*
I think you're looking for a directory called .gnome, but I don't run gnome myself, so I can't really check it.

If you find something that looks relevant you could try to remove it, and probably a new configuration will be made automatically next time you log on. Actually, best to move it to a backup location. Something like this:
Code:
mv ~/.gnome ~/.gnomebackup
(You might have to replace 'gnome' with the actual directory on your system.)

EDIT: Please be aware that that last command will remove ALL of the user's gnome settings. you will have a backup though.

Another thing you can check is the gnome-command-center. Type this in or find the corresponding icon in your gnome menu.

Last edited by stzein; 06-10-2007 at 06:03 AM.
 
Old 06-12-2007, 12:10 AM   #3
rm_-rf_windows
Member
 
Registered: Jun 2007
Location: Europe
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 23
I'm not using GNOME, I'm using KDE, which is the default in Mandriva.

Here's what's in my home directory (and the .kde directory at the end):
Code:
[linux@localhost ~]$ ls -a
./                         .gconf/             .net_monitorrc*
../                        .gconfd/            .ooo-2.0/
.amsn/                     .gimp-2.3/          .qt/
amsn_received/             .gnome2/            .realplayerrc
.bash_history              .gnome2_private/    .recently-used
.bash_logout               .gstreamer-0.10/    .rpmdrake
.bash_profile              .gtk-bookmarks      .screenrc
.bashrc                    .ICEauthority       .swp
.config/                   Images/             Téléchargement/
.crack-attack/             .kde/               .thumbnails/
.DCOPserver_localhost__0   .lesshst            tmp/
.DCOPserver_localhost_:0@  lindata/            Vidéo/
.DCOPserver_localhost__1   .local/             .viminfo
.DCOPserver_localhost_:1@  .macromedia/        .vlc/
Desktop/                   .mailcap            windata/
.dmrc                      .mcop/              .Xauthority
Documents/                 .mdk-folders/       .xcdroast/
.esd_auth                  .mdk-menu-migrated  .xine/
.fbhighlevelshistory       .MdkOnline/         .xsession-errors
.fbhighscores              .mozilla/           .xsession-errors-:1
.fbrc                      .mplayer/
.fontconfig/               Musique/
[linux@localhost ~]$ cd .kde
[linux@localhost .kde]$ ls
Autostart/        DESKTOP_ENTRY/  share/     socket-localhost@
cache-localhost@  env/            shutdown/  tmp-localhost@
[linux@localhost .kde]$
Any idea where sound would be? For the time being, I get no sound whatsoever...

Ah! Strange... I just realized that the error message I get talks about the GNOME sound manager and not the KDE one! Why might that be?

When I try and launch AuMix, it tries and then times out. I get no sound whatsoever. I've tried with other links and programs like VLC...
 
Old 06-12-2007, 02:50 AM   #4
stzein
Member
 
Registered: Mar 2004
Location: Antwerp, Belgium
Distribution: Gentoo
Posts: 65

Rep: Reputation: 15
It's a long time ago that I used Mandriva (Mandrake at the time), so I don't really know how it's set up. You do have a .gnome2 directory in your home directory though, so I suspect it's possible they use gnome parts for their sound. I think there should be a file ~/.gnome2/gnome-volume-control. Maybe you could try to copy one from another user (overwriting the one you have). Just make sure that you reset the rights for the copied file. ("chmod 770 ~/.gnome2/gnome-volume-control" should work).
If that doesn't work, you could still try you deleting (moving) the whole directory.

Now that I think about it; you could check
Code:
ls -al ~/.gnome2
judging from the error you got maybe the rights are just wrong. Or otherwise your user is not in the group required to use sound (probably the group "sound" ). You can check this by typing "groups" while logged in with that user.
 
Old 06-21-2007, 12:13 AM   #5
rm_-rf_windows
Member
 
Registered: Jun 2007
Location: Europe
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 23
Here's the contents of my /home/linux/.gnome2/gnome-volume-control file:
Code:
[Placement]
Dock=Menubar\\0,0,0,0
gnome-volume-control lines 1-3/3 (END)
'linux' is the user having problems, 'xxxx' is a normal user whose sound is working okay:
Code:
[root@localhost linux]# cd /home/linux
[root@localhost linux]# ls -a
./                         Documents/            .lesshst            .recently-used
../                        .esd_auth             lindata/            .rpmdrake
.amsn/                     .fbhighlevelshistory  .local/             .screenrc
amsn_received/             .fbhighscores         .macromedia/        .swp
.bash_history              .fbrc                 .mailcap            Téléchargement/
.bash_logout               .fontconfig/          .mcop/              .thumbnails/
.bash_profile              .gconf/               .mdk-folders/       tmp/
.bashrc                    .gconfd/              .mdk-menu-migrated  Vidéo/
.config/                   .gimp-2.3/            .MdkOnline/         .viminfo
.crack-attack/             .gnome2/              .mozilla/           .vlc/
.DCOPserver_localhost__0   .gnome2_private/      .mplayer/           windata/
.DCOPserver_localhost_:0@  .gstreamer-0.10/      Musique/            .Xauthority
.DCOPserver_localhost__1   .gtk-bookmarks        .net_monitorrc*     .xcdroast/
.DCOPserver_localhost_:1@  .ICEauthority         .ooo-2.0/           .xine/
Desktop/                   Images/               .qt/                .xsession-errors
.dmrc                      .kde/                 .realplayerrc       .xsession-errors-:1
[root@localhost linux]# cd .gnome2/
[root@localhost .gnome2]# ls
accels/  epiphany/  gcdmaster  gnometris.d/  gnome-volume-control  totem  totem_config
[root@localhost .gnome2]# cd
[root@localhost ~]# cd /home/xxxx
[root@localhost vero]# ls -a
./             Desktop/          .gtk-bookmarks  .mcop/              .qt/             .Xauthority
../            .dmrc             .ICEauthority   .mdk-folders/       .recently-used   .xine/
.bash_history  Documents/        Images/         .mdk-menu-migrated  .screenrc        .xsession-errors
.bash_logout   .gconf/           .kde/           .MdkOnline/         Téléchargement/
.bash_profile  .gconfd/          .lesshst        .mozilla/           .thumbnails/
.bashrc        .gnome2/          .local/         Musique/            tmp/
.config/       .gnome2_private/  .macromedia/    .ooo-2.0/           Vidéo/
[root@localhost vero]# cd .gnome2/
[root@localhost .gnome2]# ls
accels/
[root@localhost .gnome2]# cd accels/
[root@localhost accels]# ls
[root@localhost accels]# cd /home/linux/.gnome2/
[root@localhost .gnome2]# ls
accels/  epiphany/  gcdmaster  gnometris.d/  gnome-volume-control  totem  totem_config
[root@localhost .gnome2]# cd accels
[root@localhost accels]# ls
epiphany  gnometris  gnome-volume-control
[root@localhost accels]# ls -a
./  ../  epiphany  gnometris  gnome-volume-control
[root@localhost accels]# ls -l
total 8
-rw-r--r-- 1 linux linux 5445 jun 12 07:17 epiphany
-rw-r--r-- 1 linux linux  789 jun  8 07:45 gnometris
-rw-r--r-- 1 linux linux  888 jun 21 06:53 gnome-volume-control
[root@localhost accels]#
This is what's in that last gnome-volume-control file (in the accels directory):
Code:
; gnome-volume-control GtkAccelMap rc-file         -*- scheme -*-
; this file is an automated accelerator map dump
;
; (gtk_accel_path "<gnome-volume-control>/_Aide/\303\200 _propos" "")
; (gtk_accel_path "<gnome-volume-control>/\303\211_dition/_Pr\303\251f\303\251rences" "")
; (gtk_accel_path "<gnome-volume-control>/_Fichier/_Quitter" "<Control>q")
; (gtk_accel_path "<gnome-volume-control>/_Fichier/_Changer le p\303\251riph\303\251rique/_2: Realtek ALC650F (
OSS Mixer)" "")
; (gtk_accel_path "<gnome-volume-control>/_Fichier/_Changer le p\303\251riph\303\251rique/_0: NVidia nForce2 (A
lsa mixer)" "")
; (gtk_accel_path "<gnome-volume-control>/help-contents-item" "F1")
; (gtk_accel_path "<gnome-volume-control>/_Fichier/_Changer le p\303\251riph\303\251rique/_1: Camera (Alsa mixe
r)" "")
; (gtk_accel_path "<gnome-volume-control>/_Fichier/_Changer le p\303\251riph\303\251rique" "")
I haven't a clue as to what all of this means...
 
Old 06-21-2007, 10:15 AM   #6
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
In the event the cart has been put before the horse, it may help to check some basic things. You say you are using the KDE desktop. It may help to confirm that sound is enabled in KDE:

Open the KDE Control Center (System > Configuration > Control Center in the Mandriva menu system).

Navigate to Sound and Multimedia > Sound System in the Category tree (left).

Enable the Sound System should have a check mark in the check box (top).

Other settings are optional. In the Skip Prevention section, Run with the highest possible priority (realtime priority) is enabled on my system as is Auto-Suspend if idle (set to 60 seconds).

In the Hardware tab, Select the audio device is set to auto-detect

Another thing you may want to try is to run the KDE volume control (Multimedia > Sound > Kmix in the menu system). If either the pcm or master volume are set to zero, you will hear no sound. When you start Kmix, you may get a speaker icon in kickker near the system clock. If you do, when you click on the speaker, you should get a simple volume control with a Mixer button. Clicking the Mixer button opens the KDE sound mixer applet.

I am not sure if any of this will prove useful, but it will not hurt to check.

HTH,

Last edited by ernie; 06-21-2007 at 10:16 AM.
 
Old 06-25-2007, 10:54 PM   #7
rm_-rf_windows
Member
 
Registered: Jun 2007
Location: Europe
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 23
Thank you so much ernie! Not everything is fixed, but I was able to get sound, and that's the important thing.

It was simply ticking the 'Enable the Sound System' button that made everything work. However, I still have a problem, I cannot control the volume level of the computer and I still get the same error messages posted in Post #1. It's not a problem when I'm using VLC or RealPlayer because I can adjust the volume using their interfaces, however, when the computer makes sounds (that accompany error messages or what have you...) I cannot control the volume, which seems to be at maximum level and quite distorted. I tried "urpmi gnome-volume-manager," but all I get is "packages already installed"...

My kernel is acting strangely too. When I boot, it asks me whether I want to use 'default' or 'default.backup' configuration files and when in verbose mode (during boot, in French), none of the accents work and I get strange series of characters... That in itself is not a problem, however it isn't very reassuring either. Not only would I like to get everything working, however, 'form' is important to me too. I'm trying to learn good system administration practices... Do you or does anybody else have any ideas on how I could fix all of this up?

Thanks for the solution to the volume problem. By the way, was there a way of activating the sound by modifying some code in a configuration file? If so, do you know where that file might be?

Many thanks once again.
 
Old 06-26-2007, 12:13 AM   #8
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
Quote:
By the way, was there a way of activating the sound by modifying some code in a configuration file? If so, do you know where that file might be?
There is a configuration file that is modified by the change I had you make, but I do not know which file it is (I never felt the need to know).

You can control the system sound with the KDE volume control (Multimedia > Sound > Kmix in the menu system). Kmix may put an icon near the system clock. To get the volume control click the icon. Then you can adjust the main volume level. Click the Mixer button in the volume control to access the KDE sound mixer.

To configure all aspects of the system sounds:

Open the KDE Control Center (System > Configuration > Control Center in the Mandriva menu system).

Navigate to Sound and Multimedia > System Notifications in the Category tree (left).

I am using KDE 3.5.7 from sos, so my set up may vary from yours, but I have a Player Settings button (bottom right). Click it to set the system sounds volume.

Most of KDE can be configured from the Control Center. Take a little time to look around and become familiar with what is there. If you become familiar with KCC (the KDE Control Center) and MCC (the Mandriva Control Center aka Configure your computer), you will have access to most (if not all) of your systems configuration. I think one of the greatest things about Linux is that the configuration is not hidden from you. There are no intentionally undocumented features or secrets. Open Source Software is about freedom unlike proprietary software. Enjoy your use of Mandriva, and welcome aboard. If there is any thing else I can help with, I will be happy to try.

HTH,
 
Old 06-26-2007, 12:51 AM   #9
rm_-rf_windows
Member
 
Registered: Jun 2007
Location: Europe
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 23
Many thanks for the prompt reply ernie...

Yeah, I'd forgotten to mention that I had already tried the kmix thing. Strangely enough, I tried it again just now and it worked this time round!!

I have had a look at all of the system menus and windows and I must admit, Mandriva is pretty d*mn user friendly! I'd recommend it to people who aren't really into computers but would like to try an alternative OS... - definitely - however, I'm also very interested in configuration files and learning more about commands, scripts, etc... and that's why I'd asked all of those questions.

I was able to set the default volume to 50%, thanks for that piece of info too!

I still don't understand why I'm getting those error messages when trying to use the volume control and volume monitor. Oh well!

Many thanks for your good, simple advice!
 
Old 06-26-2007, 12:17 PM   #10
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
Quote:
I still don't understand why I'm getting those error messages when trying to use the volume control and volume monitor. Oh well!
Which Volume Control and Volume monitor?

Specifically what are the errors you get?

If you post the errors, maybe we can work out why you get them.

The majority of your system configuration files reside in the /etc directory or one of its sub-directories. On my system there is a file named /etc/asound.state that appears to store the various volume settings here. It may not be the same on your system, but perhaps it will provide a starting place.

HTH,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
volume control marsques Linux - Software 4 11-19-2006 07:05 AM
my volume control showin error dhanju Linux - Hardware 1 01-18-2006 08:34 AM
volume control bruse Linux - Newbie 3 04-21-2005 03:40 PM
volume control pantspi Debian 1 06-07-2004 04:55 AM
No volume control dhbiker Slackware 3 02-20-2004 09:56 AM


All times are GMT -5. The time now is 01:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration