LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-16-2005, 10:48 AM   #1
tahiche
LQ Newbie
 
Registered: May 2005
Posts: 11

Rep: Reputation: 0
Error: checking for glib-2.0 >= 2.6.0


hi guys and gals

I have just tried to install "bluefish 1.0.1" but need to update my gtk to gtk-2.6.7, which I did but this one asked me to update my glib to glib-2.6.4 which I also did but still no joy.

this is my final error message and I am no nearer to having my bluefish 1.0.1 which is all I want...

Quote:
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0... Requested 'glib-2.0 >= 2.6.0' but version of GLib is 2.4.6

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
I am running Mandrake 10.0

Any help would be greatly appreciated.

tahiche
 
Old 05-16-2005, 10:56 AM   #2
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 66
Moved: This thread is more suitable in Linux - Distributions / Mandriva and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 05-30-2005, 08:53 AM   #3
Galbus
LQ Newbie
 
Registered: May 2005
Location: Leeds
Distribution: Mandriva 10.1
Posts: 9

Rep: Reputation: 0
I have exactly the same error message as tahiche mentions above.

Quote:
Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) not met
I've just migrated over to linux and don't really know what to do, as I thought things like glib would already be installed with the Mandriva installation, as it is meant to run 'out of the box'.

Can anyone help?
 
Old 05-30-2005, 12:33 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
if you compiled it yourself, it would be in /usr/local whilst the scripts are looking for the packages in /usr. You could "make uninstall" and then reconfigure to install int the /usr prefix. Alternatively you may need to do,
Code:
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig
before running the bluefish installation.
 
Old 06-03-2005, 03:41 AM   #5
ron_hickson
LQ Newbie
 
Registered: Aug 2003
Location: Isle of Man
Distribution: Mandrake 2008-0
Posts: 23

Rep: Reputation: 15
Trying to install gimp-print-5.0.0-beta2, I get the following when installing gtk

checking for GLIB - version >= 2.4.0...
*** 'pkg-config --modversion glib-2.0' returned 2.4.6, but GLIB (2.6.2)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.4.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.

I've tried setting the PKG_CONFIG_PATH and also editing /etc/ld.so.conf, putting /usr/local/lib, /usr/local/lib/pkgconfig, /usr/lib/pkgconfig and /usr/lib - but no change.

Any ideas anybody?

Ron
 
Old 06-03-2005, 03:43 AM   #6
ron_hickson
LQ Newbie
 
Registered: Aug 2003
Location: Isle of Man
Distribution: Mandrake 2008-0
Posts: 23

Rep: Reputation: 15
Sorry - should have said my distribution is Mandrake 10.1, not 9.2 and I've also installed and uninstalled various versions of glib and gtk
 
Old 06-08-2005, 10:53 PM   #7
aniljacob
LQ Newbie
 
Registered: May 2005
Location: india
Distribution: debian
Posts: 10

Rep: Reputation: 0
hi ron ,
This is the problem with your library destinationss ..You just try
LD_LIBRARY_PATH=/usr/local
export LD_LIBRARY_PATH


if you have installed your glib in that directory and check it out once again ..
 
Old 06-09-2005, 02:06 PM   #8
ron_hickson
LQ Newbie
 
Registered: Aug 2003
Location: Isle of Man
Distribution: Mandrake 2008-0
Posts: 23

Rep: Reputation: 15
Thanks Anil

I'd actually managed to instal gimp-print, but not as a plug-in to gimp2. Following your advice I put in /usr/lib and /usr/local/lib for good measure and it completed all stages, apparently installing as a plug-in to gimp2. But when I open gimp2, there's no longer a printing facility.

Strange, really, because I've had it working as a plug-in before.

I'm not too worried, because I can print, using xpp, from Vuescan, which has some colour management. Gimp doesn't as yet.

Thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
checking for GLIB - version >= 2.4.0... no guarriman Fedora 1 07-19-2005 03:53 AM
checking for X...configure:error dumbsheep Linux - Newbie 4 02-01-2005 02:21 PM
checking for qt... error. ilubtofart Linux - Newbie 3 07-22-2004 10:31 PM
partition checking error lzyking Linux - Software 6 02-23-2003 06:05 PM


All times are GMT -5. The time now is 07:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration