LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Error before install (2010 powerpack) (http://www.linuxquestions.org/questions/mandriva-30/error-before-install-2010-powerpack-788583/)

MidniteHex 02-11-2010 09:15 PM

Error before install (2010 powerpack)
 
DVD was burned at 4x but burned from a friend so I can't just burn again to test.

I boot from the DVD, choose install option, and a few seconds later it gives me the "Fatal error finishing initialization", exited abnormally. Here are a few more error tidbits I looked at:

"found mandriva cd/dvd bla bla
opening /proc/splash failed
fopen bla bla failed
opening /proc/splash failed"

In the kernal menu, it gave me the strange "buffer i/o error on device sr0, logical block 2246134"

So that's it. My dvd writer is primo and I can't see it being that under any circumstances. Is it most likely a bad burn or just something in this distro release? OpenSuse would not load to X when I installed about 8 months or so ago, but it was probably some mundane detail, and it at least installed. My system specs are 2g ram, ATI 4850hd 512mb, 300g hd, amd 7750 black dual core.

Just a quick answer will do. Has anyone experienced this with Mandriva or any other distro? A few detailed google search says yes but nothing of use I could find.

GlennsPref 02-23-2010 02:42 AM

Hi, you might try the md5sum check to see if you have the whole dvd.

You could also try commands for the kernel at boot, even for the install dvd.

Can't recall the key now, maybe F3? or F2.

enter this at the end of the line, leave a space between the last command and these new ones.

nomsi noapic

see how you go, regards Glenn

pizzelle 08-07-2010 03:02 AM

This looks like an older thread, but I just tried installing Mandriva 2010 spring and had the same result. Ubuntu likewise fails.
My machine is a simple PC with a single DVD player and a single IDE disk. No scsi, no USB.

It's hard to say I'm doing something wrong if all I do is choose 'install'.

I would love to use linux, but for the life of me I cannot figure out why there are so many who swear by it, and of all the distributions I've tried since 1998, only ONE has ever installed correctly (Mandrake, came with a linux magazine once). The rest simply bomb upon installation.

Good thing Linux is free, or I'd be red-flagged on every company's support system. Windows, for all its problems, actually installs and works.

ernie 08-07-2010 08:27 AM

No one will be able to help if you do not post your system specifications, but the greatest likelihood (based on your description) is that the disk you burned (or the .iso image file you burned the disk from) is corrupted.

If you get to the point where you choose to install rather than update, the disk boots, and the installer loads, so the issue is not with your computer's ability to run Linux in graphical mode. When the installer begins to access the installation data on the disk, it can not, so it returns an error.

Check the md5som for the .iso image file with an md5sum application for Windows. You can Google for "md5sum.exe" (no quotes) to get a download link and download a copy, or go to md5summer.org. MD5Summer is a graphical Windows application. You start it, then navigate to the file to check in a file selection dialog (IIRC, the initial window).

HTH,

pizzelle 08-09-2010 12:38 AM

Ok let me get back into professional mode here...

Unlike many discussions I've seen about "linux help",
I'll try to be helpful and thorough for the sake of others.

First, I have to admit that the checksumming of the .iso was
the right answer. Thank you very much for putting up with my
frustration. As you might have seen from my linux history,
linux is on my short fuse.

What caused my problem, and most likely what causes many others,
is:
1) I downloaded several linux distros from different sites
2) all downloads completed successfully
3) all cds/dvds burned successfully
4) the pc booted from those discs
5) the install programs launched

Given those facts, it's very easy to assume that your download
was fine because wouldn't one of those fail if your file was
corrupted?

However, my .iso was indeed corrupt even though the PC booted.
I bet this is why many people are having trouble.

The error about the invalid buffer I/O on sr0 does refer to the
fact that something was wrong while reading from an optical disc.

I used md5summer (fsum works also, so I'm not new to
this sort of thing), and ran it on the .iso that I downloaded.
Its checksum did not match the checksum posted on the linux site.

For those of you who created an entire souvenir shop of coasters
and tore out half of your hair, let me suggest a process which I
will be sure to follow in the future.

1. Download your image using a reliable protocol like FTP.
FTP is based on TCP/IP and incorporates error-checking.
The Mandriva site I last used had a link that let you download
via FTP instead of HTTP.

2. Reduce your PC activity and your home network activity
to maximize your chances of a reliable download.

3. Run a checksum utilty such as fsum.exe or md5summer
to confirm the validity of the downloaded image.

4. If valid, then burn to disc.

Right now KDE and Gnome are having some trouble with the display.
I'll mess with that in another thread.

Thanks Ernie!
--Pizzelle

GlennsPref 08-09-2010 03:17 AM

Thank you for posting a solution method.

If I could add one more step, do 'verify' when you burn to cd.

Cheers Glenn

jkerr82508 08-09-2010 03:45 AM

It is also usually best to burn at a slow speed (rather than "auto") to have a better chance of getting a good burn.

Jim


All times are GMT -5. The time now is 08:55 AM.