LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   enabling amd cool 'n' quiet on mandrake 10.1 (http://www.linuxquestions.org/questions/mandriva-30/enabling-amd-cool-n-quiet-on-mandrake-10-1-a-304946/)

guy24x 03-23-2005 01:37 AM

enabling amd cool 'n' quiet on mandrake 10.1
 
hi folks,

does anyone know how to enable cool 'n' quiet on mandrake 10.1 official?
my mobo is asus k8v, processor is athlon 64bit 3000+. i have enabled q-fan (quiet fan) in the bios, that works cool ;-) , but i want to know how to enable cool 'n' quiet. i have enabled cool 'n' quiet in bios, and enabled acpi in bios.

kind regards,
gu24x

huibert.alblas 03-23-2005 06:16 AM

You could be suffering from the same problem I had.
I have the same MoBo, everything worked fine, only CoolNQuiet wouldn't work.
The problem is that Asus screwedup the ACPI spec in the bios, or something like that.

I needed a kernel patch to get it running.

I made en entry in the HCL, you can check it here

http://www.linuxquestions.org/hcl/sh...&cat=37&page=2

If you need further help, you can ask me.

guy24x 03-23-2005 11:18 AM

hi huibert !

thanx for the reply :-) only thing is, i'm a total beginner of linux, so i dont have much technical info regarding linux. so if you could walk me through, so i can enable cnq, it would be great :-)

my bios has the following settings:

acpi 2.0 support - enabled
acpi apic support - enabled
q-fan - enabled
amd cool n quiet - enabled

my kernel version is 2.6.8.1-12mdk

kind regards,
guy24x

huibert.alblas 03-24-2005 10:01 AM

You have to compile your kernel, you cannot you a default mandrake kernel.
There are many kernel cimpile howtos on the net, and one here in the LQ WIKI:

http://wiki.linuxquestions.org/wiki/Compiling_a_Kernel

If you succeded in getting your own kernel to run (without cool an quiet) you can email me with the "profile" button, I will describe what to do.

Sorry if this sounds complicated, but this is Asus 's failure, not linux.


All times are GMT -5. The time now is 03:08 PM.