LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 03-23-2005, 02:37 AM   #1
guy24x
Member
 
Registered: Jan 2005
Location: Bangalore /India
Distribution: Mandrake 10.1 Official, Simply Mepis 3.3.1-1
Posts: 45

Rep: Reputation: 15
enabling amd cool 'n' quiet on mandrake 10.1


hi folks,

does anyone know how to enable cool 'n' quiet on mandrake 10.1 official?
my mobo is asus k8v, processor is athlon 64bit 3000+. i have enabled q-fan (quiet fan) in the bios, that works cool ;-) , but i want to know how to enable cool 'n' quiet. i have enabled cool 'n' quiet in bios, and enabled acpi in bios.

kind regards,
gu24x
 
Old 03-23-2005, 07:16 AM   #2
huibert.alblas
Member
 
Registered: Jan 2004
Location: Duesseldorf /Germany
Distribution: Gentoo amd64 / Debian
Posts: 226

Rep: Reputation: 30
You could be suffering from the same problem I had.
I have the same MoBo, everything worked fine, only CoolNQuiet wouldn't work.
The problem is that Asus screwedup the ACPI spec in the bios, or something like that.

I needed a kernel patch to get it running.

I made en entry in the HCL, you can check it here

http://www.linuxquestions.org/hcl/sh...&cat=37&page=2

If you need further help, you can ask me.
 
Old 03-23-2005, 12:18 PM   #3
guy24x
Member
 
Registered: Jan 2005
Location: Bangalore /India
Distribution: Mandrake 10.1 Official, Simply Mepis 3.3.1-1
Posts: 45

Original Poster
Rep: Reputation: 15
hi huibert !

thanx for the reply :-) only thing is, i'm a total beginner of linux, so i dont have much technical info regarding linux. so if you could walk me through, so i can enable cnq, it would be great :-)

my bios has the following settings:

acpi 2.0 support - enabled
acpi apic support - enabled
q-fan - enabled
amd cool n quiet - enabled

my kernel version is 2.6.8.1-12mdk

kind regards,
guy24x
 
Old 03-24-2005, 11:01 AM   #4
huibert.alblas
Member
 
Registered: Jan 2004
Location: Duesseldorf /Germany
Distribution: Gentoo amd64 / Debian
Posts: 226

Rep: Reputation: 30
You have to compile your kernel, you cannot you a default mandrake kernel.
There are many kernel cimpile howtos on the net, and one here in the LQ WIKI:

http://wiki.linuxquestions.org/wiki/Compiling_a_Kernel

If you succeded in getting your own kernel to run (without cool an quiet) you can email me with the "profile" button, I will describe what to do.

Sorry if this sounds complicated, but this is Asus 's failure, not linux.

Last edited by huibert.alblas; 03-24-2005 at 11:03 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
athlon64 cool and quiet driver linuxmandrake Debian 1 10-19-2005 11:22 AM
AMD Cool&Quiet Support in Fedora Core 4 Gwydion The Quick Linux - Hardware 3 09-08-2005 04:06 PM
Cool and quite under Linux for AMD ? HomeUser Linux - Hardware 5 06-13-2005 06:14 AM
enabling "cool 'n' quiet" on linux guy24x Linux - Hardware 2 03-24-2005 06:49 PM
Sound very quiet (Mandrake, CMI8738) mi5iek Linux - Newbie 4 11-15-2003 03:55 PM


All times are GMT -5. The time now is 12:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration