LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Enabled SCSI-IDE and Can't Access DVD-ROM (http://www.linuxquestions.org/questions/mandriva-30/enabled-scsi-ide-and-cant-access-dvd-rom-133837/)

Campy19 01-11-2004 08:50 PM

Enabled SCSI-IDE and Can't Access DVD-ROM
 
I enabled SCSI-IDE emulation for my DVD drive so that I could use KDE CD burner program. Now I can't access my CDROM through /MNT but I can listen to CD's on the DVD drive. The DVD drive works through Windows...hdc is the Samsung DVD drive and hdd is the LG-CDROM Writer...I'm running Mandrake 9.2...

here's my FSTAB file:

/dev/hdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdb6 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/scd0,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/cdrom2 supermount dev=/dev/scd1,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,sync,umask=0,codepage=850,iocharset=iso8859-1 0 0
/dev/hda1 /mnt/windows vfat umask=0,codepage=850,iocharset=iso8859-1 0 0
none /proc proc defaults 0 0
/dev/hdb5 swap swap defaults 0 0

Here's lilo.conf:

boot=/dev/hda
vga=normal
default="Windows"
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="Linux"
root=/dev/hdb1
initrd=/boot/initrd.img
append="devfs=mount hdc=ide-scsi hdd=ide-scsi acpi=ht resume=/dev/hdb5 splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="Linux-nonfb"
root=/dev/hdb1
initrd=/boot/initrd.img
append="devfs=mount hdd=ide-scsi acpi=ht resume=/dev/hdb5"
read-only
image=/boot/vmlinuz
label="Failsafe"
root=/dev/hdb1
initrd=/boot/initrd.img
append="failsafe devfs=nomount hdd=ide-scsi acpi=ht resume=/dev/hdb5"
read-only
other=/dev/hda1
label="Windows"
table=/dev/hda
other=/dev/hda1
label="Floppy"
table=/dev/hda

Thanks,
Chris

krussell 01-12-2004 11:14 PM

Re: Enabled SCSI-IDE and Can't Access DVD-ROM
 
Quote:

Originally posted by Campy19
I enabled SCSI-IDE emulation for my DVD drive so that I could use KDE CD burner program.
you don't need dvd player as scsi to run dvd.
is it a dvd writer? then its ok.

Quote:

Originally posted by Campy19
/dev/hdb1 / ext3 defaults 1 1 none /dev/pts devpts mode=0620 0 0
/dev/hdb6 /home ext3 defaults 1 2 none /mnt/cdrom supermount dev=/dev/scd0,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/cdrom2 supermount
dev=/dev/scd1,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/floppy supermount

your cdwriter entry should look like this:
/dev/scd0 fs=udf:iso9660 ... .... ....

Quote:

Originally posted by Campy19
append="devfs=mount hdc=ide-scsi hdd=ide-scsi acpi=ht resume=/dev/hdb5
[/B]
You should remove the hdd=ide-scsi, because its your dvd drive.

Finally, you could (just for convenience) create a link called /dev/dvd that points to /dev/hdd, like "ln -s /dev/hdc /dev/dvd" if /dev/dvd exists remove it with "rm /dev/dvd", but you need to be superuser to do these.

krussell 01-12-2004 11:20 PM

Hello Campy19 :)
Please remember to enable dma for ur dvd, command is (as super user)

hdparm -d1 /dev/hdd


All times are GMT -5. The time now is 09:57 PM.