LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 09-23-2003, 04:24 PM   #1
Isjhe
LQ Newbie
 
Registered: Sep 2003
Location: Minnesota, USA
Distribution: Mandrake
Posts: 9

Rep: Reputation: 0
(EE) NVIDIA (0) Failed to initialize the NVIDIA kernel module


Hey hey everyoneÖ

I bought a copy of Mandrake 9.1 on eBay last week, and just tried to install it today. Everything went fine, I partitioned my drive with Win98 on it already, set the whole thing up and rebooted. I get to (Lilo?) the boot manager, and have the option to choose what I want to boot. Selecting Linux brings up a Mandrake Linux boot screen, where it goes through and initializes things (thatís what Iím assuming itís doing). Toward the end, the screen begins to flicker. With each flicker the rapidity increases, then I go to some sort of shell prompt for my user name and password.

I put both in, and then I get a prompt. From a little reading around I discovered that typing Ďxstartí is supposed to bring up the GUI. Unfortunately neither Ďxstartí nor Ďkdeí brings up a GUI, just a big screen with a lot of words. The important stuff (I would assume) is that the blasted thing cannot initialize the NVIDIA kernel module. [edit] There's also something about pages being found but none useable, I can't remember exactly)

Now, I know Iím supposed to download a new something or other, but Iím a windows hick, and this is the first time Iíve had to use a prompt exclusively (heck, I donít even know DOS commands). I havenít the faintest notion of how to go about doing that without a GUI.

During the install mandrake detected my video card as a ĎNvidia GeForce 2 DDR (generic)í. I donít think itís a DDR, all I know is that itís a GeForce 2 MX 400 with 64MB of RAM. There is no GeForce 2 MX option in the troubleshooter dohicky for X, just a GeForce 2 integrated and the one mentioned above.

Any help would be much appreciated.

Last edited by Isjhe; 09-23-2003 at 04:25 PM.
 
Old 09-23-2003, 04:50 PM   #2
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
login to root and type XFdrake to setup you graphics. Once thats done it startx to start your gui. If the gui comes up then a reboot should alway start you off in the gui. By the way my daughter has the same video card and it work out of the box.
 
Old 09-23-2003, 05:03 PM   #3
Isjhe
LQ Newbie
 
Registered: Sep 2003
Location: Minnesota, USA
Distribution: Mandrake
Posts: 9

Original Poster
Rep: Reputation: 0
I went through XFdrake, and tried using every Nvidia card it listed, still nothing. My card is a PCI variant of the GeForce 2, not APG, would that have anything to do with it?
 
Old 09-23-2003, 06:17 PM   #4
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
Did you by any chance load the drivers from the NVIDIA site
 
Old 09-23-2003, 07:58 PM   #5
Isjhe
LQ Newbie
 
Registered: Sep 2003
Location: Minnesota, USA
Distribution: Mandrake
Posts: 9

Original Poster
Rep: Reputation: 0
That, friend, is the problem. I am unfamiliar with the mystical methods used to transfer files downloaded through Win98 over to a partition Win98 doesnít even see. And, as mentioned before, Iím totally ignorant about anything Linux wise, so Iím unsure if itís even possible to start up a browser or similar internet agent to do the transfer from Linux itselfÖ
 
Old 09-23-2003, 09:05 PM   #6
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
Yes dl them as you would any file. Then in Linux you should be a to navigate to the windows directory and copy them to your linux side. The path to the windows dir should be /mnt/win_c /mnt/win_d and so foreth once copied to a linux partition. You should be looking for a file called NVIDIA-Linux-x86-1.0-4496-pkg2.run. Since you don't have any graphics log into root - navigate to the file location. and type in sh NVIDIA-Linux-x86-1.0-4496-pkg2.run and follow the on-screen instructions
 
Old 09-24-2003, 02:54 PM   #7
Isjhe
LQ Newbie
 
Registered: Sep 2003
Location: Minnesota, USA
Distribution: Mandrake
Posts: 9

Original Poster
Rep: Reputation: 0
Ok, thanks. Just to be sure, would the following be correct?

login as root
navigate to the folder:
/mnt/win_c/downloads/

run the program:
sh NVIDIA-Linux-x86-1.0-4496-pkg2.run

follow on-screen instructions?
 
Old 09-24-2003, 03:37 PM   #8
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
If it a win98 format file system yep it shur will.
 
Old 09-24-2003, 03:52 PM   #9
Isjhe
LQ Newbie
 
Registered: Sep 2003
Location: Minnesota, USA
Distribution: Mandrake
Posts: 9

Original Poster
Rep: Reputation: 0
Yeah, it's 98. NVIDIA-Linux-x86-1.0-4496-pkg2.run download at 55%
 
Old 09-24-2003, 06:38 PM   #10
Isjhe
LQ Newbie
 
Registered: Sep 2003
Location: Minnesota, USA
Distribution: Mandrake
Posts: 9

Original Poster
Rep: Reputation: 0
Yay! It's working now. KDE, cool...


Ew... small fonts, nasty slow mouse.


Thanks for the help.
 
Old 09-25-2003, 08:25 AM   #11
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
Hmmm a slow mouse. Did you try reconfiging the mouse to see if that helps?
 
Old 09-25-2003, 12:12 PM   #12
Isjhe
LQ Newbie
 
Registered: Sep 2003
Location: Minnesota, USA
Distribution: Mandrake
Posts: 9

Original Poster
Rep: Reputation: 0
Yeah, I managed to locate that option. Mouse Acceleration, not something I would have chosen to use in leu of the standard 'mouse speed'. I'll get used to it.

Fonts are nasty in Mozilla and Firebird, they look fine in Konquerer though, guess I'll have to troll the mozilla help forums to find a fix.

No sound either, which gets on ones nerves after awhile. I'm running a Soundblaster Live! card, in the Control Center it says that I'm using Type 10: ASLA emulation, whatever that means.
 
Old 09-25-2003, 02:12 PM   #13
courtrrb
Member
 
Registered: Sep 2003
Location: Iowa, US
Distribution: MDK Since V6.5
Posts: 570

Rep: Reputation: 30
sound is mutted by default. select Multimedia>sound>aumix and turn the sound up.
 
Old 09-25-2003, 05:05 PM   #14
Isjhe
LQ Newbie
 
Registered: Sep 2003
Location: Minnesota, USA
Distribution: Mandrake
Posts: 9

Original Poster
Rep: Reputation: 0
I've tried that. Every time I close the aumix thingy, it reverts back to everything muted. (clicking the mute option in the menubar brings it up as muted)

I can adjust the volume levers, but it doesn't do anything. If I take it off mute, save and close, then reopen it, it's muted again.
 
Old 09-25-2003, 09:29 PM   #15
Isjhe
LQ Newbie
 
Registered: Sep 2003
Location: Minnesota, USA
Distribution: Mandrake
Posts: 9

Original Poster
Rep: Reputation: 0
I got the sound working, by nuking my onboard audio. *jams to cadet*

However, I had to re-install my Nvidia drivers again after editing the BIOS. I'll check the config file, but I'm sure I did everything right, and saved it after editing. I was logged in as root too...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
(EE) NVIDIA(0): Failed to initialize the NVIDIA Kernel module latino Linux - Hardware 5 06-03-2008 03:55 AM
(EE) NVIDIA(0): Failed to initialize the nvidia kernel module necbrownie Slackware 18 06-16-2006 02:20 AM
No GUI-NVIDIA kernel module failed to initialize Lakota Mandriva 13 07-19-2004 01:17 PM
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Stan the caddy Linux - Hardware 8 01-18-2004 04:21 PM
Failed to initialize the NVIDIA kernel module THX1138 Linux - Newbie 14 11-11-2003 01:34 AM


All times are GMT -5. The time now is 07:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration