LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 12-29-2004, 06:09 AM   #1
darkjedi8359
LQ Newbie
 
Registered: Dec 2004
Location: Alaska, USA
Posts: 9

Rep: Reputation: 0
Dual Boot WinXP & Mandrake 10


Hello I am a complete linux noob, I don't know anything really about it. I have WinXP Pro installed and attempted to do a dual boot. Well when I try to boot my computer and select windows instead of linux it only shows a blinking underscore. I can see my Windows Partition so I know its all there. I have tried to uninstall linux (with WinXP disc, deleted the linux partitions) but when I did that I get a "Error Loading Operating System" So I installed Linux again, and still my windows partition showed up. I don't know if I have my boot loader settings correct. Would some one please help me?
 
Old 12-29-2004, 08:41 AM   #2
caladbolg
Member
 
Registered: Jul 2004
Distribution: Mandrake 10.x, Fedora Core 3, Archlinux 0.7, Ubuntu 5.04
Posts: 303

Rep: Reputation: 31
Install Linux and your boot loader on the first section of the MBR. Then make sure you select to configure your boot loader towards the end of the installation. Make sure Windows is one of the choices. That should work
 
Old 12-29-2004, 10:49 AM   #3
Padma
Member
 
Registered: Aug 2003
Location: Omaha, NE, USA
Distribution: PCLinuxOS 2007
Posts: 808

Rep: Reputation: 30
Which version of Mandrake, exactly?

Mandrake 10.0 had a serious bug in the installer, where if you modified the partition table with it (e.g., install using free space at the end of the Windows partition), you could no longer boot into Windows. The technical details involved the 2.6 kernel and the bios disagreeing about the contents of the partition table. IIRC, this was fixed with 10.1 Official.

The *best* workaround is to go into the BIOS and force your drive to use LBA, not AUTO.

See this bug report for more details.
 
Old 12-29-2004, 11:07 AM   #4
darkjedi8359
LQ Newbie
 
Registered: Dec 2004
Location: Alaska, USA
Posts: 9

Original Poster
Rep: Reputation: 0
I was installing 10.0 yes I guess I should have read up on it, so if I force my primary drive to LBA will windows boot? should I upgrade to 10.1?

To upgrade do I need to get the ISOs again and burn them off? sorry for all the questions.

Thank you for your help, I think linux is my new favorite OS. If only it could play HL2 I would use it full time ( I know about Wine/Cedega but can't get either atm)
 
Old 12-29-2004, 11:30 AM   #5
Padma
Member
 
Registered: Aug 2003
Location: Omaha, NE, USA
Distribution: PCLinuxOS 2007
Posts: 808

Rep: Reputation: 30
I would *try* the forced LBA thing and cross my fingers.

From the bugreport I linked to above:
Quote:
"Reboot your computer and go into the BIOS. ->
go to CMOS Featurs ->
IDE Primary Master(or the IDE with your Hard Drive) ->
change access mode to LBA, instead of auto


you should be able to get into windows. Now you can run a program like
Partition Magic and try and fix your partitions and should be able to
change
the BIOS setting back to auto"
Another person reinstalled Windows over the old partition, without clearing it out, and Windows reset the partition table correctly for him.

Here's wishing you luck getting your Windows back.


Finally, if I were you, I would definitely download the 10.1 Official ISOs, and install with those.
 
Old 12-29-2004, 11:53 AM   #6
darkjedi8359
LQ Newbie
 
Registered: Dec 2004
Location: Alaska, USA
Posts: 9

Original Poster
Rep: Reputation: 0
thank you for your help, I will try the LBA mode and see if it works. If not I will reinstall windows over te odl partition and see if that has any effect. I will try to get the 10.1 ISOs and upgrade.
 
Old 01-15-2005, 03:11 AM   #7
seow_ming
Member
 
Registered: Mar 2004
Location: Currently in China
Distribution: Fedora 9
Posts: 130

Rep: Reputation: 15
hei guys, I just follow your suggestion and chaged my harddisk access mode from NORMAL ----to----> LBA and problem solved!!!! Thanks for the suggestion.
 
Old 01-15-2005, 07:04 AM   #8
darkjedi8359
LQ Newbie
 
Registered: Dec 2004
Location: Alaska, USA
Posts: 9

Original Poster
Rep: Reputation: 0
thanks for the help, that didn't quite work for me... I ended up installing windows on another Hard Drive, but I still had that error. Switching the drive to LBA worked that time. Now I can run linux and windows fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dual boot hangs - slack & winxp timoioi Linux - Software 5 10-09-2005 10:18 PM
FC1 & WinXP (Dual boot) Alkalined Linux - Newbie 3 10-29-2004 08:48 PM
Dual boot issue w/ WinXP Pro & Mandrake 10 using GRUB Adam A Flynn Linux - General 6 06-08-2004 09:05 PM
dual boot with redhat9&winXP scarabs Linux - Newbie 6 03-20-2004 03:30 PM
Redhat 9 & winxp dual boot -xp won't boot opivy Red Hat 3 01-02-2004 01:08 PM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration