LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Don't know how to go from CLI to GUI in Mandriva 2006.0 (http://www.linuxquestions.org/questions/mandriva-30/dont-know-how-to-go-from-cli-to-gui-in-mandriva-2006-0-a-402736/)

t_smith_03 01-13-2006 12:26 AM

Don't know how to go from CLI to GUI in Mandriva 2006.0
 
Hey can someone help me? I am new to the linux enviroment, I just installed mandriva 2006 and got to the login CLI. I then logged in with root account and then got this command prompt [root@localhost ~]# . From Here I don't know how to go from this prompt to the GUI. I have looked for information on this thread, but found nothing. Please can someone help me?

Bruce Hill 01-13-2006 12:46 AM

Welcome to LQ!

Well, first thing you should do is issue "adduser username" but put tim or tom or tony or whatever your name is rather than username. Just leave everything default. When you get back to that prompt that ends with a # there (that means root), then issue "exit" to exit from root, and login as the normal user you just created. After that, issue "startx" to start the X server.

I don't use Mandrivia, so I don't want to tell you too much. Might have you turned into a Slacker if I did. What I told you will launch your GUI X server, and some of them Mandrivia guys (pray for opjose) will come on in here and give you the skinny. I thought your distro actually automatically launched you into X, but eh, I'm just a Slacker ... what do I know about that?

GlennsPref 01-13-2006 02:50 AM

probably missed an option in the setup screens, or it didn't configure your video card correctly.

What chinaman said is right, do all that.

If after a reboot it comes up in cli again login, and type "init 5". This should get things set for next time. Then type "startx".

In the MCC, (star, system, configuration, configure your desktop you may find many options to change.

A main setting is in Configure your computer, system, enable or disable system services. Be sure dm is checked to load at bootup. It's the display manager daemon/loader.

There are other ways to do all that, but if you have a gui, there it is.

t_smith_03 01-13-2006 12:17 PM

problems again
 
I did as you guys told me but it came up with these: Fatal server error: no screens found and also this error: a fatal 10 error 104 (connection reset by peer on X server ":0.0" after 0 requests (o processes known) with 0 events remaining.

Lakota 01-13-2006 12:58 PM

This thread should help you out:
http://www.linuxquestions.org/questi...54#post1677954

GlennsPref 01-13-2006 06:05 PM

That just says It could not find the path to your monitor

thunderweasel 01-13-2006 10:24 PM

From the command line, type drakconf and configure your display. Pick your graphics card, pick your monitor, and when your done, type startx from the command line and see if you get a graphical environment. Sounds like you didn't configure your graphical display when you installed. Just run drakconf and you'll be able to do it all from easy text menus.

combatbob 01-22-2006 11:02 PM

I loaded the Mandriva limited editon 2005. during setup you made selections to not start your GUI. Log in as root and type startx, that should start the Mandriva "window" system or actuall KDE 3.3. If you recieve any errors, then start over completly, yep stick the "Disc 1" power down, power up, and follow the install procedures. You want to use the KDE Graphical User Interface (GUI) It will be an option in the installation process. then holler back. Also there are tutorials along this website, lood for your specific Linux distrobution (Mandriva). You should find more help there

di11rod 01-27-2006 12:33 PM

The responses here are really helpful. Since I just dealt with a similar situation in Mandriva 2006, I can tell you that thunderweasel has given very useful advice. Combatbob would normally be on-target as well, except that in this case t-smith is getting a "no screens found" message when he tries to startx. That's a pretty sure sign the video card isn't configured properly.

If you don't see your video card listed in drakconf, you may need to install special drivers for it. Posting your video card model here would be useful for additional pointers on this issue.

Also, in terms of the direction that combatbob was recommending... he's right about going through the install disc to enable the gui to start at boot time. Another way to address this if you're booting to the command line is to login as root (or another user and su to root), then edit /etc/inittab. Make sure this line looks like this--

id:5:initdefault:

If it looks like this

id:3:initdefault:

Then change that 3 to a 5, save file (in vi it's <esc>:wq!), and reboot.

But my money is that the video card isn't configured....

di11rod

bobbelfield 01-29-2006 01:48 AM

any results?
have you tried typing kde ?

tkedwards 01-30-2006 12:26 AM

The official docs have a troubleshooting guide if X (the GUI) doesn't start: http://doc.mandrivalinux.com/Mandrak...ubleshooting-x


All times are GMT -5. The time now is 11:49 PM.