LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 10-29-2003, 04:56 PM   #1
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Ubuntu LTS
Posts: 425

Rep: Reputation: 34
Disable Touch pad *Clicking*


Ok Mandrake users. This is driving me F#$%ing nuts! I ever so badly want to disable my touch pad on my laptop from "clicking" when I tap it. My hand always seems to accidently slide accross it or something and it clicks somewhere else on another window or something. I want to throw this notebook against the damn floor. Please oh please tell me this is possible and tell me how to do it!

Oh, I also use an external USB Logitech mouse when the laptop is at home. Not sure if this information will be needed.

Wh33t
 
Old 10-29-2003, 05:53 PM   #2
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
are there ways u can go to the BIOS and disable touch pad?
and just use external mouse?
 
Old 10-29-2003, 06:04 PM   #3
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Ubuntu LTS
Posts: 425

Original Poster
Rep: Reputation: 34
Hmmmm never though of that, ill try it. I dont really want to disable/re-enable the touchpad everytime i go somewhere with out my ext mouse though. But gah, if it solves it, it solves it.

Thanks for the reply
Wh33t
 
Old 10-29-2003, 06:11 PM   #4
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Ubuntu LTS
Posts: 425

Original Poster
Rep: Reputation: 34
Nah, there is nothing in the bios for disabling the touch pad.

Wh33t
 
Old 10-29-2003, 06:49 PM   #5
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
this is gonna be a diffcult task, when laptop manufactory buy those touch pad from other company, it came with a driver (just like every other drivers u got for ur hardware)

that driver is specialy design for control the touch pad behavior. i'm not good with hardware and drivers, but i understand there are additional lines on the code u can edit to turn the touch pad on and off.

now.... base on what u've been saying, i think ur touch pad can recongize some general ps/2 setting, such as right click, left click, x and y coord. can you disable mandrake ps/2 mouse. and use mouse from USB port?

i don't think your touch pad mouse would recongize USB driver...

(just trying to shot from the dark, hope it'll help)
 
Old 10-29-2003, 06:53 PM   #6
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
can you try loading and unloading the module for your touchpad when needed?
 
Old 10-29-2003, 06:54 PM   #7
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Ubuntu LTS
Posts: 425

Original Poster
Rep: Reputation: 34
Mmmm ill try that, how would I do that? Edit the XF86config-4 file and taking out the touchpad settings then readding it? oh i guess I could just comment it out? is that what your suggesting?

Wh33t
 
Old 10-29-2003, 07:03 PM   #8
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
you'll have to try to find out what the module name is. As root in console run
lsmod then see if you see something that would be for your touch pad. You might try searching what modulename it is on the net. then as root to unload it do
rmmod modulename and then to reload it do as root
modprobe modulename
You might try man rmmod to see what all options you have there.
 
Old 10-29-2003, 07:09 PM   #9
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Ubuntu LTS
Posts: 425

Original Poster
Rep: Reputation: 34
Mmmm. I think I've found my mouse module for my touchpad, but it says unable to unload device is busy... do i have to start up mandrake without x? or is there a way to shutdown x then rmmod at console as root?

Wh33t
 
Old 10-29-2003, 07:20 PM   #10
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
Try ctrl+alt+F1 to get to console( side note, I have to use the left ctrl+alt, dunno if yours will be the same) and then ctrl+alt+f7 to get back to x.
 
Old 10-29-2003, 07:25 PM   #11
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Ubuntu LTS
Posts: 425

Original Poster
Rep: Reputation: 34
Well. that did the opposite of what I wanted. It disabled my ext mouse. Perhaps mousedev isn't the right module, I suppose I could try shutting down usbmouse. Maybe its the other way around.

Wh33t
 
Old 10-29-2003, 07:26 PM   #12
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Ubuntu LTS
Posts: 425

Original Poster
Rep: Reputation: 34
mmm thats not either. one more choice, but I get a feelings its going to shut my keyboard off. lol

Wh33t
 
Old 10-29-2003, 07:29 PM   #13
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Distribution: Ubuntu LTS
Posts: 425

Original Poster
Rep: Reputation: 34
well it said device is busy as root, so im definetly assuming that its my keyboard module. So... I'm feeling stuck

Wh33t
 
Old 10-29-2003, 07:31 PM   #14
sandman
Member
 
Registered: Sep 2002
Distribution: arch
Posts: 232

Rep: Reputation: 30
can you post the output of lsmod? I don't think removing usbmouse is gonna make you very happy
 
Old 10-29-2003, 07:37 PM   #15
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
the module u found, was ur USB mouse, ur touch pad was set up as normal PS/2, that needs to be disable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disblae Touch pad *Clicking* on a laptop wh33t Linux - Hardware 6 06-03-2009 07:07 PM
Touch Pad and Resolution BuryedAlie Fedora 0 07-09-2005 02:19 AM
Turn off touch pad "clicking" pgte3 Linux - Newbie 7 08-25-2004 01:59 PM
touch pad activation clschroe Linux - Laptop and Netbook 0 08-04-2004 04:05 AM
Touch pad Help fimanne Linux - Laptop and Netbook 3 09-11-2003 09:10 AM


All times are GMT -5. The time now is 12:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration