LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   disable graphical bootup? (http://www.linuxquestions.org/questions/mandriva-30/disable-graphical-bootup-168975/)

evilchild 04-11-2004 09:41 PM

disable graphical bootup?
 
Is it possible to dissable the graphical bootup in mandrake 8.2 ?

OmniXBro 04-11-2004 09:53 PM

in file /etc/inittab change the line

id:3:initdefault

and make sure the number is 3

Arbitor 04-11-2004 11:50 PM

Make sure you su to root first. The default should be 5, I believe (at least it is for me, which is X11).

Arb

evilchild 04-12-2004 05:36 AM

i have the following "id:3:initdefault:" what should i change it too? I didn't fully understand the posts above.

santigua 04-12-2004 05:50 AM

/etc/inittab
 
Here is a short explanation as it's found on a MDK10 System.
They are of course also applicable to any (?) other Linux System..

# Default runlevel. The runlevels used by Mandrake Linux are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

as you may have noticed, I have set the default zu 5, which will start my computer with a GUI and I can logon graphically.
Would I have set it to 3 (id:3:initdefault:) my Pc yould work exactly the same EXCEPT it doesnot start the GUI at boot time.

Hope that helped.

OmniXBro 04-13-2004 06:38 AM

interstingly, if his default runlevel was already 3, he should have a non-gui startup. but since i'm not familiar with MDK 8.2, maybe the runlevels are different? evilchild, just read the explanation above that line and compare with the info santigue gave you. full multiuser mode might be the one you're looking for. for gui, choose X11.
hope that helps

santigua 04-13-2004 07:02 PM

idea?!
 
I just had an idea...
since he wrote that he has defined runlevel 3 and still has a "graphical bootup" i was wondering if I understood correctly...

...coz...

either....
a) we are talking about the *graphical bootup* as what happens after LILO sends the command(s) to boot the system....
...you know...the BlueMDK Background with whatever it says.....while the system boots....(init etc.)

...or...

b) we are talking about the "graphical bootup" as we talk about runlevel 5.....lets say...the automatic start of the xserver.....AFTER 'a' has finished....


so??? some clearance needed...

make 04-14-2004 08:04 AM

Hello,
thought my question would fit under this topic the best.

How to disable the graphical bootup process (I don't mean runlevel 5, where it starts to X, I mean the graphical boot itself)? I just hate it, but the Mandrake 10 enabled it by default and never even asked if I want the text-only boot.

I wonder if this can be done from /etc/lilo.conf?


edit: Forgot to say that drakboot --splash (the Mandrake graphical tool) does NOT disable the graphical boot, I guess it's a bug in the program. So I need to do this MANUALLY. And this same thing happens on 3 computers.

bopo119 04-14-2004 04:14 PM

I don't know about Mandrake 10.0 but in 9.2 you should go to the boot configurator and you can change to three settings:
  • Change to GRUB bootloader - pretty text based
  • LILO with graphical boot
  • LILO with text boot
And it did ask, at the summary screen of installation you can change the bootloader. (I would go with LILO)

make 04-15-2004 12:45 AM

Quote:

Originally posted by bopo119
[*]Change to GRUB bootloader - pretty text based[*]LILO with graphical boot[*]LILO with text boot

I can change the bootloader to textmode (GRUB/LILO), but I mean the booting process itself. Even if I switch the bootloader to text-only, after the bootloader-menu/text, the booting process starts with the graphical Mandrake background picture again. :(

I think the installation program only asks about the graphical boot in the "expert"-mode. I went through all screens so carefully, because I really wanted to disable the graphical boot. If the question was somewhere there, it was VERY well hidden (I was especially looking for it from the "summary"-screen).

OmniXBro 04-15-2004 06:34 AM

ummm
graphical boot with mandrake background...what? O_o i never got that one. probably because i always use linux-nonfb boot line at bootlader. you might want to try that too?

RockmanExe 04-15-2004 04:25 PM

you're near:

there in mandrake contror center/boot options edit lilo-graphic. In advanced options select some frame buffer theme option, it would give you 2 options: lilo themes (if you have some already installed) and splash themes: select none at this option which is the one you want to disable.
Or as OmniXBro posted, select a non frame buffer option.
This in what i remember, maybe the locations are not quite exactly as i told you, since i'm not right at my mdk pc

hope this helps :)

make 04-16-2004 12:33 AM

Editing the bootloader settings helped. Thanks!

evilchild 04-16-2004 01:40 PM

hello make , what settings did you edit in the bootloader settings? or did you use the steps RockmanExe suggested about using mandrake control center ?

make 04-16-2004 03:21 PM

Quote:

Originally posted by evilchild
hello make , what settings did you edit in the bootloader settings? or did you use the steps RockmanExe suggested about using mandrake control center ?
Mandrake Control Center -> Boot -> Bootloader -> Next

Double-click the options (like linux and linux-nonfb for example) and check the "Video Mode" by first clicking "Advanced" from them. Set it to "Normal", if it's set to some framebuffer resolution.

Then accept options and it will install the bootloader with thenew settings.


All times are GMT -5. The time now is 12:24 AM.