LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 03-24-2008, 11:52 AM   #1
taj
Member
 
Registered: Aug 2004
Posts: 128

Rep: Reputation: 15
copying files to Windows Drive


I have a dual boot system with Win XP and Mandriva 2008 running KDE, and I can copy and past files from my Windows drive to my Linux drive, but can't copy and past from Linux to Windows? What do I need to do to be able to move the files between the 2 systems while in Linux?
 
Old 03-24-2008, 11:59 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
It depends. It could be that you're using the "ntfs" driver to mount the Windows partition, which means you can only mount the partition as read-only (read, copy things from there, but not to there). To get a read-write*support for your NTFS partitions, you need to use something else - maybe fuse-3g or whatever it's called. Not sure if Mandriva ships with it, some distributions do, some don't.

See here for more information:

mandrivausers.org/index.php?showtopic=43701&mode=threaded&pid=332727
 
Old 03-24-2008, 12:43 PM   #3
taj
Member
 
Registered: Aug 2004
Posts: 128

Original Poster
Rep: Reputation: 15
Thanks for info, just checked the Win drive and it is NTFS, will look into your suggested program, thanks again
 
Old 03-24-2008, 03:37 PM   #4
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
You need to install the ntfs-3g package and any dependencies, then edit your /etc/fstab file to change how your Windows partition is mounted if you wish to write to an ntfs file system. I do not have a Windows partition on my system here, but you can search this forum for ntfs-3g to learn what changes to make to your /etc/fstab file.

To install ntfs-3g, open a terminal window, su to root, and install the package(s) with urpmi:
Code:
[user@localhost ~]$ su (press the ENTER key)
Password: (enter your root password here, then press the ENTER key)
[root@localhost user]# urpmi ntfs3g (press the ENTER key)
If urpmi requests the installation of any additional packages (and I am sure it will), and the YES option in parenthesis is in caps, simply press the ENTER key to install them, if not, respond with yes then press the ENTER key.

To edit your /etc/fstab file, you will have to open it in a text editor with root access. The following example will open KDE's kwrite text editor from a terminal window as root:
Code:
[user@localhost ~]$ su (press the ENTER key)
Password: (enter your root password here, then press the ENTER key)
[root@localhost user]# kwrite /etc/fstab (press the ENTER key)
If you want to use a different text editor, replace kwrite with the name of the text editor you want to use.

HTH,
 
Old 03-26-2008, 10:50 AM   #5
taj
Member
 
Registered: Aug 2004
Posts: 128

Original Poster
Rep: Reputation: 15
I just rechecked on this machine and my Windows drives are all FAT 32, still won't let me copy files from my linux to them? When I was runing SLED 10.0 I was able to copy to them?
 
Old 03-26-2008, 10:56 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Look at the ownership and permissions of the filesystem. Check the fmask= and dmask= options in your /etc/fstab file. Values like "fmask=0111,dmask=000" will allow "others" to write to the file. Also make sure that the "rw" option is used.

Another possibility is that there is something wrong with the filesystem causing it to be mounted read-only.
 
Old 03-26-2008, 12:00 PM   #7
taj
Member
 
Registered: Aug 2004
Posts: 128

Original Poster
Rep: Reputation: 15
Not sure of what you are saying? this is what is in my "etc/fstab", I don't see what you are refering to?

/dev/hda6 / ext3 noatime 1 1
/dev/cdrom /media/cdrom auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
/dev/cdrom2 /media/cdrom2 auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
/dev/hda1 /mnt/win_c vfat umask=0022,iocharset=utf8 0 0
/dev/hda5 /mnt/win_d vfat umask=0022,iocharset=utf8 0 0
/dev/hda9 /mnt/win_e vfat umask=0022,iocharset=utf8 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0
 
Old 03-26-2008, 11:02 PM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Quote:
/dev/hda1 /mnt/win_c vfat umask=0022,iocharset=utf8 0 0
/dev/hda5 /mnt/win_d vfat umask=0022,iocharset=utf8 0 0
/dev/hda9 /mnt/win_e vfat umask=0022,iocharset=utf8 0 0
These are the entries to change. Change the "umask=0022" to "fmask=0111,dmask=000". This will mount these partitions with rw file access for everyone. The 'x' bit for directories allows you to enter that directory. Because vfat isn't a native filetype, the permissions are determined when the partition is mounted and effect the entire partition.

See "man mount" and "info coreutils" for more info on mount and permissions.
 
Old 03-27-2008, 11:48 AM   #9
taj
Member
 
Registered: Aug 2004
Posts: 128

Original Poster
Rep: Reputation: 15
Thanks for the info, made the changes you suggested and all works fine now, really appreciate your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Copying Individual Windows Files to a Linux Drive marietechie Linux - Hardware 5 01-01-2008 12:13 PM
Copying Protected Files from Windows XP Salty9 Linux - Security 4 06-05-2007 05:52 PM
Copying files from Windows to Linux Kmann Linux - Newbie 3 11-24-2006 02:19 PM
copying files from linux to windows Nigel Robinson Linux - Newbie 11 07-27-2005 02:41 PM
Seeing a Linux drive from Windows and copying files from the Linux drive? Alvis Linux - Software 4 03-26-2005 07:03 PM


All times are GMT -5. The time now is 12:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration