LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Configure Internet connection through LAN - windows machine (http://www.linuxquestions.org/questions/mandriva-30/configure-internet-connection-through-lan-windows-machine-568711/)

Micik 07-12-2007 07:10 AM

Configure Internet connection through LAN - windows machine
 
Hello people...
I have Mandrake 10.1 linux installed and I have problems configuring internet connection.
I have two computers at home. One, which is connected to the Internet (by dial up) is Windows XP machine, and other is Mandrake machine.
I have configured static IP LAN addresses: win machine 192.168.0.1 and linux: 192.168.0.2
I have configured network on Mandrake machine by using wizard and notworks works OK I think.
I have tested connection using ping on both computers and it works.
However, if I try to open a web page on Mandrake machine, I receive an error "unknown host"
I also tried to ping www.yahoo.com, also ping 87.... (yahoo IP) and ping command on Mandrake machine failed.
I have entered during network configuration
DNS1: 127.0.0.1
DNS2: 192.168.0.1
and gateway: 192.168.0.1 (win machine) but that didn't help.
Can you give me any advice?
Thank you

acid_kewpie 07-12-2007 07:18 AM

are you running dns on 192.168.0.1 or 127.0.0.1? no use as dns servers unless you are... only other thing would be the internet sharing gubbins on windows. note that none of these problems have anything to do with linux itself.

Micik 07-12-2007 07:30 AM

Quote:

Originally Posted by acid_kewpie
are you running dns on 192.168.0.1 or 127.0.0.1? no use as dns servers unless you are... only other thing would be the internet sharing gubbins on windows. note that none of these problems have anything to do with linux itself.

You're right, this is more networking problem, but since I use Mandrake linux, I placed question in Mandriva forum.
Basicaly, I want to connect Mandrake machine (192.168.0.2) to the Internet through windows machine (192.168.0.1).
Hope someone will help me with this.

acid_kewpie 07-12-2007 09:03 AM

well i still have asked you a number of critical questions which you've not answered...

Micik 07-12-2007 02:25 PM

Unfortunately I don't know answer on these questions. I thought it's OK to write DNS: 192.168.0.1 on my Mandrake machine since I intend to connect this machine through LAN. I thought it was sufficient to write IP address of other machine. Don't know how to make this work on Mandrake. I recently had ubuntu installed and it worked without any problems.

Micik 07-13-2007 03:39 AM

I have opened file etc/sysconfig/network and I saw there something like this:
HOSTNAME="Mandrake Linux"
NETWORKING=yes
GATEWAY=192.168.0.1

and still I'm unable to ping www.yahoo.com or google.com and open any web page on linux machine.
I'm getting error message unknown host. What could that be? Is there any other way I can manually check settings?
This is contents of ifcfg-eth0 file:
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.0.2
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
ONBOOT=yes
METRIC=10
MII_NOT_SUPPORTED=no
GATEWAY=192.168.0.1

I have addeg that last line with gateway, but no success. I have setup samba server, so LAN is working fine, but Internet doesn't work...
Thanks

acid_kewpie 07-13-2007 03:57 AM

it's not about making this work on mandrake... you need to supply a valid dns server to the client if you wish them to use dns. if you've not got DNS running on that machine, it's not a dns server, so is of no use. you can probably just copy the details from the windows. should be fine.

jkerr82508 07-13-2007 04:37 AM

Have you set up the XP machine for Internet Connection Sharing? There's a wizard of some kind that is supposed to do this.

Jim

Micik 07-13-2007 07:28 AM

Quote:

Originally Posted by acid_kewpie
it's not about making this work on mandrake... you need to supply a valid dns server to the client if you wish them to use dns. if you've not got DNS running on that machine, it's not a dns server, so is of no use. you can probably just copy the details from the windows. should be fine.

I have allowed ICS on WIN XP machine.
I have run all GUI services that configure network in Mandrake but didn't managed to make this work. I know probably there is a way by manually configure conf files, but I'm not an experienced user.
Since it worked on ubuntu by using GUI services, I think maybe I'm missing something on madrake or there's a bug.
How to enetr DNS server manually and where? I have entered DNS server using GUI program, but that didn't help.
Can you at least, give me a list of things I need to check?
Thanks

P.S. Since I manually entered info about gateway I can ping www.linuxquestions.org by its IP address (64.179.4.146), but when I type this IP address in web browser Konqueror I get error message: "Timeout on server"
I'm making some progress...

jschiwal 07-13-2007 07:35 AM

Run "ipconfig /all" on the windows machine. Write down the DNS addresses listed, and use the same addresses on the Mandriva machine, replacing the 192.168.0.1 and 127.0.0.1 entries, using the same GUI config program you used before. If you want to enter them manually, you can edit the /etc/resolv.conf manually.
The entries look like this:
Code:


nameserver 24.116.209.232
nameserver 24.116.0.202


Micik 07-13-2007 07:48 AM

Quote:

Originally Posted by jschiwal
Run "ipconfig /all" on the windows machine. Write down the DNS addresses listed, and use the same addresses on the Mandriva machine, replacing the 192.168.0.1 and 127.0.0.1 entries, using the same GUI config program you used before. If you want to enter them manually, you can edit the /etc/resolv.conf manually.
The entries look like this:
Code:


nameserver 24.116.209.232
nameserver 24.116.0.202


I've done that...
This is what I get on win machine:


Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
Physical Address. . . . . . . . . : 00-13-D4-B4-BE-E2
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

PPP adapter DialUp-Internet:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 85.92.230.250
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 85.92.230.250
DNS Servers . . . . . . . . . . . : 195.222.32.10
195.222.32.20

NetBIOS over Tcpip. . . . . . . . : Disabled


And this is resolv.conf file after I edited:

search local
# search 192.168.0.1 192.168.0.1 192.168.0.1 192.168.0.1 192.168.0.1 192.168.0.1
nameserver 195.222.32.10
nameserver 195.222.32.20
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 127.0.0.1
# nameserver 192.168.0.2

# ppp temp entry

But still nothing...

acid_kewpie 07-13-2007 11:36 AM

well this is clearly still a windows issue with with connention sharing. still unrelated to Linux. can you ping those DNS IP addresses? bet you can't...

Micik 07-14-2007 02:12 AM

Thank you all for the help.
I've turned off firewall on windows machine and it's working now.
I must figure out how to make exception and to turn firewall back on.
Thanks again

GlennsPref 07-16-2007 07:58 AM

My 2 cents, for a more secure network, have the windows box access the web through the linux box.

Much, Much better.

Regards, Glenn

siggma 07-17-2007 06:27 PM

Help, help again.
This thing tossed a long post. Thank in advance for making me retype it :)

I need help with the same issue as this.

I have two adapters:
Intel pro 100
Realtek

Both work OK alone. I can always get them to work.

I had an adapter that I thought was failing so I replaced it. Now I have eth0 eth1 and eth2 but the internet share wizard won't see the valid adapter. I've tried to remove the bindings between ethX and the hardware but I can't seem to find the config where they are defined.

Currently I have:
Realtek mapped to eth0
Intel mapped to eth2
nonexistent hardware mapped to eth1

The sharing wizard only sees eth0 as internet and eth1 as host share adapter and thinks it's a valid adapter. Obviously that won't work. I tried removing the udev mappings from 61-net_config.rules and rebooting, which clears the hardware mappings but the wizard still thinks it's a valid adapter. I assume these are configured in a chain so eth2 is never going to work unless eth1 is gone.

ifconfig
eth0 Link encap:Ethernet HWaddr 00:48:54:89:D3:04
inet addr:216.99.209.41 Bcast:216.99.209.255 Mask:255.255.255.0
inet6 addr: fe80::248:54ff:fe89:d304/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7131 errors:0 dropped:0 overruns:0 frame:0
TX packets:5399 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9519017 (9.0 MiB) TX bytes:552460 (539.5 KiB)
Interrupt:11 Base address:0xc000

eth2 Link encap:Ethernet HWaddr 00:D0:B7:6B:97:E2
inet6 addr: fe80::2d0:b7ff:fe6b:97e2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:146 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:22442 (21.9 KiB) TX bytes:2820 (2.7 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:92 errors:0 dropped:0 overruns:0 frame:0
TX packets:92 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6656 (6.5 KiB) TX bytes:6656 (6.5 KiB)

How do I delete or reset the hardware config the wizard is using so I can begin to debug the routing issues?

HELP!
siggma


All times are GMT -5. The time now is 01:47 PM.