LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 02-25-2005, 03:25 PM   #1
-=|Man0waR|=-
LQ Newbie
 
Registered: Feb 2005
Distribution: Ubuntu 5.10
Posts: 5

Rep: Reputation: 0
./configure error while compiling superkaramba .qt-mt required


hello..

My problem is as follows:
While running ./configure i'm getting stuck upown an error:
Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!

now the problem is that i've allready installed all the required rpms:
qt3-common-3.3.3-26mdk
libqt3-3.3.3-26mdk
libqtc1-3.2.3-9mdk
libqt3-devel-3.3.3-26mdk

I've noticed that i have an option for disabling mt.
--disable-mt link to non-threaded Qt (deprecated)

I'm realy frustrated with this...
Help me please with this problem becouse I realy don't want to configure with this option.

Thanks...
 
Old 02-25-2005, 07:00 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,503

Rep: Reputation: 174Reputation: 174
"Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!"

You can get that error for a variety of reasons. Some that come to mind are:

Qt was compiled without the --thread=mt option. SuSe used to do this in some of the earlier releases when qt-mt was buggy.

You don't have the qt3-dev package installed.

You don't have QTDIR pointing to the correct directory. Check QTDIR with:
echo $QTDIR
Then go to that location and see if ./lib contains some version of libqt-mt.so.

----------------------------
Steve Stites
 
Old 02-26-2005, 04:10 AM   #3
-=|Man0waR|=-
LQ Newbie
 
Registered: Feb 2005
Distribution: Ubuntu 5.10
Posts: 5

Original Poster
Rep: Reputation: 0
well... $QTDIR point to:
/usr/lib/qt3

and the qt-mt libs are in ./lib:
/usr/lib/qt3/lib/libqt-mt.so.3
/usr/lib/qt3/lib/libqt-mt.so.3.3
/usr/lib/qt3/lib/libqt-mt.so.3.3.3
/usr/lib/qt3/lib/libqt-mt.so

I've also used the --with-qt-libraries argument and still nothing
So... I don't know whats wrong...

By the way someone mentioned here earlier about dependencies saying "welcome to dependencies hell" ...well, I have a contribution to make to all other noobs around here ...WELCOME TO THE COMPILATION HELL!

Last edited by -=|Man0waR|=-; 02-26-2005 at 05:00 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling Kaffiene ./configure Error elliotfuller Linux - Software 1 04-27-2005 09:46 PM
aclocal configure.ac or configure.in required shooterfpga Linux - General 1 01-19-2005 05:38 AM
Error when compiling Superkaramba. z-vet Linux - Software 6 11-16-2004 02:04 AM
error compiling superkaramba 0.33 madlinux Linux - General 2 05-26-2004 03:23 PM
linker error compiling superkaramba seth_m Linux - General 1 10-15-2003 07:07 PM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration