LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Change Login Default Back to Root? (http://www.linuxquestions.org/questions/mandriva-30/change-login-default-back-to-root-261317/)

jbrush 12-01-2004 10:43 AM

Change Login Default Back to Root?
 
I am just experimenting, evaluating Mandrake 10, and have already installed multiple times to correct mistakes and overcome bad choices on the install, which although its frustrating, but I am learning by doing it more than once. :-)

I have always logged in as root, without a password. Please don't hate me. I am only running Linux to learn, its not on a network, and its certainly not mission critical, so I want all the rights to blow it up and learn it myself without having to constantly drop out and do SU commands. I always have a second user defined, for learning purposes, but root is how I want to log in, and always have.

The last time I installed, very late last night <g> I guess I inadvertantly left the button checked that automatically logged in a user, which means each time I boot, I am 'john' and not root. Well, I would like to go back to logging in as root, or at least have that choice to make at boot up, so I would like to know if there is a way to change something somewhere to allow me the option, or to automatically log in as root. When I log out of a session, the only choice I get is to log back in as 'john' There seems to be no place to choose to be the root for the entire session.

I don't want to keep opening consoles and doing SU. One day, when Linux is my main OS, I will follow the good advice and set up a user and only be root when needed, but for now, I do always want to have the option to log in as "root" but I seem to have lost that option somehow.

Anyone know the way to override the "auto logon" that I chose during install, without going back and reinstalling? I did a reinstall, without formatting, so that the installation went much faster and only updated a few things, but it never did ask me about the logon stuff, so unless there is something I can edit or change, I will have to reformat and start completely over, and I am sure that is not the only way to 'get there from here.'

Thanks for any help or pointers.

John

msalimane 12-01-2004 02:13 PM

First go to :
main menu --system -- configure -- configure ur computer -- enter ur password
it will show the mandrake control center click on boot and after on auto login
make sure that "No i don't want auto login is selected and click ok
Then go to :
main menu -- system -- configuration -- Kde -- system -- login manager
it will ask for ur root pasword
enter ur root password
it will show the login manager
then click on the users tab
on the left u have "show users" panel
make sure that "Not hidden" is selected , then in the middle u have the hidden users ,select the users u don't want see at the login but leave the root not selected as he's the one u want to use . Then click ok and reboot it will show the root user at the login and when u login using the root account , u can do everything without interruption
u cannot auto login with the root account , it's disabled in mandrake i think

jbrush 12-01-2004 02:59 PM

Quote:

Originally posted by msalimane
. Then click ok and reboot it will show the root user at the login and when u login using the root account , u can do everything without interruption
u cannot auto login with the root account , it's disabled in mandrake i think

Thank you very much. I sure do appreciate the detailed steps and it is all fixed up now. I hope you get a little happy at having helped someone in need, because it makes me feel good to find the help in the first place! :-)

Much obliged,

John


All times are GMT -5. The time now is 11:59 PM.