LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 08-05-2004, 09:05 PM   #1
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
CD-burner no longer recognized


Without my knowingly having changed anything, my NEC DVD/CD/CDRW writer stopped
working under Mandrake Linux 9.2 today. I can still use it to boot from, and to
restore Linux, which I've done at least five times today. But it won't be recognized
once Linux is running. I searched for at least three hours on these forums and elsewhere
and followed various leads and made various changes with no luck. At this point, I'm
stumped. I had it working under SCSI emulation for almost a year.

I notice that dmesg shows hdc and hdd devices, but the system insists that hdc
doesn't exist, and that scd0 doesn't exist. (Device labeled hdc is an ASUS CD-ROM (read
only) device that still gets recognized and works as before.)


...This is my lilo.conf:

boot=/dev/hda
map=/boot/map
install=menu
vga=normal
default="linux"
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda1
initrd=/boot/initrd.img
append="devfs=mount splash=silent hdc=ide-scsi hdd=ide-scsi acpi=ht resume=/dev/hdb5"
vga=788
read-only

... Here is my /etc/fstab:
/dev/hda1 / ext3 noatime 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 noatime 1 2
none /mnt/cdrom supermount dev=/dev/hdc,fs=udf:iso9660,ro,--,iocharset=iso8859-1 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=auto,ro,--,iocharset=iso8859-1,codepage=850 0 0
/dev/hdb1 /mnt/hd2 auto kudzu,user,nosuid,codepage=850,noauto,iocharset=iso8859-1,nodev 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

...Here's the result of lsmod:
Module Size Used by Not tainted
r128 81620 2
agpgart 53508 3 (autoclean)
sr_mod 17016 0 (autoclean) (unused)
lp 8160 0
parport_pc 25544 1
parport 34472 1 [lp parport_pc]
snd-seq-oss 32000 0 (unused)
snd-seq-midi-event 6080 0 [snd-seq-oss]
snd-seq 42544 2 [snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43652 0
snd-mixer-oss 14200 1 [snd-pcm-oss]
snd-via82xx 15360 1
snd-pcm 79588 0 [snd-pcm-oss snd-via82xx]
snd-timer 18436 0 [snd-seq snd-pcm]
snd-ac97-codec 45752 0 [snd-via82xx]
snd-page-alloc 9044 0 [snd-via82xx snd-pcm]
snd-mpu401-uart 4704 0 [snd-via82xx]
snd-rawmidi 17760 0 [snd-mpu401-uart]
snd-seq-device 5832 0 [snd-seq-oss snd-seq snd-rawmidi]
ipt_ttl 1144 0 (autoclean)
snd 41380 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-via82xx snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 6340 0 [snd]
ipt_unclean 7576 0 (autoclean)
ppp_deflate 4472 0 (unused)
bsd_comp 5400 0 (unused)
iptable_mangle 2712 0 (unused)
ipt_MASQUERADE 2200 0 (unused)
ipt_TOS 1592 0 (unused)
ipt_REDIRECT 1272 0 (unused)
iptable_nat 20814 0 [ipt_MASQUERADE ipt_REDIRECT]
ip_conntrack_irc 4400 0 (unused)
ppp_synctty 7520 0 (unused)
ppp_async 9312 1
ppp_generic 24292 3 [ppp_deflate bsd_comp ppp_synctty ppp_async]
slhc 6564 0 [ppp_generic]
ipt_state 1080 18 (autoclean)
ipt_REJECT 3960 4 (autoclean)
ipt_limit 1560 6 (autoclean)
ipt_LOG 4184 6 (autoclean)
ip_conntrack_ftp 5168 0 (unused)
ip_conntrack 26468 4 [ipt_MASQUERADE ipt_REDIRECT iptable_nat ip_conntrack_irc ipt_state ip_conntrack_ftp]
iptable_filter 2316 1 (autoclean)
ip_tables 15072 14 [ipt_ttl ipt_unclean iptable_mangle ipt_MASQUERADE ipt_TOS ipt_REDIRECT iptable_nat ipt_state ipt_REJECT ipt_limit ipt_LOG iptable_filter]
af_packet 14856 2 (autoclean)
via686a 9716 0 (unused)
eeprom 4628 0 (unused)
i2c-proc 8116 0 [via686a eeprom]
i2c-isa 1292 0 (unused)
i2c-viapro 4300 0 (unused)
i2c-core 20484 0 [via686a eeprom i2c-proc i2c-isa i2c-viapro]
isofs 28180 0 (autoclean)
udf 91840 0 (autoclean)
floppy 55932 0
8139too 17384 1 (autoclean)
mii 3864 0 (autoclean) [8139too]
supermount 84032 2 (autoclean)
ide-cd 34052 0
cdrom 32608 0 [sr_mod ide-cd]
ide-scsi 11376 0
scsi_mod 105792 2 [sr_mod ide-scsi]
usb-uhci 25136 0 (unused)
usbcore 74988 1 [usb-uhci]
rtc 9228 0 (autoclean)
ext3 60048 2
jbd 39360 2 [ext3]

...Here's what I get by running 'dmesg | grep '^hd.:'

hda: Maxtor 91021U2, ATA DISK drive
hdb: Maxtor 91303D6, ATA DISK drive
hdc: _NEC DVD+RW ND-1100A, ATAPI CD/DVD-ROM drive
hdd: ASUS CD-S400/A, ATAPI CD/DVD-ROM drive
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 20010816 sectors (10246 MB) w/512KiB Cache, CHS=1245/255/63, UDMA(66)
hdb: attached ide-disk driver.
hdb: host protected area => 1
hdb: 25450992 sectors (13031 MB) w/512KiB Cache, CHS=1584/255/63, UDMA(33)
hdd: attached ide-cdrom driver.
hdd: ATAPI 40X CD-ROM drive, 128kB Cache, UDMA(33)

I will be grateful for any suggestion! Thanks in advance.
 
Old 08-05-2004, 09:33 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
You have the ide-cd module being loaded at the same time as the ide-scsi so they are conflicting. I believe you need the line option ide-cd ignore=hdc (you may want to google on this I'm not positive on the exact format) in your /etc/modules.conf then reboot and see how it goes.

Code:
supermount 84032 2 (autoclean)
 ide-cd 34052 0 
 cdrom 32608 0 [sr_mod ide-cd]
 ide-scsi 11376 0 
 scsi_mod 105792 2 [sr_mod ide-scsi]
 
Old 08-05-2004, 11:37 PM   #3
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 47
Thanks, HappyTux, but that didn't work. Here's my modules.conf:
probeall usb-interface usb-uhci
above snd-via82xx snd-pcm-oss
alias eth0 8139too
alias sound-slot-0 snd-via82xx
probeall scsi_hostadapter ide-scsi
#next TWO lines added to try to get scsi emulation to work:
options ide-cd ignore=hdc
alias hdc ide-scsi
#at same time took out next line which was original 2nd line added:
#pre-install sg modprobe ide-scsi


I verified that your syntax was the right one, but it had no effect to add that line. The "TWO lines" referred
to, I had added ages ago when I first succeeded in getting the burner to work. The lines "options ide-cd ignore=hdc" and "pre-install sg modprobe ide-scsi" which I found SOMEWHERE on the Web after hours
of searching, did the trick then--but they've lost their magic now, apparently. I made no system changes
whatever between yesterday, when the burner worked fine, and today, when it's no longer recognized....
 
Old 08-06-2004, 12:23 AM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally posted by jonr
Thanks, HappyTux, but that didn't work. Here's my modules.conf:
probeall usb-interface usb-uhci
above snd-via82xx snd-pcm-oss
alias eth0 8139too
alias sound-slot-0 snd-via82xx
probeall scsi_hostadapter ide-scsi
#next TWO lines added to try to get scsi emulation to work:
options ide-cd ignore=hdc
alias hdc ide-scsi
#at same time took out next line which was original 2nd line added:
#pre-install sg modprobe ide-scsi


I verified that your syntax was the right one, but it had no effect to add that line. The "TWO lines" referred
to, I had added ages ago when I first succeeded in getting the burner to work. The lines "options ide-cd ignore=hdc" and "pre-install sg modprobe ide-scsi" which I found SOMEWHERE on the Web after hours
of searching, did the trick then--but they've lost their magic now, apparently. I made no system changes
whatever between yesterday, when the burner worked fine, and today, when it's no longer recognized....
I think I'm out of ideas on this one other than checking to see if the ide-cd is in your /etc/modules and if it is comment it out and you may want to uncomment pre-install sg modprobe ide-scsi. This is pretty much the exact reason I gave up on Mandrake to many strange little things like you have happening here with no apparent cause to them at all.
 
Old 08-06-2004, 01:10 AM   #5
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 47
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a `#', and everything on the line after them are ignored.

scsi_hostadapter
#ide-cd ignore=\"hdc hdd\"
ide-scsi

Above is my /etc/modules after I commented out a line.
Then I un-commented the "pre-install sg modprobe ide-scsi" line
in my /etc/module.conf file and rebooted. Still no luck.

But in my wanderings the past NINE HOURS, I've learned a new
command rmmod. So I figured it wouldn't hurt to try

rmmod ide-cd

and lo and behold, functionality of a sort was restored to the drive. I can
read and write with it just fine, though XCDRoast grumbles that I've now
selected an ATAPI drive for writing and will get miserable performance and
should institute SCSI emulation for it. In practice, it worked just as well as it ever
did before. In fact, isn't it under SCSI emulation now? Confused, but relieved
to be able to use the drive. Without your tips, I'd be sitting here all night trying
to get it to work. Now I can go to bed for a few hours!

Thanks very much.
 
Old 08-06-2004, 01:43 AM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally posted by jonr
and lo and behold, functionality of a sort was restored to the drive. I can
read and write with it just fine, though XCDRoast grumbles that I've now
selected an ATAPI drive for writing and will get miserable performance and
should institute SCSI emulation for it. In practice, it worked just as well as it ever
did before. In fact, isn't it under SCSI emulation now? Confused, but relieved
to be able to use the drive. Without your tips, I'd be sitting here all night trying
to get it to work. Now I can go to bed for a few hours!


Thanks very much.
Your welcome and good to hear you got it going, though that is definitely a strange one you could check with dmesg | grep scsi and see if it is getting detected as scsi and if you use KDE for a desktop you may want to look at installing K3B I do believe I recall seeing .rpm for Mandrake 9.x on their website it is a nice little app.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cd burner not recognized corbis_demon Slackware 8 04-14-2006 09:38 PM
dvd burner no longer mounts microwave_safe Linux - Hardware 2 11-17-2005 11:39 AM
Monitor no longer recognized noahbeane Linux - Hardware 1 06-13-2005 12:36 PM
Help: drive is no longer recognized after the system is up leisure Linux - Hardware 2 05-28-2005 05:53 AM
help - wireless card no longer recognized? dublin212 Linux - Wireless Networking 1 06-15-2003 08:03 PM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration