LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   Can't mount/access CD/DVDs (http://www.linuxquestions.org/questions/mandriva-30/cant-mount-access-cd-dvds-407868/)

JerryP 01-25-2006 11:43 AM

Can't mount/access CD/DVDs
 
I am running Mandriva 2006.1. My CD DVR RW (AOPEN DUW1608/ARR) is driving me nuts (where it hadn't been with 2005LE).
Essentially I can't get it to mount or stay mounted. I have CDs “all over the place” and I'd just like to clean the whole thing up and have one. What I have is /mnt/cdrom2 showing in KDiskFree. If I put in a music CD I'm informed that I don't have permission to /dev/hdd and that there is no disk in the drive.
Audio CD KDE Daemon tells me it can't access system:/media/hdd. /mnt shows a cdrom, a cdrom1 and a cdrom2 all of which report no items - no files - no folders.
Trying to mount the thing through MCC gives me a mnt point of /mnt/cdrom2 for where the CD/DVD burner is with DiskDrake.
I'm sure there is some sort of basic concept I'm missing here. Any suggestions to resolve this would be appreciated.

camorri 01-25-2006 01:19 PM

Let me see if I can get you started in the right direction.

First off, you do not ever mount a music CD. Don't bother trying, there is no file system on a music CD. They will play without being mounted.

You do have to mount any data CD in order to read it. I do not have a DVD drive, so I'm not sure I can help you there. To mount a data CD, you need a mount point in your file system. That is a directory that has to be added. Mandriva has GUI tools to allow you to create a mount point. From your post it sounds like you have a directory of /mnt/cdrom2 You can look at the directory structure easily by using Konqueror. On your desktop there will be a Home icon. Click it, and after it comes up, press F9. F9 opens the left panel to allow you to navigate the file system my clicking. Right panel will show the files.

You also need entries in /etc/fstab if you want to mount the device. As far as I know you need an entry for music CD's and one for data CD's. You can view (as any user) and edit that file as root. If you decide to change it, back the file up first. Here is what the line for playing CD's looks like for my CD reader.

/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0

Note, on my system this is the third drive, so it is hdc, if your drive is the forth, it will be hdd. The /mnt/cdrom is the file system mount point. This directory must be present in the file system. If it is not there, you can make it using the md (make directory command). Note the ro ( read only ). My drive is a R/W drive.

The second entry looks like this.

/dev/scsi/host1/bus0/target0/lun0/cd /mnt/cdrom1 auto pamconsole,exec,noauto,utf8,codepage=850,iocharset=iso8859-15,managed 0 0

Mandy created this one, I used the gui tools.

Work on one function at a time. Start out with getting a CD to play. My guess is you have sound working. Please let us know if that assumption is not right. If yes, bring up what ever program you want to play the music CD with and try it. Let us know what happens, including the lights on the player, post any error messages etc.

Next try to mount a data CD. You can do that from within Kdiskfree, or the command line. Have a look at your file system and fstab. You should only need one mount point. Not at all sure why you have more than one. Once again post any errors, and a copy of fstab.

As for the DVD part, have a look in the how-to's to get it going. I have read some info ( can't remember where ) on some libraries you may not have installed to get the DVD part going. There may be other posts also if you look around.

JerryP 01-25-2006 02:26 PM

Excellent reply and I appreciate your time. I have definitely learned something here although I still have the problem. Sound works fine - love that AmaroK and Radio Paradise. Here's what happens;

I put a music CD in the drive. KsCD opens with an error box the says “CD-ROM read or access error (or no audio disc in drive). Please make sure you have access permissions to:/dev/hdd”. KsCD doesn't show anything or do anything. Also “Audio CD – KDE Daemon” opens and asks me what I want to do.
If I say “play” it opens KsCD and I get “the same” message. If I say “open in a new window” it says, “Device doesn't have read permissions for this account. Check the read permissions on the device.” and it reports “No Items – No Files - No Folders”. Now, if I try to change permissions (checking “properties” I only get tabs for “general” and “preview”. It's the same for user as well as root. There is no tab to change permission. If I say to “Extract and Encode Audio Tracks I get the same error message and KAudioCreator reports there is no music CD.
If I say “play with Kaffeine” I get;

Kaffeine Part...
Ok.
KDE...
Found version: 3.5.0
Ok.
xine-lib...
Found version: 1.1.1
Ok.
WIN32 Codecs...
No WIN32 codecs found in /usr/lib/win32. You're not able to play Windows Media 9 files, newer Real Media files and some less common formats. Download the codecs here: http://www.mplayerhq.hu.
libdvdcss...
libdvdcss not found. You're not able to play encrypted (most commercial) DVD's. You can get the library here (but using it may violate copyright regulations of your country!): http://developers.videolan.org/libdvdcss.
DVD Drive...
Can't check DMA mode. Permission denied or no such device: "/dev/dvd".
DVB-Device...
No DVB-Devices found. The DVB related functions will be hidden.
Distribution...
Ok.
RESULT: Found some problems, but nevertheless Kaffeine may work.

It then says there is no music CD in the drive or the path to the drive is wrong.

I guess I'll have to tackle the DVD part later but it would be great to get the CD to play. BTW the CD/DVD player is bootable and that works so it's not a hardware matter.

Ta, Jerry

camorri 01-26-2006 10:02 AM

Quote:

Please make sure you have access permissions to:/dev/hdd
If you open up Konqueror, and navigate to the /dev directory, do you have a block device called 'hdd' ?

I had a similar problem when I first installed Mandriva 2006. It was pointed at a device hdc, and I could not play a CD either. I pointed it at /dev/scsi/host1/bus0/target0/lun0/cd and voila, music from the CD drive.

I can also can change read/write permissions and group ownership through that block device.

So, open up Konqueror, F9 for the left panel, and navigate to /dev and see if you have a /scsi/ folder. Follow that path (it should be similar to mine but because of hardware configuration, you could see bus1 or different target and lun numbers). Look for the block device at the end of the path. If It is there ( I think it will be ) open up KsCD and click on Extras --> Configure KsCD. Near the bottom you will see a area called CD Drive. There is a field there that probably says /dev/hdd on your machine. Edit the line to point at /dev/scsi/.... (to match your box). Click apply and give it a try.

Win32 codecs and libdvdcss should be available for install from urpmi. Have you set URPMI up yet? If not, here is a link to follow to get it going.

http://www.mandrivausers.org/easyurpmi/index.php

When you have URPMI working, just go to Install package from MCC and look for each package and install.

Post back your results...

JerryP 01-26-2006 02:32 PM

Thanks but I didn't get too far on your instructions. I don't have a /scsi folder. I did "locate" scsi in a terminal and there isn't one anywhere on the computer. While anticipating your reply I'm going to see if there are some scsi packages I can install that may create it.
Ta, Jerry

camorri 01-27-2006 09:20 AM

On the SCSI packages, that code will be part of the original distribution. You shouldn't need to download anything. The question for me is, what type of CD/RW-DVD do you have. I think we need to determine if ( it is a big if ) you need scsi support for your drive. A lot of drives use scsi emulation. Yours may not need it.

Would you post as much information about the drive as you can? Make model etc. Go to MCC and look in the hardware section for the drive. Most of the information you need should be listed there.

Some background. Mandriva uses a damon called udev to create devices for each piece of hardware. You generally don't need to worry too much about this, until you have a device that is not working; like your CD-DVD drive.

I think what is wrong is it is trying to use a device called /dev/hdd but it is not there or is not the correct device.

Somewhere in the /dev directory there should be a the correct device. If we can point the software, it probably will work just fine. You pointed out this is not a hardware issue, and I agree.

What you can try is - open konqueror, navigate to the /dev directory and look at the 'properties' of some of the most likely dev's. You may get a clew from MCC Hardware when you go to look up the information on the drive. For example, have a look at one like sr0 or sr1. If the properties say it is the CD, that is what you are looking for. It it not at all clear to mw why the wrong device gets configured.

If this drive needs scsi emulation, ( its been a while since I played with this ) I think you will have to use a command called insmod to insert scsi support into the kernel. Don't try that until we think you need it.

JerryP 01-31-2006 03:16 PM

Thanks for your time Cliff. It was too much for me and I've gone to the dark side. I'm now running Suse 10 and everything is working for me. I just didn't have the time to figure out the Mandriva problem and had to get productive. I did put Suse on HDC though and Mandriva is still on HDA so as soon as I work out how to mount things correctly so LILO will let me choose the distro (I imagine this can be done) I'll get back to trying to straighten Mandriva out in my "spare time". The main thing I like is RPMDrake and Easy URPMI. Yast just doesn't float my boat although there are certainly a lot of Suse RPMs available.
Thanks again and Ta,
Jerry

camorri 02-01-2006 08:56 AM

I'm glad you now have a productive system. Lilo is not bad to configure, I boot 3 systems with it on different drives.

I'm sure the CD problem is fixable. Post when ( and if ) you need some more guidance.

[CBLA]Green 02-16-2006 07:20 PM

woot from toronto eh? :P
I've got mandrake just set up on an old laptop that has a dvd drive (read only) and i'm having similar problems in gnome. is there anything that I need to set on my fstab to read the audio cd? also do you know how i might get an enhansed cd or w/e to work? all other mounts work just fine.
I've also got an even older desktop that can read audio cd's perfectly without tweaks and it's on mandrake too. is there anything that i can use as an example from that fstab to set up the laptop?

camorri 02-17-2006 08:47 AM

[CBLA]Green,

You do not need an entry in fstab in order to play a music CD. That is for data CD's that have data files. They could be .mp3's but they are data, not music until they go through the digital to analog converter.

Quote:

how i might get an enhansed cd or w/e to work?
To some degree this depends on the type of drive you have. There are scsi drives and ide drives. There is no simple answer. Start at MCC (Mandrake Control Centre) and see if you have the hardware detected. Here is what my drive looks like.

Identification
Disk identifier: ‎SAMSUNG CD-R/RW SW-252F
Media class: ‎cdrom
Bus identification
Device ID: ‎0
Connection
Bus: ‎SCSI
Channel: ‎0
Logical unit number: ‎0
Device
Old device file: ‎/dev/sr0
New devfs device: ‎/dev/scsi/host1/bus0/target0/lun0/cd
Misc
Drive capacity: ‎burner

Disk controller: ‎1
Module: ‎ide-scsi

It should see it as a R/W drive. There is a configuration button on MCC for the drive if you need to configure it.

fstab entries on my machine for the CD R/W look like this:

/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0

This entry should allow you to mount and read data CD's. Note, there are probably some differences such as /dev/hdc ... On my system I have two HDD's, so the CD reader becomes hdc. If you have one drive, it would be hdb.

The second entry allows writing. It looks like this :

/dev/scsi/host1/bus0/target0/lun0/cd /mnt/cdrom1 auto pamconsole,exec,noauto,utf8,codepage=850,iocharset=iso8859-15,managed 0 0

You have to have scsi support inserted in the kernel. To find out if it is inserted, form a konsole, type '/sbin/lsmod' ( without the quotes ). That will list the kernel loadable modules. Here is what the scsi module looks like on Mandriva 2006...

scsi_mod 120808 7 sg,sr_mod,ide_scsi,usb_storage,sd_mod,ahci,libata

Remember the module you insert may be different depending on the drive you have.

BTW, in the future it would be better if you started your own thread, rather than tag onto someone else's thread. It's OK to answer a thread, but not to hy-jack it.

One last thought, here is a link that will give you some technical help.

http://www.troubleshooters.com/linux/cdrw.htm

Hope this helps...

[CBLA]Green 02-20-2006 12:54 PM

Thanks,

sorry i had no intetion on hy-jacking :P. i just thought it might be easier to tag onto this on rather than start one for the same problem. I got it to read fine and was able to use Grip to rip them and play them in xmms (which was acting REAL funny). after i got xmms to stop crashing EVERY time i tryied to play an .ogg and the only way it would stay on is if i started in in a console. so I know that my driv is dectected, and i can see it in MCC. I'll have a look for the proper set up when i get home. thanks ppl :)

JerryP 02-20-2006 03:42 PM

Hi Cliff, JerryP back again. Still running SuSE so maybe this thread is geting a little whacky but my problem seems simllar. I now can't get my MP3 player to mount. I think that this does need a fstab entry but I can't figure out what it is. dmesg tells me the following but I don't know what to do with it.

[drm] Loading R200 Microcode
Vendor: SanDisk Model: SDMX1 MP3 Player Rev: 1.13
Type: Direct-Access ANSI SCSI revision: 00
SCSI device sda: 995328 512-byte hdwr sectors (510 MB)
sda: Write Protect is off
sda: Mode Sense: 23 00 00 00
sda: assuming drive cache: write through
SCSI device sda: 995328 512-byte hdwr sectors (510 MB)
sda: Write Protect is off
sda: Mode Sense: 23 00 00 00
sda: assuming drive cache: write through
sda: sda1
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
usb-storage: device scan complete
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0
Buffer I/O error on device sda1, logical block 1001216
Buffer I/O error on device sda1, logical block 1001217
Buffer I/O error on device sda1, logical block 1001218
Buffer I/O error on device sda1, logical block 1001219
Buffer I/O error on device sda1, logical block 1001220
Buffer I/O error on device sda1, logical block 1001221
Buffer I/O error on device sda1, logical block 1001222
Buffer I/O error on device sda1, logical block 1001223
Buffer I/O error on device sda1, logical block 1001216
Buffer I/O error on device sda1, logical block 1001217

My fstab looks like:

/dev/hda1 / ext3 acl,user_xattr 1 1
/dev/hdb1 /data vfat umask=000 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hda5 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/dvdrecorder /media/ subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0

Any suggestions? I just want to rw from the player. Couldn't do it with Mandriva either.

Cool on the LILO. I'm reading an article on setting up multiple boots for different distros. I'd like to have multiple root choices and share my one "/home" and one fat drive that have all my working files on them. I'm not sure that one distros /home will stay the same one to the other though.

Ta, Jerry

camorri 02-21-2006 09:28 AM

JerryP,

I do not have a mp3 player, but I do have Nikon camera memory cards I mount to retrieve peicures from. I have a Optex flash card reader that I connect to any available USB port.

Here is the fstab entry I have for that card.

/dev/sda1 /mnt/removable vfat pamconsole,exec,noauto,noatime,codepage=850,iocharset=iso8859-15,managed 0 0

I don't see an entry for sda1 or any other device that could be your mp3 player. Mandriva 2006 uses the udev damon for creating a device when you hot plug it. I would suggest you use konqueror and navigate to /dev directory. You will have lots of devices. Do this once without the mp3 player plugged in and I suspect you will not see any sda device. Then hot plug the device and look at konqueror again. You can either restart Konq or just use the refresh button. A device for the mp3 player should have been created. I think it will be treated as a mass storage device. My guess is the file system will be vfat; ( remember I'm just guessing ). On my system I created a directory /mnt/removable and added the line to fstab. Then you may need to issue a mount command. BTW I use KdiskFree to make life a little simpler for myself. In KdiskFree you will see a line for each line in your fstab. If you right click on a line, you get a pop up menu, and one option is to mount if it is unmounted, or umount if you want to remove the device.

Another thing you could try.... Open up MCC and go to Mount Points. There should be an icon to create, delete resize partitions. If you get the player mounted, you should see what looks like another disk tab, probably sda. Click it, and you should be able to see the type of formatting ( file system ) you have. I have never fromatted a memory card using MCC since I can do it on the camera. Not sure how you would do that with the mp3 player.

This thread has changed; from a CD/DVD problem to mp3...

Hope this gives you some more success...

new2penguin 02-21-2006 12:03 PM

I was also facing this problem an hour ago and started fiddling with my system settings and managed to get it fixed. All you need to do is to enter the KsCD configuration page and select the "CD Player" tab. Then uncheck the "Use direct digital playback option" found in the CD Drive section.

wingcom 03-12-2006 07:04 AM

Quote:

Originally Posted by new2penguin
I was also facing this problem an hour ago and started fiddling with my system settings and managed to get it fixed. All you need to do is to enter the KsCD configuration page and select the "CD Player" tab. Then uncheck the "Use direct digital playback option" found in the CD Drive section.

indeed, i found this too. However, i dont have a cable connected to my onboard soundcard for both my cd drives.

- When Kscd is started as wingcom when digital playback is turned on(via artsd or alsa: Allthough i cant change to alsa cus my /dev/cdrom is giving me errors and every time i look back the digital playback pops back to artsd :s) it doesnt work

- This configuration DOES work as root

- When digital playback is turned off, wingcom/kscd is able to playback the audio cd.


So any of you know which device/file to give permissions too? i guess alsa or something needs permissions on /dev/cdrom cus wingcom has and that works. Its just that "man" in the middle that needs permissions OR its not /mnt/cdrom that needs the permissions but something else - bad errormessage?

edit: sound works straight away in alsaplayer (via alsa, duh)

i'll look some more...
cheers,

wingcom


All times are GMT -5. The time now is 11:38 AM.