LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 01-18-2006, 06:42 PM   #1
bytebull
LQ Newbie
 
Registered: Jan 2006
Location: All over america
Distribution: Madriva
Posts: 9

Rep: Reputation: 0
Can only access USB external drive when in ROOT user


Hi,

I had to reinstall Mandriva 2006 (official) ((not free)) a second time to get access to my USB external drives. I will not let any profile I make access those drives, only when I log into ROOT account.

is there a fix for this?

or any suggestions about how I can manipulate my created accounts so I can grant them access using GROUPS?

Anyone?



~perplexed..
 
Old 01-18-2006, 06:53 PM   #2
bytebull
LQ Newbie
 
Registered: Jan 2006
Location: All over america
Distribution: Madriva
Posts: 9

Original Poster
Rep: Reputation: 0
120Gb Netdisk

that shouldn't matter as long as my USB is working because ROOT login gives me full access.

how can I give all users access on my OS?

THANKS.
 
Old 01-21-2006, 11:22 AM   #3
valyo_bg
Member
 
Registered: Jul 2005
Location: Bulgaria
Distribution: Mandriva 2011
Posts: 49

Rep: Reputation: 15
There are two reasons for this I think. Furst is if you choose "High" or more security level during installation of Mandriva. In this case only root can have access to additional drives and windows disks. Try to choose lower security level - Standard. There is a warning during installation about this.
Second is to enable access to your devices (partittions) for ordinary users. This can be done on Mandriva control center -> Mount points -> Partitions -> Toggle to expert mode -> Then click on needed partiton -> Unmount -> Options and then check option "umask=0". Then mount your device and everything should be OK.

Regards,
Valentin
 
Old 01-22-2006, 07:47 AM   #4
Richie55
Member
 
Registered: Nov 2004
Location: UK
Distribution: Mandriva 2010.1
Posts: 128

Rep: Reputation: 15
Hi, don't know if any of the above has worked, but here are somethings you may try.

Have you got your USB drvice to mount in fstab? If so then is it in read only mode, look at fstab and if it sayd RO change it to RW.

Secondly the directory you mount the device to, did you create it with the root account, if so you need to chage the permissions with chmod while the device is not mounted. to give everyone read write acess chmod +777 /mnt/whatever.

I know I had a similer problem with a usb pen and this sorted it.
 
Old 11-28-2006, 01:06 PM   #5
bytebull
LQ Newbie
 
Registered: Jan 2006
Location: All over america
Distribution: Madriva
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Have you got your USB drvice to mount in fstab? If so then is it in read only mode, look at fstab and if it sayd RO change it to RW.
Worked. Thanks a bunch. But now Having major issues with this distro on my new x64 desktop... It's always something eh? lol
 
Old 12-08-2006, 03:10 AM   #6
mr805newbie
Member
 
Registered: Aug 2004
Posts: 78

Rep: Reputation: 15
Smile

Quote:
Originally Posted by valyo_bg
There are two reasons for this I think. Furst is if you choose "High" or more security level during installation of Mandriva. In this case only root can have access to additional drives and windows disks. Try to choose lower security level - Standard. There is a warning during installation about this.
Second is to enable access to your devices (partittions) for ordinary users. This can be done on Mandriva control center -> Mount points -> Partitions -> Toggle to expert mode -> Then click on needed partiton -> Unmount -> Options and then check option "umask=0". Then mount your device and everything should be OK.

Regards,
Valentin
This worked for me!!!! I was all over this forum trying to get my Maxtor Onetouch III to work and the instructions above here worked. Thanks Valentin!!!

By the way I am using Mandriva 2007 Official Power Pack (the one you pay for).

Last edited by mr805newbie; 12-08-2006 at 03:11 AM.
 
Old 12-08-2006, 02:12 PM   #7
valyo_bg
Member
 
Registered: Jul 2005
Location: Bulgaria
Distribution: Mandriva 2011
Posts: 49

Rep: Reputation: 15
You are Welcome,

Regards, Valentin
 
Old 12-22-2006, 09:12 PM   #8
mr805newbie
Member
 
Registered: Aug 2004
Posts: 78

Rep: Reputation: 15
Quote:
There are two reasons for this I think. Furst is if you choose "High" or more security level during installation of Mandriva. In this case only root can have access to additional drives and windows disks. Try to choose lower security level - Standard. There is a warning during installation about this.
Second is to enable access to your devices (partittions) for ordinary users. This can be done on Mandriva control center -> Mount points -> Partitions -> Toggle to expert mode -> Then click on needed partiton -> Unmount -> Options and then check option "umask=0". Then mount your device and everything should be OK.
Why can't everything in Mandriva be this straight forward?
 
Old 01-03-2007, 08:24 AM   #9
mkhan919
Member
 
Registered: Jan 2007
Location: Valbonne, France
Distribution: Mandriva 2008 (Free)
Posts: 135

Rep: Reputation: 15
hi

i am having a similar kind of problem. In my case, the security level is set to "standard". When even i moung the disk, the disks do not show in "Drives" on the desktop. When i open console and do su, i can access the mounted drives. but when as a normal user i try it , on console or on graphical interface, i get the message that i do not have permission to access mnt. I tried changing the file permissions on /mnt and it worked. but as soon as i closed the root terminal and tried again , same problem. the permissions on /mnt are back to what they were before.. which is

drwx------ 10 root root 1024 Jan 3 14:00 mnt/

Can you suggest some solutions for this?
 
Old 01-03-2007, 04:30 PM   #10
tytower
Member
 
Registered: Jun 2006
Location: Oz
Distribution: Mandriva 10.0,10.1,10.2,2006,Mepis 6.0,Opensuse10.2,Puppy 2.14
Posts: 250

Rep: Reputation: 30
Did you even Read above first!- have you tried these?

Quote:
Second is to enable access to your devices (partittions) for ordinary users. This can be done on Mandriva control center -> Mount points -> Partitions -> Toggle to expert mode -> Then click on needed partiton -> Unmount -> Options and then check option "umask=0". Then mount your device and everything should be OK.
Have you got your USB drvice to mount in fstab? If so then is it in read only mode, look at fstab and if it sayd RO change it to RW.
Quote:
Secondly the directory you mount the device to, did you create it with the root account, if so you need to chage the permissions with chmod while the device is not mounted. to give everyone read write acess chmod +777 /mnt/whatever.

Last edited by tytower; 01-03-2007 at 04:31 PM.
 
Old 01-04-2007, 08:00 AM   #11
mkhan919
Member
 
Registered: Jan 2007
Location: Valbonne, France
Distribution: Mandriva 2008 (Free)
Posts: 135

Rep: Reputation: 15
i had tried to above mentioned solution before posting and it did not work for me.. However, the other thread that u mentioned on the mandrake forum, it did work and the problem is now some what solved

THANKS

just one small additional question

Is there a way we can specify a generic setting for all USB drives that i plug in the system, for example, a friend on mine brought a usb drive (40 gb) over and we tried to access it but there were problems.. The folder (/mnt/mydrive ) where mydrive is the label of the disk in windows, is created automatically but the access permisions are set so that only root can access it. Since i dont know the name of folder before hand, how can i provide settings for it in fstab ??
If i add this line

/dev/sdb1 /mnt/Temp ntfs rw,noexec,nosuid,nodev,sync 0 0

would it work if the attached harddisk has more than one partition....?
because at the moment, it creates a different folder for each partition??

So do we have to know the volume label and number of partitions before a user can mount it? or is there a way to make the automount utility set the permissions for users at well?

THANKS for the help


OKAY here is another bizare occurance.....
after i un mounted the Temp folder. Changed the file permissions to 777, then tried to mount it again....and strangely the now the permission of the mnt folder are set to allow access only to root. IT has happened before. Sometimes when i plug in a new drive, the permissions of mnt are changed so that only root can access it....
i would really appreciate any hint into what is going on here since i dont have any clue....

thanks

Last edited by mkhan919; 01-04-2007 at 08:24 AM.
 
Old 01-05-2007, 03:17 AM   #12
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Rep: Reputation: 47
Quote:
There are two reasons for this I think. Furst is if you choose "High" or more security level during installation of Mandriva. In this case only root can have access to additional drives and windows disks
It is worth mentioning that one can also play with sudo (visudo) and grant usage of mount to selected user(s) with root privilege.
It is an alternative, maybe not the best one, but can be appropriate in some cases
 
Old 01-05-2007, 05:48 PM   #13
mkhan919
Member
 
Registered: Jan 2007
Location: Valbonne, France
Distribution: Mandriva 2008 (Free)
Posts: 135

Rep: Reputation: 15
The security level is set to "standard".
can you shed any light on why do the access rigts are /mnt folder are being changed by mandriva???
f
 
Old 01-06-2007, 03:27 AM   #14
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Rep: Reputation: 47
maybe not why, but here is how
see drakperm
 
Old 01-06-2007, 12:14 PM   #15
mkhan919
Member
 
Registered: Jan 2007
Location: Valbonne, France
Distribution: Mandriva 2008 (Free)
Posts: 135

Rep: Reputation: 15
Thank you for your help

Soory for continuting to bother you, but ...
there is a rule in the permission that says that the /mnt/ is owned by root and the permissions are set to be 755 ( this this gives other users the ablity to read the /mnt folder)

in addition i have added the rule that that changes the security permissions to /mnt/ to 777.

But still the problem is not solved... Is there some tool that can be used to log when and why the security permissions on /mnt/ are changing...

Boy, it sure is a lot of bother on linux to simply let users mount their usb drives...lol
 
  


Reply

Tags
access, drive, having, maxtor, onetouch, usb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant access external HD as user, cant change permissions as root? Kramer Linux - Software 3 01-12-2006 03:56 PM
External USB disks --access as USER not ROOT 1kyle Linux - Hardware 4 10-31-2004 02:55 PM
External Hard Drive --No Access as USER only ROOT (10.1) 1kyle Mandriva 1 10-31-2004 10:09 AM
External USB drive -- only WRITE as root 1kyle Linux - Hardware 0 08-03-2004 11:00 AM
External Drive Mounted, Can't access as a user thewaker Linux - Hardware 4 08-14-2003 04:26 PM


All times are GMT -5. The time now is 02:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration