LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 08-03-2005, 03:05 PM   #1
Latem
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Mandriva 2005 LE
Posts: 44

Rep: Reputation: 15
can't halt the computer


For a long time now (probably since I upgraded to 10.2 and it's been getting worse with time), I am having problems with turning off my computer. I use KDE, and for example when I do "shut down" from the menu in KDE, it just logs me out into the screen with users, so I can login again. This doesn't happen all the time but, but probably 50% of the time. If this does happen, than sometimes I am able to turn off the computer by pressing Halt, but sometimes even that doesn't work. Then the only way I am able to turn of (thru the GUI, and not dropping to command line and halting manually), is to: Press Reboot which gives me the selection of boot options; choose Linux; then it returns to the user choosing menu again; and then pressing Halt finally actually works. I use the Mandriva desktop manager, the one with the list of users, and you click on one, and then u type in password. I haven't tried KDM yet. Anyone know why this is happening and how I can fix this? I've searched and all I got were results regarding people's halt routine not actually turning off the computer (ie power), and usually a prblem with ACPI. However this isn't my problem, once halt begins, everything is fine, and it's able to turn off the computer and power it down. It's just I have a hard time starting halt from KDE, or the login menu thing.

Thanks,

Latem
 
Old 08-03-2005, 06:09 PM   #2
springshades
Member
 
Registered: Nov 2004
Location: Near Lansing, MI , USA
Distribution: Mainly just Mandriva these days.
Posts: 310

Rep: Reputation: 30
When you get to the boot menu, lilo, can you hit escape then type in:

linux 3

and then boot that way. (This should work, if not, type in your default boot name then a space then 3). Now log in. Does the halt command work from here? If not, if you switch to super user (using the su command), does /sbin/halt work? You've said this is kind of a 50/50 so you may have to do it a couple times to get a feel for whether it is working or not.
 
Old 08-09-2005, 11:02 AM   #3
Latem
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Mandriva 2005 LE
Posts: 44

Original Poster
Rep: Reputation: 15
Sorry for such a late reply, I've been away.

From all experimentation I've done, manually halting works. dropping to command line at the login screen, and doing halt works. Even when pressing the "Halt" button doesn't. When I did linux 3, it worked. However it didn't boot very nicely for some reason. It gave a whole bunch of errors, and a few things FAILED, and it booted to command line and not the login screen. I think it couldn't start X for some reason.

Latem
 
Old 08-09-2005, 04:19 PM   #4
springshades
Member
 
Registered: Nov 2004
Location: Near Lansing, MI , USA
Distribution: Mainly just Mandriva these days.
Posts: 310

Rep: Reputation: 30
Well, the errors with booting to linux 3 are strange, but the command line isn't. That's what I was trying to get you to so you could try out using halt manually. Using the command linux 3 in lilo just boots you to run level 3 instead of run level 5 (which is what you'd normally boot to). Run level 3 boots to command line, run level 5 boots to graphical log in. It's something useful to know.

I'm a little busy now, but I'll check to see if I can find anything to help you later today.
 
Old 08-09-2005, 04:29 PM   #5
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
open console
#su
passwd
#poweroff
 
Old 08-10-2005, 03:11 AM   #6
springshades
Member
 
Registered: Nov 2004
Location: Near Lansing, MI , USA
Distribution: Mainly just Mandriva these days.
Posts: 310

Rep: Reputation: 30
Quote:
open console
#su
passwd
#poweroff
Only this doesn't help the problem that the OP actually posted about.


To the OP: a couple thoughts.

First, in the menu, try going to:
System > Configuration > KDE > System > Login Manager
Go to the shutdown tab. Check to see if the shutdown command is /sbin/halt.

Second, check to see if /usr/bin/halt is a link to /usr/bin/consolehelper (probably should also check to see that consolehelper actually exists too). This is how it is on my system.

Third, I noticed that my login display manager is actually KDM. And besides that, I did a default install of Mandriva for 2005 LE, and it actually did NOT install the Mandriva login display manager. I'm wondering if changing yours to KDM might actually be helpful.

Fourth, when you get to the login screen after trying to shutdown and having it fail, have you ever tried restarting the X server (control+alt+backspace or looking for the option) and then trying to shutdown again? I've had weird experiences with not being able to log in until restarting the X server (though my experiences have been easily traced to compiling a CVS version of Xorg to get dri working). I'm wondering if it's possible you could have a somewhat similar issue.

Fifth, if worst comes to worst and we can't get this fixed, since it seems like the halt command is working for you we could make a fairly easy work around. We could add either a menu entry or a shortcut in your taskbar that uses the command halt. The command halt shouldn't require super user access so it should just work. Having an icon that did this would simply halt your computer if you clicked on it. That's a fairly elegant solution even if we can't fix things the proper way.

Last edited by springshades; 08-10-2005 at 04:03 AM.
 
Old 08-12-2005, 07:57 AM   #7
Latem
Member
 
Registered: Sep 2004
Location: Canada
Distribution: Mandriva 2005 LE
Posts: 44

Original Poster
Rep: Reputation: 15
Thanks for all the suggestions. I'll double check on those. I've been using KDM for the last couple of days w/o any troubles, so I think KDM works ok. Plus it's themable which is nice, so I'll probably just end up using that.

Latem
 
Old 08-12-2005, 10:57 AM   #8
springshades
Member
 
Registered: Nov 2004
Location: Near Lansing, MI , USA
Distribution: Mainly just Mandriva these days.
Posts: 310

Rep: Reputation: 30
Glad you've got it working. While you're playing with themes, if you ever figure out how to completely get rid of the blue starry background that Mandriva uses, let me know. I think it's ugly. I've changed the bootsplash, the kdm theme, kde splash screen, the background for the kde splash screen, the desktop (all of these are different setting that you have to change in different places), but I still have one of the original Mandriva backgrounds show up twice during the boot up (I think just before and just after the login screen) for a few seconds each time.
 
Old 09-27-2005, 02:34 PM   #9
kalleanka
Member
 
Registered: Aug 2003
Location: Mallorca, Spain
Distribution: xubuntu
Posts: 547

Rep: Reputation: 38
got the same problem.

I will try kdm as well thanks for the ide.
 
Old 09-27-2005, 04:01 PM   #10
Maldain
Member
 
Registered: Jan 2005
Posts: 112

Rep: Reputation: 15
On changing the back grounds

Changing background is pretty easy in KDM depending on which backgrounds you want to change. You can change the log in backgrounds by just setting the background you want in the login manager. For instance my company wants their logo to be in the back ground of the login screen and as the background for individual x-users. So I just put the png file of the company logo in /usr/share/wallpapers and change the back ground to that logo in the login manager. For users I just set the background to display the logo and that eliminates the Mandrake logo background.

Now my problem is on the few systems where I'm running init 3 I get this stupid penguin as part of the background screen. It's really annoying. I fixed it kind of micky mouse by finding the png file Mandrake is using and erasing penguiin by painting over it with black. But I'd really like to not have that png display at all on those systems.

M. Lacy
Western Tool Supply
 
Old 04-15-2006, 11:09 PM   #11
kep51
LQ Newbie
 
Registered: Feb 2006
Location: Sacramento CA
Distribution: mandriva
Posts: 5

Rep: Reputation: 0
I have had the same proplem with Mandriva. Started with Mandrake about 2 months ago and all seemed to work ok upgraded that to Mandriva. I think I have installed and reinstalled Mandrake and Mandiva at least 2 dozen times learning how to fix and more importatantly how not to fix. It is a dual boot with XP pro. I have spent 2 weeks trying to fix the logon and off issue, as well a slow running internet and just a slow system period. Ipv6 was killing me. Seems it could still respond faster than it is. Mandrake did. Removing kat wacked the hell out of the system.
Ok I followed your advise (springshades) and put shortcuts for halt and reboot on the desktop. Then found that I only had a choice of XDM or XDM. At that point I installed 3 additional KDM packages. Now have a proper graphical login and can halt and reboot just fine.
The one thing that is still not right is switch user. It is there but click it and there is only a blank line. It does not do anything.
Any futher suggestions?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
halt sethgeekx86 Slackware 1 04-20-2004 01:07 PM
Halt Startup Hammy Linux - Software 4 02-29-2004 07:55 AM
halt rstmn957 Slackware 1 09-29-2003 08:29 AM
Don't halt? tr4nce Slackware 3 03-22-2003 10:15 AM
halt...by yourself please da Perp Linux - Newbie 2 12-21-2001 02:30 AM


All times are GMT -5. The time now is 10:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration