LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2005, 09:36 PM   #1
cegha
Member
 
Registered: Jul 2005
Location: Goose Creek, SC
Distribution: Mandriva LE 2005
Posts: 41

Rep: Reputation: 15
Azureus problems, specifically port 6881


ok i use azereus all the time in windows, so i know port 6881, is fowarded correctly, but on my linux machine, im getting, NAT error when i test it. Im not sure if i got a firewall running or not, so how do i check?

When i go under "Alter miscellaneuos internet settings" under status it says not connected, even though Azureus is running, Firefox is fully functional, and all the other internet settings list my DHCP servers, IP address, etc. So whats up with that?

Also i went under security tab, then the only option under there about firewall and i have FTP Server, Web Server, SSH server, and Windows File Sharing, enabled, and i clicked advanced and entered 6881/tcp 6881/udp, for misc ports, and that didn't seem to solve the problem either. So tell me where i need to open up port 6881.

Edit: Basically where are all the places i should look to make sure port 6881 is enabled.

Last edited by cegha; 07-19-2005 at 03:13 PM.
 
Old 07-19-2005, 04:33 PM   #2
z9_87
Member
 
Registered: Dec 2004
Location: Urbana, IL
Distribution: Ubuntu 6.10
Posts: 118

Rep: Reputation: 15
Do you have a router or external firewall? If so make sure 6881 is open on those ports as well. On my router opening any ports (tcp or udp) to file sharing clients doesn't work for some reason so I just set up the dmz to my machine.
 
Old 07-19-2005, 06:31 PM   #3
cegha
Member
 
Registered: Jul 2005
Location: Goose Creek, SC
Distribution: Mandriva LE 2005
Posts: 41

Original Poster
Rep: Reputation: 15
no external firewall, but on my rotuer i have 6881 fowarded correctly, i always get green smilies in windows when i download on Azureus, so i know it's done correctly, im messing with Samba in Webmin, ATM, and im going to poke around with firewall related stuff in there in a couple mins and see if i can't fix it.
 
Old 07-19-2005, 11:46 PM   #4
z9_87
Member
 
Registered: Dec 2004
Location: Urbana, IL
Distribution: Ubuntu 6.10
Posts: 118

Rep: Reputation: 15
First, what router do you have? Next have you tried to just download a file ignoring the errors? I used to have the linksys router NR041 or something like that and it was a royal piece. Even though it seemed like orts were forwarded and dmz was working they didnt seem to be. Azureus always told me that tcp and udp ports xxxx were not open. However I could still download the torrents.
 
Old 07-20-2005, 04:12 AM   #5
cegha
Member
 
Registered: Jul 2005
Location: Goose Creek, SC
Distribution: Mandriva LE 2005
Posts: 41

Original Poster
Rep: Reputation: 15
it's actually a newer one, model number BEFW11S4 ver.4, (Wireless B router, with 4 wired ports), like i said, on the windows machine i use, Azureus works 100% fine absoutley no problems, i did go look under my settings for it and i didn't think about it but it asks what IP address you want to foward the port for, so i set it to 192.168.1.102, which is my linux comp, and that still didn't fix the problem. Turned off firewall, (shorewall or something to that effect), and still no luck, when i test it i get NAT error. (that one menu option to test and make sure your firewall is etup correctly/port fowarding is enabled)

I'm sure i can download stuff with it, cause i downloaded the plugin safepeer (im always safe =)), and it downloaded fine, but it won't upload it at all, and when not fully connected (like have port 6881 fowarded, and stuff and have blue smilies), you get drastic speed reductions, or so i have heard, thats why port 6881 needs to be opened.

If i get too frustrated with it, i can always download the crap through my windows machine, and then move it over via Samba (which is already configured), but i'd rather be able to download directly to the linux machine (it's going to be running more, then the windows machine, and it's just really annoying to start it everytime i have to reboot for an windows update or whatnot).

Edit: Getting connection errors (figures).

Edit2: looking under "Linux firewall" settings in webmin, and under chain net2fw, it plainly says "Accept" "If protocol is UDP and destination is port 6881", and "Accept" "If protocol is TCP and destination is port 6881", so that should be fine, but doesn't azureus need to LISTEN in on port 6881? Wehre can i check to see if it's actually being listened in on?

Last edited by cegha; 07-20-2005 at 04:57 AM.
 
Old 07-20-2005, 04:19 AM   #6
cegha
Member
 
Registered: Jul 2005
Location: Goose Creek, SC
Distribution: Mandriva LE 2005
Posts: 41

Original Poster
Rep: Reputation: 15
also kinda has to relate to this (limewire also), when i click on this one file to start limewire it shows a bunch of stuff running in the terminal as it loads but if i close that limewire closes, and i notice if i start Azureus the same way (through the script or whatever) and then close it it closes out Azureus, but if i do cd /home/cegha/azureus, then do ./azureus that it shows the stuff loading in terminal, and then i can close it and it's fine. I'm just wondering why it closes ther stuff when launched from the scripts.

Edit: Also i find it weird i have done absoutley nothing to limewire and i get upwards of 40+kb/s downloads off there (well for pr0n anyways), and that workds just fine, no port fowarding, no tinkering with firewall settings, no nothing.

Last edited by cegha; 07-20-2005 at 04:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Testing port 6881....NAT Error - error in Azureus dr_zayus69 Linux - Security 20 05-26-2006 02:52 PM
how to make azureus (or any port forwarding) works in my suse 9.3 box and squid proxy efm Linux - Newbie 0 10-31-2005 02:22 AM
Azureus NAT error on port 6881 dealerman Fedora 3 08-21-2005 10:42 AM
open azereus port 6881 demmylls Linux - Security 3 12-17-2004 12:01 AM
6881 Port Opening? Bana Linux - Networking 1 02-16-2004 08:34 PM


All times are GMT -5. The time now is 09:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration