LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-26-2005, 07:05 PM   #1
grimlaur
LQ Newbie
 
Registered: Jan 2005
Location: West Palm Beach, Florida
Distribution: Slackware 11.0 / Suse 10.1
Posts: 20

Rep: Reputation: 0
Automount in LE 2005 cannot access cdrom drives


After upgrading to LE 2005 both the cd rom and cd-rw in my system stopped working.

I can view the contents of the disks in MC or any other editor (logged in as root) at /mnt/cdrom.
I cannot open the drives logged in as user in konqorer.
I get the following error: The file or folder /mnt/cdrom does not exist.
When a data disc is placed in eighter of the two drives. they mount automatically.

fstab

/dev/hdc /mnt/cdrom iso9660 user, iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
/dev/hdd /mnt/cdrom2 iso9660 unmask=0,user,iocharset=iso8895-1,codepage=850,noauto,ro,exec,users 0 0

I am not quite sure what the fix is or what my next step would be.
I anybody has a moment or sugesstion it would be appreciated.

grimlaur
 
Old 05-26-2005, 07:13 PM   #2
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Rep: Reputation: 30
Check your permissions..


ls -l /dev/cdrom
and
ls -l /dev/hdc

/dev/cdrom should have a --> /dev/hdc (which is a symlink).
You need the right permissions to access it, your fstab looks fine though.
-Jason
 
Old 05-26-2005, 07:25 PM   #3
grimlaur
LQ Newbie
 
Registered: Jan 2005
Location: West Palm Beach, Florida
Distribution: Slackware 11.0 / Suse 10.1
Posts: 20

Original Poster
Rep: Reputation: 0
OK - Thanks Jason:

ls -l /dev/hdc output is:
brw-rw---- 1 test cdrom 22, 0 May 22 12:45 /dev/hdc
ls -1 /dev/cdrom output is:
lrwxrwxrwx 1 root root 3 May 22 12:45 /dev/cdrom -> hdc

do these need to be changed to execute as well?

grimlaur
 
Old 05-26-2005, 07:31 PM   #4
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Rep: Reputation: 30
Hmm...

/dev/hdc /mnt/cdrom iso9660 user, iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0

I don't think that fstab line needs user twice, not too sure.
Mandriva could be different, I've never used it.

If it automounts, that is good, but you can't read the data?

When you view the data of a cd, you cd into the mount point, not the device in /dev.
So if the CD was automounted to /mnt/cdrom (which is mount point) or /mnt/cdrom2, then cd into either of those directories.

If the cd is not mounted, ls -l /mnt/cdrom or ls -l /mnt/cdrom2 will display no data.
if the CD is mounted to either location, you should see the data.
Try that and see what happens,
-Jason
 
Old 05-26-2005, 08:49 PM   #5
grimlaur
LQ Newbie
 
Registered: Jan 2005
Location: West Palm Beach, Florida
Distribution: Slackware 11.0 / Suse 10.1
Posts: 20

Original Poster
Rep: Reputation: 0
Jason-

Hey I had a lot to look at because of this:

Quote:
When you view the data of a cd, you cd into the mount point, not the device in /dev.
So if the CD was automounted to /mnt/cdrom (which is mount point) or /mnt/cdrom2, then cd into either of those directories.
i rearranged my autofs files to point to /dev/cdrom and dev/cdrom2
now, when i... ls -l /mnt/cdrom .....i get output: Permission denied.
and, when i ... ls -l /mnt/cdrom2.... i get output: Permission denied.

the names on my icons also grew they now state the dev and the mnt point CD-ROM (hdc) {/mnt/cdrom}
removing user from fstab removes the icons from my desktop completely.


grimlaur
 
Old 05-26-2005, 08:57 PM   #6
username17
Member
 
Registered: Aug 2004
Location: Norfolk VA
Distribution: Slackware 11
Posts: 230

Rep: Reputation: 30
Hmm,
When mounting something, this is the syntax:
mount /dev/device /mount/point
You may need to specify the filesystem, so:
mount -t auto /dev/device /mount/point

Auto can be replaced with several different filesystems, they're listed in "man mount".

So, since your two CD drives are /dev/hdc and /dev/hdc.
mount /dev/hdc /mnt/cdrom
and
mount /dev/hdd /mnt/cdrom2

fstab:
/dev/hdc /mnt/cdrom auto noauto,ro,user

with a config like that, you can specify either the device or mount point, when mounting.
So "mount /mnt/cdrom" or "mount /dev/hdc" would work.

I believe, by default, users don't have the ability to mount, but if the CDs are auto-mounting, then this may not be an issue.
The "noauto,ro,user" options can be changed depending on your setup.
I've gotta run, play around with the above and I'll be home in 30mins or so.
GL,
-Jason
 
Old 05-28-2005, 06:32 PM   #7
grimlaur
LQ Newbie
 
Registered: Jan 2005
Location: West Palm Beach, Florida
Distribution: Slackware 11.0 / Suse 10.1
Posts: 20

Original Poster
Rep: Reputation: 0
Jason - it's been a while but i am back with an answer.

Mandrake linux allows for a general security level setting i had switched the security from standard (ie: network client) to higher because i was testing mod_ssl and open_ssl on this machine.

when you swith the security settings it appears that mandrake does not allow the CD-rom files to be shown through the graphical interface.

The drives always mount and if you log in as root you have access. but if you are logged in as user no access.

When I set the security levels back to normal the drives just automatically work. No problems.

I can't explain it, but I can accept it as valid. Thanks for your help, I really do appeciate it.
I think once i am a little more confident in my linux skills i will switch to slackware for my servers.

Matthew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot access cdrom drives question M$ISBS Linux - General 2 10-27-2005 08:07 PM
FC2 can't access CDROM drives kipper Fedora 2 11-08-2004 01:44 PM
automount cdrom and pen drives mokojin Slackware 3 10-31-2004 02:56 PM
Give user permission to mount/use cdrom drives or usb drives zwyrbla Linux - Newbie 2 08-23-2004 04:30 PM
Cannot access cdrom and floppy drives navarre9 Linux - General 2 01-12-2004 11:58 AM


All times are GMT -5. The time now is 07:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration