LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 02-23-2004, 08:41 AM   #1
kenbo
LQ Newbie
 
Registered: Feb 2004
Location: upstate NY
Distribution: Manmdrake 9.2
Posts: 12

Rep: Reputation: 4
ATI 8500DV finally got it but still some problems


Through lots of searching and trial and error. This noobie actually got both 3D accel and TV tuner to work on Mandrake 9.2!

After recompiling the kernel acouple of times (and actually have it boot!)
I ended up installing Xfree86 4.4 RC 2 then installed the latest DRM-kernel and ati.2 drivers from gatos. and vola' everything worked!

Almost....

KDM now crashes when It starts, tuxracer works but crashes the computer on exit, Armagetron wont start.

both armagetron and KDM.log have the same error:

error while loading shared libraries: libXxf86vm.so.1: cannot open shared object file: No such file or directory


I looked in /usr/ X11R6/lib and found libXxf86vm.so.1 is a link to shared library libXxf86vm.so.1.0. So it appears that it's there. so why doesnt anything seem to find it?

There are no errors in the Xfree86.0.log


Any help would be appreciated big tim. I'm sooooo close!

Kenbo

Last edited by kenbo; 02-23-2004 at 08:43 AM.
 
Old 02-27-2004, 08:13 AM   #2
kenbo
LQ Newbie
 
Registered: Feb 2004
Location: upstate NY
Distribution: Manmdrake 9.2
Posts: 12

Original Poster
Rep: Reputation: 4
OK I think I got it (only still kinda) . I completely reinstalled mandy updated the kernel from my update cd. recompiled with drm off and support for my sis 735 chipset on (found it was turned off). then installed Xfree 4.4.0 RC2 then drm-kernel and ati.2 from gatos. Now everything works EXCEPT when I exit any full-screen games the computer crashes and sometimes my monitor says "out of range"


ANY help would be greatly appreciated!
Ken
 
Old 02-27-2004, 06:29 PM   #3
kenbo
LQ Newbie
 
Registered: Feb 2004
Location: upstate NY
Distribution: Manmdrake 9.2
Posts: 12

Original Poster
Rep: Reputation: 4
Now I think I'm going crazy!

About 15 min after I made the last post. I left the room, came back afew min later. and saw the screensaver was moving slow. I tried glxinfo and the xserver crashed. I restarted x and then glxinfo sayd "direct rendering: no" again. Xfree log still says directrendering enabled and no errors other than

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/localhost:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

Which it has said since I upgraed x to 4.4

It was working then it wasn't all in the same session.
How can accel. stop in the middle of use?
I did install acouple of pakages (yahoo msgr, and mldonkey) but nothing that had to do with this.


someone HELP!
 
Old 02-29-2004, 12:47 AM   #4
kenbo
LQ Newbie
 
Registered: Feb 2004
Location: upstate NY
Distribution: Manmdrake 9.2
Posts: 12

Original Poster
Rep: Reputation: 4
for completeness sake. I found that ATI_GLX... that mandrake installs got in the way. All I had to do was uninstall that. and now everything works!


Thanks for all the helpful hints.
(well maybe not in this thread but elsewhere around the forum)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon 9800XT driver installation finally solved lightweave Linux - Hardware 4 01-08-2005 12:11 AM
ATI AIW 8500DV, crashes with 'no screens found' when using radeon module. metagore Linux - Hardware 14 03-17-2004 02:22 PM
finally got the ATI drivers working in 9.2... trey85stang Mandriva 2 12-01-2003 12:46 PM
Radeon All-In-Wonder 8500DV and RedHat 9 ? Klein Linux - Hardware 1 10-12-2003 03:01 PM
Getting TV to Work --8500DV RH9 chiefjoe Linux - Hardware 10 09-19-2003 10:43 AM


All times are GMT -5. The time now is 04:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration