LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 10-18-2003, 01:31 AM   #1
dzel
LQ Newbie
 
Registered: Oct 2003
Posts: 2

Rep: Reputation: 0
ASUS A7VX8 audio driver


HELLLLLLLLPPPPPPPPPPP!

I got these messages when I tried to install the motherboard's audio driver

rpm --rebuild viaudiocombo-2.2-1.src.rpm
error: cannot open viaudiocombo-2.2-1.src.rpm: No such file or directory
[root@edwin viaudiocombo-2.3-1]# rpm --rebuild viaudiocombo-2.3-1.src.rpm
Installing viaudiocombo-2.3-1.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.25517
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd /usr/src/RPM/BUILD
+ rm -rf viaudiocombo-2.3
+ /bin/gzip -dc /usr/src/RPM/SOURCES/viaudiocombo-2.3.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd viaudiocombo-2.3
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.25517
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd viaudiocombo-2.3
+ ./install.sh
Could not find Linux directory, please link it with /usr/src/linux
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.25517
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd viaudiocombo-2.3
+ rm -rf /usr/src/RPM/BUILD/viaudiocombo-root
+ mkdir -p /usr/src/RPM/BUILD/viaudiocombo-root/etc/init.d
+ mkdir -p /usr/src/RPM/BUILD/viaudiocombo-root/lib/modules/2.4.21-0.13mdk/kernel/drivers/sound
+ install viasound /usr/src/RPM/BUILD/viaudiocombo-root/etc/init.d/viasound
++ uname -r
+ install -m 644 viaudiocombo.o /usr/src/RPM/BUILD/viaudiocombo-root/lib/modules/2.4.21-0.13mdk/kernel/drivers/sound/viaudiocombo.o
install: cannot stat `viaudiocombo.o': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.25517 (%install)

I also tried another version that's viaudiocombo-2.2-3 same thing happens

rpm --rebuild viaudiocombo-2.2-3.src.rpm
Installing viaudiocombo-2.2-3.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.68035
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd /usr/src/RPM/BUILD
+ rm -rf viaudiocombo-2.2
+ /bin/gzip -dc /usr/src/RPM/SOURCES/viaudiocombo-2.2.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd viaudiocombo-2.2
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.68035
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd viaudiocombo-2.2
+ ./install.sh
Could not find Linux directory, please link it with /usr/src/linux
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.68035
+ umask 022
+ cd /usr/src/RPM/BUILD
+ cd viaudiocombo-2.2
+ rm -rf /usr/src/RPM/BUILD/viaudiocombo-root
+ mkdir -p /usr/src/RPM/BUILD/viaudiocombo-root/etc/init.d
+ mkdir -p /usr/src/RPM/BUILD/viaudiocombo-root/lib/modules/2.4.21-0.13mdk/kernel/drivers/sound
+ install viasound /usr/src/RPM/BUILD/viaudiocombo-root/etc/init.d/viasound
++ uname -r
+ install -m 644 viaudiocombo.o /usr/src/RPM/BUILD/viaudiocombo-root/lib/modules/2.4.21-0.13mdk/kernel/drivers/sound/viaudiocombo.o
install: cannot stat `viaudiocombo.o': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.68035 (%install)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.68035 (%install)

Any help is greatly appreciated.
 
Old 02-25-2004, 12:41 PM   #2
JonyKyte
LQ Newbie
 
Registered: Dec 2003
Distribution: Redhat
Posts: 17

Rep: Reputation: 0
Hi,

Just wondered if you'd managed to find a solution as I'm having similar problems.

Thanks
 
Old 02-25-2004, 07:23 PM   #3
uvone
LQ Newbie
 
Registered: Aug 2003
Location: Brisbane, Australia
Distribution: slackware-current
Posts: 25

Rep: Reputation: 15
i assume you have the nVIDIA chipset on your motherboard. i could be wrong but i think you need the kernel source installed. that will let you build the rpm, if i remember correctly you will find the new rpm in /usr/src/linux. it should get outputted anyways.

hope this helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to use audio driver on an Asus A8N-VM CSM lukeb Fedora 3 02-07-2006 05:00 PM
Audio driver for ASUS board and HP 1150 Laser PRinter Driver ccatindia Linux - Hardware 1 05-11-2004 03:20 AM
ASUS A7VX8 audio driver for Mandrake 9.1 dzel Linux - Hardware 1 10-18-2003 08:06 AM
audio driver for ASUS A7V8X-X motherboard erickvaldez Red Hat 1 10-15-2003 05:40 AM
driver for ADI AD1985 "82801EB AC'97 Audio" sound card ??? (Asus P4C800) christophe.dr Linux - Hardware 3 09-07-2003 02:46 PM


All times are GMT -5. The time now is 12:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration