LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 04-26-2004, 06:34 AM   #1
viluve
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
ALSA - 5.1 doesn't work with Xine / Totem


Hi everyone,

I'm using Mandrake 10, Audigy sound card and enabled the ALSA driver.
Using xmms to play mp3, ALSA works perfectly (using the ALSA plugin) with sounds coming from all 5 speakers. But when I tried to play mp3 using Totem or Xine, the sound only come out from the 2 front speakers ( I've made sure the vol. for centre & rear speakers are not on 0 )

I did the test sound on the hardware config. and the sounds came from all 5 speakers which is good, and also during the booting process.. I can see that ALSA driver is loaded succesfully.

Thanks in advance

vito
 
Old 04-26-2004, 09:39 AM   #2
[NL]_Target
Member
 
Registered: Aug 2003
Distribution: Arch Linux 0.7
Posts: 81

Rep: Reputation: 15
i'm not quite sure about this, since i don't have 5 speakers so I'm not speaking from experience, but what comes to mind is that xmms might be using some form of mixing the stereo sound to 5.1 sound so it goes to all speakers. Did you configure Totem and Xine to use ALSA? If so, then I think that it's some plugin for XMMS. Try playing a DVD with xine, if sound comes from 5 speakers when you play a 5.1 cd, then it is just the fact that xine plays stereo sound over 2 speakers, and xmms does it over 5. If xine still plays over 2 speakers when you know that the audio is 5.1, then you could check the xine website, cause then there is something wrong in xine... good luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Totem, Xine, ... no audio D-Vine Linux - Software 3 09-20-2005 01:03 PM
Tried to install Xine now Totem won't work jallingt Linux - Software 10 07-05-2005 05:53 PM
XMMS, Xine, MPlayer and Totem don't work in KDE 3.2 sdr_ar Mandriva 6 12-30-2004 07:51 AM
Totem/ Totem-xine regorbro Linux - Software 1 12-11-2004 10:32 PM
totem and xine problems d1l2w3 Linux - Software 2 09-16-2004 09:34 AM


All times are GMT -5. The time now is 12:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration