LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   2.6.8 Ltmodem support (http://www.linuxquestions.org/questions/mandriva-30/2-6-8-ltmodem-support-250085/)

elberto 11-02-2004 12:40 AM

2.6.8 Ltmodem support
 
Hi,

Im running Mandrake 10.0 Community with the 2.6.8 kernel (its actually more 10.1 then 10.0). I have an Lucent Winmodem (ltmodem) and need some working drivers, can anyone tell me where I can find them?

Them drivers at ltmodem.heby.de compile correctly but don't work, with error message "... invalid module format" when running ./checkout or modprobe.

Rob

aRTee 11-02-2004 01:16 PM

I just installed the ltmodem from that very site onto my laptop which is running Mandrakelinux 10.1 OE; get the one that says: support for RH 2.6.7 kernel.

Oh, and make sure you have development stuff installed.


On second thought, I think that you may have a mismatch of the kernel source and the running kernel...? Strange since the install scripts check everything...

RonnyBaby 11-03-2004 06:05 PM

I have also tried installing an ltmodem into 2.6.8.1 MDK 10.1 final

After typing in the line: modprobe ltserial
This is what I get back:
inserting ltmodem(/lib/modules/2.6.8.1-10mdk/other/ltmodem.ko)
Fatal Error ocurrs: invalid module format

I used driver: ltmodem-2.6.3-4mdk.tgz

Don't know if it matters that much... but do I need a different driver?

Hey... I'm a :newbie: what can I say? Go easy on me!

Thanks for any help provided!!

aRTee 11-04-2004 05:29 PM

ltmodem-2.6.3-4mdk.tgz is likely a package for the 2.6.3 kernel, whereas 10.1 has a 2.6.8.1 kernel.

Just go to the above website, and find this:
http://www.physcip.uni-stuttgart.de/...-8.31a8.tar.gz

Follow the instructions at the website, and it should work.


All times are GMT -5. The time now is 12:44 AM.