LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 01-28-2005, 11:24 PM   #1
jdecock
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Rep: Reputation: 0
10.1 Refuses to Load KDE/Gnome/etc.


I'm attempting to install Linux for the first time, so my experience is very limited. I'm basing my information about what is supposed to happen off the screenshots found at shots.osdir.com/slideshows/slideshow.php?release=193&slide=1.

I have a computer with an ASUS A8V Deluxe VIA K8T800 Pro motherboard, an AMD Athlon 64 3800+ processor, and an nVIDIA GeForce 6800 GT 256MB graphics card. I'm using the download version of Mandrake 10.1 Official.

When I try to install the OS, everything goes smoothly until I get to the Summary screen. It informs me that it couldn't detect the correct Graphical Interface. I click on Configure, leave it on GeForce 6800, select my monitor (Gateway VX900), and set the resolution. When I press Test, though, it gives me an error. I've tried a LOT of different configurations, but haven't found anything that works, so I left it on the closest I could find to my actual configuration.

Now, when Linux boots, it goes to a command line and asks me to login. Even after loggin in, however, I still don't have access to a GUI, just the terminal. I know that when I installed I said to automatically log me into the system using KDE.

I also tried manually installing the latest nVidia drivers that I downloaded using FTP, but they refused to install.

--
Jason
 
Old 01-28-2005, 11:49 PM   #2
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
When selecting driver for your graphic card, rather than selecting "GeForce 6800" try scrolling down the list to the xorg section and choose"nv" instead. Then try the test on that driver and see if it works for you.

Last edited by Lakota; 01-28-2005 at 11:51 PM.
 
Old 01-28-2005, 11:59 PM   #3
jdecock
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Lakota
When selecting driver for your graphic card, rather than selecting "GeForce 6800" try scrolling down the list to the xorg section and choose"nv" instead. Then try the test on that driver and see if it works for you.
I tried that without any luck. I do have some additional information that may be useful, though. I tried the startx command and received the following error:

Code:
[bunch of X version info]

Using vt 7
(EE) Failed to load module "usr/X11R6/lib/modules/extensions/libglx.a" (once-only module, 135962511
)
((EE) No devices detected

Fatal server error:
no screens found

Please consult The X.Org Foundation support
     at http://wiki.X.org
for help
Please also check the log file at "var/log/Xorg.0.log" for additional information

XIO: fatal IO error 104 (connection reset by peer) on X server ":0.0"
     after 0 requests (0 known processed) with 0 events remaining
--
Jason
 
Old 01-29-2005, 04:38 AM   #4
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
appears to be choking trying to load gl
Quote:
(EE) Failed to load module "usr/X11R6/lib/modules/extensions/libglx.a"
how about we disable gl and see if your GUI will then start

You will need to learn Vi basics at some point in time so here you go.
Vi has two modes, command and insert. It opens to command by default, to put it into insert mode press the "i" key. To get back to command mode hit "escape" key. Not sure which you are in?, simply hit "escape" key a few times and you are at command mode. Use the four arrow keys to move cursor around the screen. Made a mess of things and want to abort without saving, use escape key to get to command mode and press the":" key then the "q" then the "!" and "enter". Made the changes and you want to save the file and exit, use escape key to get to command mode and press the":" key then the "w" then the "q" and "enter". w is write command, q is of course quit. (BTW when you get your gui working there are graphical editors such as kate, much like notepad from windoze, but they are inaccessable till you get your GUI.)
Code:
[don@x1-6-00-0a-e6-91-be-32 X11]$ su
Password:
[root@x1-6-00-0a-e6-91-be-32 X11]# vim /etc/X11/xorg.conf
so, now use arrow keys to find the "glx" entry in the "Section "Module"". Move the cursor over the "L" in the line "Load "glx" # 3D layer". Now you will hit the "i" key to get into insert mode". Now press the "#" key to insert it. (If you have not seen this before it is "commenting out" . It is better than deleting, as it is there if you need to reverse it later, but commenting something out will stop it from executing.) So now we want to save it. Hit the "escape" key a couple of times to get to command mode. Now press the":" key, then the "w" then the "q" then the "enter"
Here is an example of our end result.
Code:
Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
   #Load "/usr/X11R6/lib/modules/extensions/libglx.so"
   #Load "glx" # 3D layer
EndSection
now I would like to think your GUI will fire up. Use the command "startx" and lets hear what happens.

*If still no go, could you post the content in the device section of your xorg.conf file. (you can copy that down while you have it open in vim for editing
Code:
Section "Device"
    Identifier "device1"
    VendorName "nVidia Corp."
    BoardName "NVIDIA GeForce2 DDR (generic)"
    Driver "nvidia"
    Option "DPMS"
EndSection
as well as what libglx files reside in your /usr/X11R6/lib/modules/extensions
Code:
[don@x1-6-00-0a-e6-91-be-32 X11]$ cd /usr/X11R6/lib/modules/extensions
[don@x1-6-00-0a-e6-91-be-32 extensions]$ ls
libdbe.a  libextmod.a  libglx.so.1.0.6629*  libxtrap.a
libdri.a  libglx.so@   librecord.a
[don@x1-6-00-0a-e6-91-be-32 extensions]$
 
Old 01-28-2006, 01:49 PM   #5
Borgs8472
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
Hey there, I'm also trying to install mandriva, been searching for ages now.

I got the same problem and applied your suggestion to disable the glx thing. That got rid of the "Failed to load module "usr/X11R6/lib/modules/extensions/libglx.a" error in question.

However I still get

"open /dev/fb0 No such file or directory"

which seems to stop things too.

Like the thread starter, I am a complete newbie to linux and installing mandriva completely from scratch and can't get as far as the GUI.
 
Old 01-28-2006, 05:15 PM   #6
Borgs8472
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
Hmm, all fixed, it seems the resolution of 1600x1200 which is defaulted to it didn't like. Forcing it to 1024x768 things are working just fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to load KDE/Gnome? SirJinX Linux - Distributions 6 07-11-2005 10:04 PM
KDE won't load - and either will gnome!!! help?! ada601 Linux - Software 4 06-06-2004 06:21 PM
Slackware 9.1 refuses to install KDE / GNOME brotulix Slackware - Installation 4 03-18-2004 05:16 AM
Installed Mandrake Linux 9.1... Gnome seems to work, but KDE refuses to load. swamiji Mandriva 4 11-28-2003 11:54 PM
Help, can't load KDE or GNOME? wjsulliv Linux - Newbie 1 02-16-2002 01:34 PM


All times are GMT -5. The time now is 10:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration