LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-21-2004, 08:16 AM   #1
riseringseeker
Member
 
Registered: Aug 2004
Posts: 31

Rep: Reputation: 15
10.0 hangs on shutdown


I have Mandrake 10.0 installed, and have a dual boot with windoze XP Pro. I use LILO for the boot manager.

LILO does just fine when rebooting back to Mandrake, or if I choose to boot to XP from the login screen. If I choose "Restart Computer" from within a session, it works. If I choose "Turn Off Computer", from either the login prompt, or from within a session, it hangs, and I end up having to turn the computer off. (I've left it for 20 minutes - still hung).

I did not have this problem when ran 9.0, or 9.2. I hope someone can give me a place to look to solve the problem.
 
Old 09-21-2004, 12:05 PM   #2
eqxro
Member
 
Registered: Apr 2004
Location: Outer space :D
Distribution: Gentoo 2005.0 amd64 2.6.14-dfx3
Posts: 203

Rep: Reputation: 30
MDK has the default acpi=ht option passed to the kernel. Edit as root /etc/lilo.conf and try removing the option (if it's there). Don't forget to re-run lilo. You have to reboot in order to see if it works. This worked for me when i switched from AT to ATX.
 
Old 09-21-2004, 02:58 PM   #3
riseringseeker
Member
 
Registered: Aug 2004
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by eqxro
MDK has the default acpi=ht option passed to the kernel. Edit as root /etc/lilo.conf and try removing the option (if it's there). Don't forget to re-run lilo. You have to reboot in order to see if it works. This worked for me when i switched from AT to ATX.
Tried editing the file, turns out I have 4 lines with that string in it. the strings are:

"devfs=mount acpi=ht resume=/dev/hda6 splash=silent"
"devfs=mount splash=silent acpi=ht resume=/dev/hda6"
"devfs=mount acpi=ht resume=/dev/hda6 splash=silent"
"devfs=mount acpi=ht resume=/dev/hda6 splash=silent"

I'm still not using vi, or other line editor, but used Kwrite as root (I know I need to learn how to use vi/vim, but haven't yet).

I added a "#" at the front of each line, and ran lilo (as root), still hangs, giving me:

Halting system...
md: stopping all devices
md: md0 switched to read-only mode.
Power down

That's where it stops
 
Old 09-21-2004, 03:54 PM   #4
eqxro
Member
 
Registered: Apr 2004
Location: Outer space :D
Distribution: Gentoo 2005.0 amd64 2.6.14-dfx3
Posts: 203

Rep: Reputation: 30
Well, in fact you should have deleted only the "acpi=ht" part, not comment the whole line. Some entries are still useful . Each entry corresponds to a certain boot option.. You can either delete them all, all delete only the one in your current option. Also, you can try "acpi=off". Check my thread. The last post particularly. For me, removing the acpi option did the trick, then again, I'm using a custom-compiled kernel .

I was getting the "Power down." message and no power-off before I removed the "acpi=ht" option. After that, It went down by itself the first time.
 
Old 09-21-2004, 08:11 PM   #5
riseringseeker
Member
 
Registered: Aug 2004
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by eqxro
Well, in fact you should have deleted only the "acpi=ht" part, not comment the whole line. Some entries are still useful . Each entry corresponds to a certain boot option.. You can either delete them all, all delete only the one in your current option. Also, you can try "acpi=off". Check my thread. The last post particularly. For me, removing the acpi option did the trick, then again, I'm using a custom-compiled kernel .

I was getting the "Power down." message and no power-off before I removed the "acpi=ht" option. After that, It went down by itself the first time.
OK, changing the *appropriate* portion of the line to "acpi=off", did nothing. Next step was to try deleting that portion entirely. That worked! Thanks for the help! Now, if I can only get help, or at least replies on a couple of other hitches (esp. the printer), I'll be estatic with this system!

Last edited by riseringseeker; 09-21-2004 at 08:19 PM.
 
Old 09-22-2004, 03:42 PM   #6
eqxro
Member
 
Registered: Apr 2004
Location: Outer space :D
Distribution: Gentoo 2005.0 amd64 2.6.14-dfx3
Posts: 203

Rep: Reputation: 30
I'm glad it works... The hardware can always be tricky, esp. when you have the wrong drivers or the right stuff doing a wrong thing (acpi should've been able to power down, but it couldn't, so it was up to the apm ).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
system hangs on shutdown jbeiter Linux - Enterprise 5 03-12-2005 09:01 PM
Mandrakelinux 10.1 Hangs on Shutdown dqualls Linux - Newbie 3 02-08-2005 08:29 PM
x11 hangs on shutdown todd_seiler Linux - General 2 10-17-2004 06:47 PM
Shutdown hangs at ALSA mdhowe Mandriva 0 09-21-2004 09:53 PM
FC 2 Hangs On Shutdown sandgroper Fedora 5 07-06-2004 11:32 AM


All times are GMT -5. The time now is 07:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration