LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 08-31-2003, 06:20 PM   #1
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Rep: Reputation: 15
Unhappy [URGENT] Internet connection problem w/ bamboo 'n' cable modem


Hi!

I cannot connect to internet with my ISP's cable modem. This doesn't seems to be a modem problem or even a Ethernet card problem since I already saw many questions in several sites mentioning the same. So I did try to it first before bothering halfworld

Odd enough, no useful reply is given, not even in Mandrake Expert

Many reported that with the same machine that now gives them probs it did worked fine with 9.0. And also mentioned by others and by myself that everything works smoothly in M$ Windows 2000 PRO or XP

Mandrake's Control Center reports eth0 is up, configured for dhcp with the correct driver (8139too), no IP Address defined and Internet Access Type = lan.

ifconfig shows 3 entries. lo, eth0 with appropriate HWaddr but no IP address and also an entry for eth0:9 with the same HWaddr as eth0. This also has a inet addr of 169.254.211.159.

Where did this come from? There is no ifcfg-eth0:9 in the network-scripts. I manually configured resolv.conf for my ISP (as mentioned in one of the few prob replyes I found) to no avail.

And also I think it is important to mention that when 9.1 is booting it hangs on "Bringing up interface ETH0" (close wording). It will eventually pass as [OK] and continue.

Then, when I open the Mandrake Control Center to view network config, it says the eth0 is up but no IP address is listed. The network config is using DHCP. And it cannot connect to Internet on testing connection.

The most funny part is that in the cablemodem the "Status" LED is On; and the "Cable" and "PC" LEDs blink when MCC try to connect or even if I try to /sbin/dhcpcd -dBH eth0 on command line.

Of course, PINGging is absolutly useless since it always returns a "No host found" message

Anyone know what might be going on. What did change between 9.0 and 9.1 in this area?

Thanks in advance.

1,

Lopo
 
Old 08-31-2003, 07:32 PM   #2
stumbles
LQ Newbie
 
Registered: Apr 2003
Posts: 21

Rep: Reputation: 15
Re: [URGENT] Internet connection problem w/ bamboo 'n' cable modem

Quote:
Originally posted by humaneasy
Hi!


ifconfig shows 3 entries. lo, eth0 with appropriate HWaddr but no IP address and also an entry for eth0:9 with the same HWaddr as eth0. This also has a inet addr of 169.254.211.159.


When ifconfig reports an IP of 169.254.211.159 it means dhcp was not set up correctly.

Fire up MCC (Mandrake Control Center) and click on Network & Internet > DrakConnect > Wizard. At this point check that "Use auto detection" is enabled and while your at it "Expert Mode", click Next.

If LAN connection is selected, deselect it and choose instead "Cable connection", click Next.

Now your asked which dhcp-client you want, the default should be "dhcp-client, run with it, click Next. At this point it might install some packages, relax.

Now your asked if it detected the correct NIC, if so say No to having another one and click Next.

Now on this page you can choose if your box will use a host name assinged from the DHCP address it will soon get and start at boot. If those are ok, run with it, click next.

This page needs no explination, click next.

This page needs no explination, click next.

Again, this page needs no explination. The rest you can cypher.

On a side note. I do not know why but I have had to reboot the machine to get this to work. I have tried restarting dhcpd, network and anything else I thought needed but nothing work as I said without rebooting.
 
Old 08-31-2003, 11:34 PM   #3
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Unhappy Didn't work

I've even removed all DHCP packages

Reboot, Halt, Shutdown, Restarted... nothing worked.

Result:
Quote:
eth0 Encapsulating Link: Ethernet HW Address 00:0C:76:14:6C:00
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
colisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
IRQ:18 I/O Address:0x6000

eth0:9 Encapsulating Link: Ethernet HW Address 00:0C:76:14:6C:00
inet end.: 169.254.191.161 Bcast:169.254.255.255 Masc:255.255.0.0
UP BROADCASTRUNNING MULTICAST MTU:1500 Metrics:1
IRQ:18 I/O Address:0x6000

lo Encapsulating Link: Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
UP LOOPBACKRUNNING MTU:16436 Metrics:1
RX packets:82 errors:0 dropped:0 overruns:0 frame:0
TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
colisions:0 txqueuelen:0
RX bytes:5344 (5.2 Kb) TX bytes:5344 (5.2 Kb)
Dunno what to do more

Tomorrow (today, later) I will re-install Mandrake and follow your instructions with a clean new system.

I will post results... but if you have (or anyone else) other ideas they are welcomed.

If other files contents needed just ask.

8) Lopo
 
Old 09-02-2003, 11:49 AM   #4
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Unhappy The Saga continues...

Well!

I did the fresh install. Now I changed from "lan" to "cable" when the "summary" screen appeared in the instalation process. Everything seems to go well but...

When entering the system it reverted to "lan", so I tryed once more changing it throughout MCC without aparent success

I reboot it and I noticed a fast message that appeared on screen for a brief moment:
Quote:
Cannot change /etc/resolv.conf. You don't have rights to do that
or something like that. I mean, the text was not with this exact words but it said that I don't have rights to modify /etc/resolv.conf

This gives someone a light on the problem

I'm a so please be explicit

Lopo
 
Old 09-02-2003, 11:52 AM   #5
stumbles
LQ Newbie
 
Registered: Apr 2003
Posts: 21

Rep: Reputation: 15
Re: The Saga continues...

Quote:
Originally posted by humaneasy
Well!

I did the fresh install. Now I changed from "lan" to "cable" when the "summary" screen appeared in the instalation process. Everything seems to go well but...

When entering the system it reverted to "lan", so I tryed once more changing it throughout MCC without aparent success

I reboot it and I noticed a fast message that appeared on screen for a brief moment:

or something like that. I mean, the text was not with this exact words but it said that I don't have rights to modify /etc/resolv.conf

This gives someone a light on the problem

I'm a so please be explicit

Lopo

Check the permissions on /etc/resolv.conf. Doesn't make sense really since you have to be root to run MCC so root should have write access to resolv.conf.

That puzzles me.
 
Old 09-02-2003, 01:57 PM   #6
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Red face net oddity

Hummm!

This turns odd and odd...

Guess!?!?...

/etc/resolv.conf has 644 - root - root and zero bytes

It looks like a joke but it isn't

Do you know what configuration files should I modify by hand to make it work? And what do their "insides" should look like?

Best and thanks,

Lopo
 
Old 09-02-2003, 02:16 PM   #7
stumbles
LQ Newbie
 
Registered: Apr 2003
Posts: 21

Rep: Reputation: 15
Re: net oddity

Quote:
Originally posted by humaneasy
Hummm!

his turns dd and odd...
Guess!?!?...

/etc/resolv.conf has 644 - root - root and zero bytes

It looks like a joke but it isn't

Do you know what configuration files should I modify by hand to make it work? And what do their "insides" should look like?

Best and thanks,

Lopo
Well since it is only complaining about resolv.conf I would change the permiisions of it to be the same as the other files in /etc. The contents should look like this;

search this.is.your.isp.domain
nameserver 192.168.1.1
nameserver 192.168.1.2
nameserver 192.168.1.3


The name servers are the primary, secondary and ternary DNS servers used/provided by your ISP. If your using a firewall/router just log into it and hunt around for that information. If not then call your ISP and find out what those are for your area.
 
Old 09-03-2003, 03:06 PM   #8
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Unhappy It didn't work

Hi!

It didn't work

I think that it should be something else VERY wrong in my system and I dunno what.

Below is a screenshot of MCC DrakConnect in portuguese, but things are in the same place

http://pwp.netcabo.pt/0652324702/images/drakconnect.png

Shouldn't Tipo (Type) be "cable" instead of "lan"?
Shouldn't Protocolo (Protocol) be "dhcp" instead of "static" hence I don't have a static IP address but a dynamic one?

Hope you can help. If need more screenshots please ask.

Thank you very much,

Lopo
 
Old 09-03-2003, 03:22 PM   #9
camelrider
Member
 
Registered: Apr 2003
Location: Juneau, Alaska
Posts: 245

Rep: Reputation: 31
Are you running Mandraqke at "Paranoid" security level? Maybe it set the "immutable" bit on /etc/resolv.conf.
(man chattr)
 
Old 09-03-2003, 03:30 PM   #10
stumbles
LQ Newbie
 
Registered: Apr 2003
Posts: 21

Rep: Reputation: 15
Re: It didn't work

Quote:
Originally posted by humaneasy
Hi!


Shouldn't Tipo (Type) be "cable" instead of "lan"?
Shouldn't Protocolo (Protocol) be "dhcp" instead of "static" hence I don't have a static IP address but a dynamic one?


Lopo
Yes is should say cable instead.
 
Old 09-03-2003, 03:49 PM   #11
stumbles
LQ Newbie
 
Registered: Apr 2003
Posts: 21

Rep: Reputation: 15
Quote:
Originally posted by camelrider
Are you running Mandraqke at "Paranoid" security level? Maybe it set the "immutable" bit on /etc/resolv.conf.
(man chattr)

Hmmm, hadn't thought of that.
 
Old 09-03-2003, 06:04 PM   #12
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Re: Re: It didn't work

Quote:
Originally posted by stumbles
Yes is should say cable instead.
Where the hell can I change it
And "Protocol"? Did you saw the pic?

Quote:
Originally posted by camelrider
Are you running Mandrake at "Paranoid" security level? Maybe it set the "immutable" bit on /etc/resolv.conf.
(man chattr)
I don't know When I installed I set it to the lowest level... but I have shorewall installed and in MCC it as the option to allow all requests from internet checked and I uncheck it (that was when shorewall was installed).

Does this mean that I turn it "Paranoid"?

Best and thanks for you precious help

1,

Lopo
 
Old 09-03-2003, 06:19 PM   #13
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Red face One more little thing...

One more little thing...

If you feel in the mood to post a step-by-step mini-how-to for dummy s my data - token from MsWindows IPCONFIG - to access the Cable ISP is:

DNS Server: netcabo.pt
IP Address: 81.84.129.29
Subnet Mask: 255.255.254.0
Default Gateway: 81.84.129.254

If this could be of any use and if you are willing to do it

Best again,

Lopo

Last edited by humaneasy; 09-03-2003 at 06:25 PM.
 
Old 09-03-2003, 06:37 PM   #14
stumbles
LQ Newbie
 
Registered: Apr 2003
Posts: 21

Rep: Reputation: 15
Quote:
Originally posted by humaneasy
One more little thing...

If you feel in the mood to post a step-by-step mini-how-to for dummy s my data - token from MsWindows IPCONFIG - to access the Cable ISP is:

DNS Server: netcabo.pt
IP Address: 81.84.129.29
Mask: 255.255.254.0
Gateway: 81.84.129.254

Run up MCC, go to DrakConnect. Click Expert Mode then Wizard.

Auto detection should already be checked, also enable Expert Mode, click Next.

Deselect LAN connection and click on Cable connection, click Next.

Click dhcp-client then Next.

Click Next.

Again Click Next.

You should now be at the window to assign a static IP. Enable Automatic IP. If you do not want the host name to be something relating to your IPSs domain then deselect "Assign host name from DHCP address" and on the "DHCP host name line enter what you want your box host name to be, then click Next.

If you want to use Zeroconf then enter the host name of your box. Same for Host name (FQDN). Click Next and Next.

Once it is done restarting the network you should end up back at the first display of Drakconnect.

At the top click Configure Internet Access and enter the gateway IP (81.84.129.254).

Now click on Conifgure Local Area Network. Delete the IP and Netmask if there. Check the Boot Protocol is DHCP and start at boot. Click Ok.

Clcik Apply and then Ok. Restart the system. I know you should have to restart the machine but I have not been able to get this sort of connection working without one.
 
Old 09-04-2003, 12:27 AM   #15
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Nope

Spending a full night awake looking to Mdk and going back and forth from Linux machine to Windows machine was not my idea of starting my birthday

Latter I will post an URL to a small page with explained screenshots of all steps I took so you can see if there is something wrong. I also had screenshots from DrakSec and DrakFirewall

Bye and "see" you later.

Lopo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet connection/Cable Modem resets intermittently NLawrence Linux - Networking 1 04-23-2005 03:10 PM
Cable modem internet connection does not work GeneB Linux - Software 0 01-26-2005 11:10 AM
Problem connecting to the Internet with a Cable Modem desmith1944 Linux - Networking 4 10-24-2004 08:32 PM
Nic card -> cable internet modem no internet connection zeshan_b Mandriva 21 09-26-2004 12:48 PM
Problem connecting Suse 8.0 to internet via cable modem traveler Linux - Newbie 2 09-25-2002 01:22 PM


All times are GMT -5. The time now is 04:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration