LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (http://www.linuxquestions.org/questions/mandriva-30/)
-   -   [MDV2010.0] Interactive Firewall, never-ending warnings, can't contact daemon error (http://www.linuxquestions.org/questions/mandriva-30/%5Bmdv2010-0%5D-interactive-firewall-never-ending-warnings-cant-contact-daemon-error-776383/)

Xolo 12-17-2009 06:05 AM

[MDV2010.0] Interactive Firewall, never-ending warnings, can't contact daemon error
 
As a result of installing Samba i'm now left with never-ending warning messages:

Code:

Interactive Firewall
xxx.xxx.xxx.xxx is connecting on the netbios-dgm service.

About every 8 to 15 seconds, sometimes with a 30 second pause in between series of 10 messages.
I assume this is a result of allowing SMB in the firewall and choosing to have Interactive Firewall enabled during the firewall configuration.

There is a way to whitelist/blacklist addresses, but..

Right clicking the net applet in the system tray, choosing 'Interactive Firewall' yields:

Code:

Interactive Firewall
Unable to contact daemon

An error which then never stops until you log out or shut down.
To complicate the problem, the Interactive Firewall GUI for log/blacklisting/whitelisting is completely blank. No logs, no addresses, so you can't use it.

Of course I can disable Interactive Firewall, but that would be counter productive.


Has anyone else seen this?

affinity 12-17-2009 10:22 AM

I don't use Mandriva and I'm not sure what firewall GUI it uses, is interactive firewall the program name or just the description of it's service? However if I were having this issue the first thing I would try is disabling the firewall service and finding the documentation for editing any configuration files it has. Linux uses IP tables for network filtering, so I am assuming that the firewall service you are using is just a graphical front end for them. You could try looking at the IP tables themselves, or posting them here minus any private information.

1jnike 12-18-2009 07:20 PM

Hi Xolo,

Have tried using the Mandriva MCC (Mandriva Linux Control Center).

Using Gnome, go to Systems > Administration > Configure Your system

Once you have logged into the MCC

Go to security option

Than select configure system security, permissions and Audit,

You should than be able to turn off auditing, under Basic security,

uncheck:
Display security alerts on desktop.

That should resolve your issue.


I hope this is of help


Jnike

1jnike 12-19-2009 03:15 AM

Hi Xolo,

Update

You may want to also uncheck the intractive firewall option under the MCC > Security > set up personal firewall, select services you would allow the internet to connect too > uncheck interactive firewall box.

Ensure you restart your system to enable change.

I hope this is of help

Jnike

miclem 12-19-2009 08:24 AM

Just to confirm - had the very same issue & 1jnike has the solution!

ernie 12-19-2009 08:38 AM

After configuring my firewall, and setting the notifications (I want to know when connections are made on my system - home network), I began to receive the same notifications (these are notifications, not warnings). I ALT+Clicked the Network icon in my system tray, and opened the Interactive Firewall dialog. The dialog opens to the Log tab. Select an IP address in the log, then click the Whitelist button (bottom). After whitelisting all appropriate IP addresses, close the dialog. Open the Interactive Firewall dialog again, and now all whitelisted IP addresses should be listed in the Whitelist tab.

After whitelisting the appropriate IP addresses, the notifications stopped. They may appear once after a reboot (I have not checked yet). I will check then post back to inform of my results.

Update: After restarting the system, the Log tab in the Interactive Firewall dialog is clear (no reported connection attempts), the two IP addresses I whitelisted before the reboot are still listed in the Whitelist tab, and I have received no new notifications after the first give minutes ot operation.

HTH,

Xolo 03-20-2010 05:17 PM

Quote:

Originally Posted by 1jnike (Post 3797653)
Hi Xolo,

Update

You may want to also uncheck the intractive firewall option under the MCC > Security > set up personal firewall, select services you would allow the internet to connect too > uncheck interactive firewall box.

Ensure you restart your system to enable change.

I hope this is of help

Jnike

While this stops the errors and dialog spam, it does not fix the issue, it only hides the symptoms. Sorry! I can only be honest about it.
I am not out to hide the notifications, I want them enabled, but in a normal fashion. It worked before this edition.

As for the suggestions by ernie, i'm afraid I can't report any improvement, the errors remain.

I am resolving to disabling Interactive Firewall for Mandriva 2010, as it is broken.

wy125 12-21-2010 11:58 PM

Xolo,

I have the exact same problem. I ended up disabling the interactive firewall because I was tired of the messages.

Were you able to figure out how to solve this problem? Like you, I want the messages just not all of them. I have been unable to disable 'port scan detection' from MCC since I get the same 'Unable to contact Daemon' error.

If anyone has any input on this I would appreciate it.

thanks


All times are GMT -5. The time now is 03:07 AM.