LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices



Reply
 
Search this Thread
Old 12-17-2009, 07:05 AM   #1
Xolo
Member
 
Registered: Jul 2004
Location: The Netherlands
Distribution: Mandrake, Knoppix, Coyote Linux, RedHat
Posts: 354
Blog Entries: 3

Rep: Reputation: 31
[MDV2010.0] Interactive Firewall, never-ending warnings, can't contact daemon error


As a result of installing Samba i'm now left with never-ending warning messages:

Code:
Interactive Firewall
xxx.xxx.xxx.xxx is connecting on the netbios-dgm service.
About every 8 to 15 seconds, sometimes with a 30 second pause in between series of 10 messages.
I assume this is a result of allowing SMB in the firewall and choosing to have Interactive Firewall enabled during the firewall configuration.

There is a way to whitelist/blacklist addresses, but..

Right clicking the net applet in the system tray, choosing 'Interactive Firewall' yields:

Code:
Interactive Firewall
Unable to contact daemon
An error which then never stops until you log out or shut down.
To complicate the problem, the Interactive Firewall GUI for log/blacklisting/whitelisting is completely blank. No logs, no addresses, so you can't use it.

Of course I can disable Interactive Firewall, but that would be counter productive.


Has anyone else seen this?
 
Old 12-17-2009, 11:22 AM   #2
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
I don't use Mandriva and I'm not sure what firewall GUI it uses, is interactive firewall the program name or just the description of it's service? However if I were having this issue the first thing I would try is disabling the firewall service and finding the documentation for editing any configuration files it has. Linux uses IP tables for network filtering, so I am assuming that the firewall service you are using is just a graphical front end for them. You could try looking at the IP tables themselves, or posting them here minus any private information.
 
Old 12-18-2009, 08:20 PM   #3
1jnike
Member
 
Registered: Jan 2006
Location: UK
Distribution: Fedora,Mandriva,Debian,Suse,Solaris
Posts: 135

Rep: Reputation: 17
Lightbulb

Hi Xolo,

Have tried using the Mandriva MCC (Mandriva Linux Control Center).

Using Gnome, go to Systems > Administration > Configure Your system

Once you have logged into the MCC

Go to security option

Than select configure system security, permissions and Audit,

You should than be able to turn off auditing, under Basic security,

uncheck:
Display security alerts on desktop.

That should resolve your issue.


I hope this is of help


Jnike
 
Old 12-19-2009, 04:15 AM   #4
1jnike
Member
 
Registered: Jan 2006
Location: UK
Distribution: Fedora,Mandriva,Debian,Suse,Solaris
Posts: 135

Rep: Reputation: 17
Hi Xolo,

Update

You may want to also uncheck the intractive firewall option under the MCC > Security > set up personal firewall, select services you would allow the internet to connect too > uncheck interactive firewall box.

Ensure you restart your system to enable change.

I hope this is of help

Jnike

Last edited by 1jnike; 12-19-2009 at 04:42 AM.
 
Old 12-19-2009, 09:24 AM   #5
miclem
Member
 
Registered: Jan 2005
Distribution: Mandriva 2009 Powerpack x64
Posts: 80

Rep: Reputation: 15
Just to confirm - had the very same issue & 1jnike has the solution!
 
Old 12-19-2009, 09:38 AM   #6
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
After configuring my firewall, and setting the notifications (I want to know when connections are made on my system - home network), I began to receive the same notifications (these are notifications, not warnings). I ALT+Clicked the Network icon in my system tray, and opened the Interactive Firewall dialog. The dialog opens to the Log tab. Select an IP address in the log, then click the Whitelist button (bottom). After whitelisting all appropriate IP addresses, close the dialog. Open the Interactive Firewall dialog again, and now all whitelisted IP addresses should be listed in the Whitelist tab.

After whitelisting the appropriate IP addresses, the notifications stopped. They may appear once after a reboot (I have not checked yet). I will check then post back to inform of my results.

Update: After restarting the system, the Log tab in the Interactive Firewall dialog is clear (no reported connection attempts), the two IP addresses I whitelisted before the reboot are still listed in the Whitelist tab, and I have received no new notifications after the first give minutes ot operation.

HTH,

Last edited by ernie; 12-19-2009 at 09:49 AM. Reason: Update information
 
Old 03-20-2010, 06:17 PM   #7
Xolo
Member
 
Registered: Jul 2004
Location: The Netherlands
Distribution: Mandrake, Knoppix, Coyote Linux, RedHat
Posts: 354
Blog Entries: 3

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by 1jnike View Post
Hi Xolo,

Update

You may want to also uncheck the intractive firewall option under the MCC > Security > set up personal firewall, select services you would allow the internet to connect too > uncheck interactive firewall box.

Ensure you restart your system to enable change.

I hope this is of help

Jnike
While this stops the errors and dialog spam, it does not fix the issue, it only hides the symptoms. Sorry! I can only be honest about it.
I am not out to hide the notifications, I want them enabled, but in a normal fashion. It worked before this edition.

As for the suggestions by ernie, i'm afraid I can't report any improvement, the errors remain.

I am resolving to disabling Interactive Firewall for Mandriva 2010, as it is broken.
 
Old 12-22-2010, 12:58 AM   #8
wy125
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Rep: Reputation: 0
Xolo,

I have the exact same problem. I ended up disabling the interactive firewall because I was tired of the messages.

Were you able to figure out how to solve this problem? Like you, I want the messages just not all of them. I have been unable to disable 'port scan detection' from MCC since I get the same 'Unable to contact Daemon' error.

If anyone has any input on this I would appreciate it.

thanks
 
  


Reply

Tags
firewall, interactive, mandriva, netbios, samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tiger warnings about avahi-daemon - should I be concerned? mark_alfred Linux - Security 5 04-30-2009 12:20 PM
how to design interactive contact form for web page? bezdomny Linux - General 3 09-06-2007 11:03 AM
Interactive Graphical Firewall ADxD_7 Linux - Software 2 08-15-2007 07:49 PM
Interactive Firewall Attack Warnings dolphans1 Mandriva 2 05-11-2006 07:59 AM
How to configure Mandi (Interactive Firewall) kasl33 Mandriva 2 12-20-2005 06:09 PM


All times are GMT -5. The time now is 04:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration