LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mageia (http://www.linuxquestions.org/questions/mageia-97/)
-   -   Mageia 3 can not mount DVD (http://www.linuxquestions.org/questions/mageia-97/mageia-3-can-not-mount-dvd-4175443644/)

future_computer 12-31-2012 09:39 PM

Mageia 3 can not mount DVD
 
I plug in the DVD, it shows

Error mounting system-managed device /dev/sr0: Command-line `mount "/media/cdrom"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sr0,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

What can I do?

teckk 01-01-2013 12:07 PM

Quote:

I plug in the DVD
What does that mean? You plugged in an external DVD drive to a USB port? You put a DVD disk into an internal DVD drive? You tried to mount a DVD without any media in the drive?
You are using udev to automount? Or did you try and manually mount? Are you trying to mount a blank DVD+R?
Better help with better question.

future_computer 01-01-2013 11:51 PM

it is a desktop,
internal DVD ROM,
I just put in a DVD,
it does not mount.

nigelc 01-02-2013 12:43 AM

Hello,
It's not just a bad dvd? Have you tried another one?
cheers

future_computer 01-02-2013 05:51 AM

i tried a few DVD, not DVD problem.

teckk 01-02-2013 06:14 PM

How have you tried to mount it? Can you mount it manually?
Code:

mount -t iso9660 /dev/sr0 /mounting/point
You may need to be root. Depends on how you have your box configured. You may need to give user permissions to mount, or configure udev.
Also your not trying to mount an MT DVD are you? Do you have the drive in your fstab?
I see that pinguy is built on Ubuntu. You may try their forum also.
Looks like you need to configure it.

http://forum.pinguyos.com/Thread-Ext...e-not-detected
http://linux.die.net/man/8/mount
http://manpages.ubuntu.com/manpages/...n7/udev.7.html

If it's Magia, mount the disk manually or find out how to configure it to automount.
http://www.mageia.org/en/support/

future_computer 01-02-2013 09:51 PM

Noted your advice.

digigold 01-03-2013 05:12 AM

Quote:

Originally Posted by future_computer (Post 4860407)
I plug in the DVD, it shows

Error mounting system-managed device /dev/sr0: Command-line `mount "/media/cdrom"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sr0,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

What can I do?

What I would do is just add the following line to your fstab file.
Code:

/dev/cdrom  /cd  iso9660  ro,user,noauto,unhide
Note the "user" option allows any user to mount the drive.
Unless you have a hardware problem, this should work. If it doesn't let us know what happened.

future_computer 01-03-2013 07:06 AM

the error message is this:

mount: wrong fs type, bad option, bad superblock on /dev/sr0,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

future_computer 01-03-2013 07:11 AM

What I did was this:

1. go to /mnt, su mkdir cdrom
2. the at terminal, type
mount -t iso9660 /dev/sr0 /mnt/cdrom

It was mounted, can be accessed from file manager.

How to make it automount?

future_computer 01-03-2013 07:15 AM

why the usb drive is at

/run/media/daniel/TDK

my drive name is TDK.

digigold 01-03-2013 07:37 AM

Quote:

Originally Posted by future_computer (Post 4862014)
why the usb drive is at

/run/media/daniel/TDK

my drive name is TDK.

/run/media is where the udisks daemon is probably set to mount.

digigold 01-03-2013 07:47 AM

Quote:

Originally Posted by future_computer (Post 4862011)
What I did was this:

1. go to /mnt, su mkdir cdrom
2. the at terminal, type
mount -t iso9660 /dev/sr0 /mnt/cdrom

It was mounted, can be accessed from file manager.

How to make it automount?

add this line to /etc/fstab:
Code:

/dev/sr0  /mnt/cdrom  iso9660  ro,user,unhide 0 2
then check/or to easily mount later use:
Code:

mount -a

future_computer 01-03-2013 08:26 AM

Is this a bug in beta 1?
mageia 2 can automount.

floppywhopper 01-20-2013 12:29 AM

probably is a bug
you need to report it


All times are GMT -5. The time now is 03:34 PM.