LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mageia
User Name
Password
Mageia This forum is for the discussion of Mageia Linux.

Notices

Reply
 
Search this Thread
Old 05-23-2013, 07:20 PM   #1
ADDn00b
Member
 
Registered: Sep 2007
Location: Buckeye Nation
Distribution: Mint 14, Mageia
Posts: 31

Rep: Reputation: 15
GRUB error? Mageia 3, can't boot without DVD


Hello everyone,

I haven't had any issues for quite some time, so I've only been lurking...until today.

I successfully used and installed (multiple times) Mandriva, Ubuntu, and most recently Mint, on different computers in my home, but wanted to try out Mageia 3 on my main laptop, thinking I could dual-boot as I always have before.
I have completely screwed something up, and I can't say I adequately understand what happened, even after reading through the posts from those with similar issues.
I noticed nothing untoward during installation and I thought I had a good install until I shut it down and attempted to restart. The machine would not boot into either Windows or Mageia.
On boot attempt, I got the following text:
"Reboot and select proper boot device or insert boot media in selected boot device and press a key."
Freaking out, I put the install DVD back in the drive and pressed a key. The GRUB GUI appeared and I selected "Boot Microsoft Windows".
Here is the text I got:
"Filesystem type unknown, partition type 0x83 make active chainloader +1. Remove disks or other media. Press any key to restart". (Circular logic?)

I can boot into Mageia only with the DVD in the drive, and it appears to be operating from the DVD rather than the hard disk. I was able to import my windows files using MCC import utility, but I haven't restarted since I did so, so I don't know if they were written into the Mageia partition. (Guessing not, so I put it all on a USB). I took a screenshot of the partitions shown on the disk management page of MCC, and it shows the partitions allocated to Mageia and Windows and swap, with a very tiny gray sliver at the far left that I might think is the MBR?

Most everything during install was default, but it is possible that I wasn't paying attention well when it asked me what bootloader I wanted. Having used GRUB before, I might have selected it rather than GRUB 2, as I now know I shouldn't have (after reading the forums).

Best case scenario, I would like to have a working dual-boot operation. I know I can re-install Windows if I have to (since nearly everything is backed up), but because I use a soon-to-expire accounting program for my business, it will be a MAJOR pain-in-the-a**, should it be necessary.

(If I do that, it is unlikely that I would try Mageia again for awhile having been scared witless at this attempt of mine. Please understand, I completely blame my own damn self for not paying better attention.)

Is there a way to fix the MBR without losing both OS's? Is the MBR the problem? Have mercy.

I crossposted this to the Mageia forums as well, hoping against hope that somebody, anybody, has an idea what I've done....besides embarass myself, that is.

Note: my signature line is no longer correct.
 
Old 05-23-2013, 07:52 PM   #2
MCMLXXIII
Member
 
Registered: Aug 2012
Distribution: [Desktop] Debian Wheezy, [Laptop #1] Ubuntu 12.04, [Laptop #2] openSUSE 13.1, [Netbook] CentOS 6.5
Posts: 60

Rep: Reputation: Disabled
This program should help restore your MBR.

What edition of Windows are you using? If it's Windows 7, then you can follow this handy guide (even though it's Ubuntu, the same method applies with other Linux distributions.) GRUB and GRUB2 are personal choices, so either will work in this scenario.
 
1 members found this post helpful.
Old 05-23-2013, 08:00 PM   #3
ADDn00b
Member
 
Registered: Sep 2007
Location: Buckeye Nation
Distribution: Mint 14, Mageia
Posts: 31

Original Poster
Rep: Reputation: 15
MCMLXXIII, Thank you so much. I will be checking out the program on sourceforge. Got a 403-forbidden error on the link to the guide. I'll try to look it up. Thanks again, and I'll let you know how it goes.
 
Old 05-23-2013, 08:04 PM   #4
MCMLXXIII
Member
 
Registered: Aug 2012
Distribution: [Desktop] Debian Wheezy, [Laptop #1] Ubuntu 12.04, [Laptop #2] openSUSE 13.1, [Netbook] CentOS 6.5
Posts: 60

Rep: Reputation: Disabled
Quote:
Originally Posted by ADDn00b View Post
MCMLXXIII, Thank you so much. I will be checking out the program on sourceforge. Got a 403-forbidden error on the link to the guide. I'll try to look it up. Thanks again, and I'll let you know how it goes.
That's weird. That link was working fine after I posted it. Then I checked it again after your reply and I get the same message.

It was a dual-boot guide. I'd recommend restoring your MBR and then deleting your Mageia partitions and starting over. See if this link works instead? It's an older article, but the same method applies to non-Ubuntu distributions.

http://www.linuxbsdos.com/2011/05/22...-ubuntu-11-04/
 
1 members found this post helpful.
Old 05-23-2013, 08:15 PM   #5
MCMLXXIII
Member
 
Registered: Aug 2012
Distribution: [Desktop] Debian Wheezy, [Laptop #1] Ubuntu 12.04, [Laptop #2] openSUSE 13.1, [Netbook] CentOS 6.5
Posts: 60

Rep: Reputation: Disabled
Sorry but that link isn't accessible from here either. Just input the address manually in your browser to see the content.
 
Old 05-23-2013, 08:15 PM   #6
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,178

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Quote:
Originally Posted by MCMLXXIII View Post
That's weird. That link was working fine after I posted it. Then I checked it again after your reply and I get the same message.

It was a dual-boot guide. I'd recommend restoring your MBR and then deleting your Mageia partitions and starting over. See if this link works instead? It's an older article, but the same method applies to non-Ubuntu distributions.

http://www.linuxbsdos.com/2011/05/22...-ubuntu-11-04/
403 on that one too.

Was reading this thread with interest as I have a major problem with grub under Mageia 3 too. Somewhat different than the topic here though.

I have run Mageia 3 on here but needed to do a lot of things to this box and get eye surgery. Finally could install and it is, just haven't figured out how to fix the screwed grub install. I know it is the installation of grub(2) that is the problem because that is the error I got when it was installing.

I think I can fix it.

If the OP has install media for MS he should be able to use it to restore the MS bootloader to the MBR and boot W7 without reinstalling.
 
1 members found this post helpful.
Old 05-23-2013, 08:15 PM   #7
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,109

Rep: Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985
Before you start, boot up the DVD, go get bootinfoscript and run it so we can see what your full boot environment is. Post the RESULTS.txt.
You'll probably get similar from boot-repair, but let's see it first.
 
1 members found this post helpful.
Old 05-23-2013, 08:32 PM   #8
ADDn00b
Member
 
Registered: Sep 2007
Location: Buckeye Nation
Distribution: Mint 14, Mageia
Posts: 31

Original Poster
Rep: Reputation: 15
syg00, I'm not smart enough to get bootinfoscript to work. I'm still working on it though.
 
Old 05-23-2013, 09:04 PM   #9
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,109

Rep: Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985
Not your fault - the instructions are deficient; used to be ok, so I don't even look these days. The download should have given you a file called "bootinfoscript-061.tar.gz" - this is compressed archive (like .zip). Run this to unroll the tar, then you can execute the resultant file as per the website
Code:
tar -xvzf bootinfoscript-061.tar.gz
 
1 members found this post helpful.
Old 05-23-2013, 09:27 PM   #10
ADDn00b
Member
 
Registered: Sep 2007
Location: Buckeye Nation
Distribution: Mint 14, Mageia
Posts: 31

Original Poster
Rep: Reputation: 15
syg00, I couldn't get that to work, either.

Quote:
[root@localhost ~]# tar -xvzf bootinfoscript-061.tar.gz
tar (child): bootinfoscript-061.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
It gave me the option to "extract", which I did, but it assumes I know what directory it extracted to, and I guess I don't.
Following the instructions that came with it, I got nowhere either. If there is a results.txt, I do not know where it went. It didn't appear to do anything.

I so appreciate your efforts to help me!

The dual-boot guide MCMLXXIII posted above was instructive. I understand now that Windows prefers it's own MBR and bootloader. Wish I hadn't pulled the trigger without doing more research.
 
Old 05-23-2013, 09:36 PM   #11
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,109

Rep: Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985
Try these - the first one will take a little while to run as it builds a database of all the filenames on your system. The other two just look for filenames (or fragments thereof).
Code:
updatedb
locate RESULTS.txt
locate bootinfo
We can fix the loader problem in all likelihood - we just need some info ...
 
1 members found this post helpful.
Old 05-23-2013, 10:18 PM   #12
ADDn00b
Member
 
Registered: Sep 2007
Location: Buckeye Nation
Distribution: Mint 14, Mageia
Posts: 31

Original Poster
Rep: Reputation: 15
All I see is the bootinfoscript, which extracts to gedit and starts with
Quote:
#!/bin/bash
VERSION='0.61';
RELEASE_DATE='1 April 2012';
LAST_GIT_COMMIT='';
RETRIEVAL_DATE='';
###############################################################################
.

Followed by the copyright notice and then the history of the program and then the follwoing:
Quote:
## Check if the script is run with bash as shell interpreter.

if [ -z "$BASH_VERSION" ] ; then
echo 'Boot Info Script needs to be run with bash as shell interpreter.' >&2;
exit 1;
fi



## Display help text ##
#
# ./bootinfoscript -h
# ./bootinfoscript -help
# ./bootinfoscript --help

help () {
cat <<- HELP
It then displays the help info that was already unhelpful.
IF I had any idea what I was looking at, it almost looks like some part of it should be copied and pasted into the terminal, but I wouldn know where to start or end it.

I'm likely not seeing the forest for the trees.
 
Old 05-24-2013, 12:37 AM   #13
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,109

Rep: Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985
I don't use a GUI file manager for these things.
The locate commands should show you where the files are - "cd" into the directory with the downloaded file, and run the "tar" command I gave you. Then run this command (presuming you are still root)
Code:
./bootinfoscript
(yes, you do need the dot-slash).

Last edited by syg00; 05-24-2013 at 12:38 AM. Reason: typos everywhere .... d'oh
 
Old 05-24-2013, 01:43 AM   #14
ADDn00b
Member
 
Registered: Sep 2007
Location: Buckeye Nation
Distribution: Mint 14, Mageia
Posts: 31

Original Poster
Rep: Reputation: 15
Unfortunately, after trying several things...I've given up and started system recovery. Boo. And I'm now stuck on my tablet while the recovey takes place. Double boo. Any luck and I'll get everything back up and get payroll done by 5.

Next time, and there will be one, I'll be asking you fine folks how to do it right BEFORE I get started!

Thank you both again. I really appreciate it.
 
Old 05-24-2013, 04:28 AM   #15
floppywhopper
Member
 
Registered: Aug 2004
Location: Albany, Western Australia
Distribution: Mageia 2, SME Server 8
Posts: 617
Blog Entries: 2

Rep: Reputation: 54
how did you resize the windows partition
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 3 can not mount DVD future_computer Mageia 15 02-20-2013 06:54 AM
[SOLVED] Can't Boot Mageia 2 after Upgrading from Mageia 1 gdawg Mageia 3 06-24-2012 10:20 AM
[SOLVED] Grub error 17 after installing Mageia nigelc Mandriva 2 08-29-2011 12:29 AM
[SOLVED] Mageia Linux DVD version. Are Emerald repos included on DVD or not? nando321 Mandriva 2 07-13-2011 06:51 PM
Making Grub boot a cd/dvd? Chomper Linux - Software 9 01-14-2010 09:31 PM


All times are GMT -5. The time now is 05:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration