LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mageia
User Name
Password
Mageia This forum is for the discussion of Mageia Linux.

Notices

Reply
 
Search this Thread
Old 06-15-2013, 09:44 AM   #1
AlanSecker
Member
 
Registered: Aug 2003
Location: London, UK
Distribution: Red Hat
Posts: 35

Rep: Reputation: 0
/etc/modules


According to an answer in Linux Format Aug 2013, the contents of /etc/modules specify which modules that should be loaded at boot time.

Mine, in Mageia 2 is empty! So where are they specified?
 
Old 06-15-2013, 10:10 AM   #2
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,805

Rep: Reputation: 231Reputation: 231Reputation: 231
that advice is probably out of date. the kernel will automatically load modules as it needs them. it has been capable of doing this for many years now. there are very few modules which need to be manually specified, but none of them are critical to the operation of your machine.
 
Old 06-15-2013, 10:42 AM   #3
AlanSecker
Member
 
Registered: Aug 2003
Location: London, UK
Distribution: Red Hat
Posts: 35

Original Poster
Rep: Reputation: 0
Smile Missing modules

Actually I was thrashing around for an answer to a problem.

I have compiled driver(s) for my PCI TV card a tbs-6280. They don't show up in dmesg / lsmod etc.
I also cannot get LCDd to strut its stuff.

I wondered if there might be a common problem such as a missing symlink but in
order to make one, I needed to find the modules in the fist place.
 
Old 07-20-2013, 08:01 AM   #4
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi,

If you know the module name you can insert it in
/etc/modprobe.preload
Code:
# /etc/modprobe.preload: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line.  Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules
i2c-dev
max6650
#psmouse
snd_usb_audio
snd_seq_oss
it87
rfcomm
gpm-data
evdev
is what mine look like.

If by the way you need to block a module from loading you would insert it here,

/etc/modprobe.d/blacklist-mga.conf
Code:
# blacklisted modules for PCI coldplug
# see also /etc/modprobe.d/blacklist-compat

blacklist rivatv

# For some bridges both intel-agp and i82875p_edac are loaded. If i82875p_edac
# is loaded first it will grab the device. Then intel-agp doesn't work.
# Therefore we disable automatic loading of 82875p_edac. (Bug 213840)
# https://bugzilla.novell.com/show_bug.cgi?id=213840
blacklist i82875p_edac

# do not use "Boot Protocol" drivers, we prefer usbhid
# and they cause problems when loaded together with usbhid (#37726, #40861)
blacklist usbkbd
blacklist usbmouse

# disable PC speaker by default
# pcspkr is the standard driver, while snd-pcsp is the ALSA driver
blacklist pcspkr
blacklist snd-pcsp
blacklist nouveau
blacklist snd_hda_codec_hdmi  #hda-nvidia-digital-stereo
blacklist snd_hda_codec_realtek #hda onboard 5.1 surround
blacklist snd_hda_intel
blacklist snd_hda_codec
is what mine look like.

Hope this helps.

btw, that info is very old, kernel v4

Last edited by GlennsPref; 07-20-2013 at 08:01 AM. Reason: manners
 
Old 07-21-2013, 08:44 AM   #5
AlanSecker
Member
 
Registered: Aug 2003
Location: London, UK
Distribution: Red Hat
Posts: 35

Original Poster
Rep: Reputation: 0
The problem resolved itself eventually. I believed that all that was needed was a cold boot. Something similar has been similarly resolved on previous occasions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FATAL: Could not load /lib/modules/2.6.14-default/modules.dep no such file exist dr_zayus69 Linux - Software 3 12-26-2005 07:44 PM
/etc/conf.modules is more recent than /lib/module/2.2.15-4mdk/modules.dep Derek-kun Linux - Newbie 3 09-26-2003 03:56 AM
Slack9 - no PPP (can't open dependencies file /lib/modules/2.4.18/modules.dep) bluehz Slackware 1 05-04-2003 03:32 PM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - General 1 01-24-2002 02:50 AM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - Newbie 2 01-24-2002 02:40 AM


All times are GMT -5. The time now is 11:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration