LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mageia (http://www.linuxquestions.org/questions/mageia-97/)
-   -   /etc/modules (http://www.linuxquestions.org/questions/mageia-97/etc-modules-4175466127/)

AlanSecker 06-15-2013 08:44 AM

/etc/modules
 
According to an answer in Linux Format Aug 2013, the contents of /etc/modules specify which modules that should be loaded at boot time.

Mine, in Mageia 2 is empty! So where are they specified?

rkelsen 06-15-2013 09:10 AM

that advice is probably out of date. the kernel will automatically load modules as it needs them. it has been capable of doing this for many years now. there are very few modules which need to be manually specified, but none of them are critical to the operation of your machine.

AlanSecker 06-15-2013 09:42 AM

Missing modules
 
Actually I was thrashing around for an answer to a problem.

I have compiled driver(s) for my PCI TV card a tbs-6280. They don't show up in dmesg / lsmod etc.
I also cannot get LCDd to strut its stuff.

I wondered if there might be a common problem such as a missing symlink but in
order to make one, I needed to find the modules in the fist place.

GlennsPref 07-20-2013 07:01 AM

Hi,

If you know the module name you can insert it in
/etc/modprobe.preload
Code:

# /etc/modprobe.preload: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line.  Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules
i2c-dev
max6650
#psmouse
snd_usb_audio
snd_seq_oss
it87
rfcomm
gpm-data
evdev

is what mine look like.

If by the way you need to block a module from loading you would insert it here,

/etc/modprobe.d/blacklist-mga.conf
Code:

# blacklisted modules for PCI coldplug
# see also /etc/modprobe.d/blacklist-compat

blacklist rivatv

# For some bridges both intel-agp and i82875p_edac are loaded. If i82875p_edac
# is loaded first it will grab the device. Then intel-agp doesn't work.
# Therefore we disable automatic loading of 82875p_edac. (Bug 213840)
# https://bugzilla.novell.com/show_bug.cgi?id=213840
blacklist i82875p_edac

# do not use "Boot Protocol" drivers, we prefer usbhid
# and they cause problems when loaded together with usbhid (#37726, #40861)
blacklist usbkbd
blacklist usbmouse

# disable PC speaker by default
# pcspkr is the standard driver, while snd-pcsp is the ALSA driver
blacklist pcspkr
blacklist snd-pcsp
blacklist nouveau
blacklist snd_hda_codec_hdmi  #hda-nvidia-digital-stereo
blacklist snd_hda_codec_realtek #hda onboard 5.1 surround
blacklist snd_hda_intel
blacklist snd_hda_codec

is what mine look like.

Hope this helps.

btw, that info is very old, kernel v4

AlanSecker 07-21-2013 07:44 AM

The problem resolved itself eventually. I believed that all that was needed was a cold boot. Something similar has been similarly resolved on previous occasions.


All times are GMT -5. The time now is 11:22 AM.