LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > LinuxQuestions.org > LQ Suggestions & Feedback
User Name
Password
LQ Suggestions & Feedback Do you have a suggestion for this site or an idea that will make the site better? This forum is for you.
PLEASE READ THIS FORUM - Information and status updates will also be posted here.

Notices

Reply
 
Search this Thread
Old 07-04-2002, 11:20 AM   #1
RefriedBean
Member
 
Registered: Jun 2002
Location: N 37 33.327 E 126 55.650
Distribution: Gentoo, Slackware, OpenZaurus
Posts: 186

Rep: Reputation: 30
Question Wrong Time


Hi!
For some reason the "The Time Now is" thing on the page reports my local time 1 hour ahead of time. For Example when its 1 PM here, it says its 2 PM. I've made sure that my GMT offset is correct (GMT +9).

Any ideas?

Thanks!!
RefriedBean
 
Old 07-04-2002, 11:50 AM   #2
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Did you check you profile to make sure you set the time zone correctly?
 
Old 07-04-2002, 09:11 PM   #3
RefriedBean
Member
 
Registered: Jun 2002
Location: N 37 33.327 E 126 55.650
Distribution: Gentoo, Slackware, OpenZaurus
Posts: 186

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by pickledbeans
Did you check you profile to make sure you set the time zone correctly?
I am 100% sure that its correct, at the bottom of the page it says "All times are GMT +9 hours. The time now is 12:09 PM." And Korea is definately GMT +9.

Thanks!!
RefriedBean
 
Old 07-05-2002, 12:15 AM   #4
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Do you have your hardware clock set to the correct GMT time? Do you have daylight savings time? When you use the GMT setting in the time config, it's supposed to automatically adjust for daylight savings time.

If you do have daylight savings time, set your hardware clock to local time minus 10 hours. That will give you GMT time.

Last edited by linuxcool; 07-05-2002 at 12:19 AM.
 
Old 07-07-2002, 05:17 PM   #5
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Did you get your time problem fixed?
 
Old 07-08-2002, 06:17 AM   #6
RefriedBean
Member
 
Registered: Jun 2002
Location: N 37 33.327 E 126 55.650
Distribution: Gentoo, Slackware, OpenZaurus
Posts: 186

Original Poster
Rep: Reputation: 30
Hi!
Well, It seems to me that the message board uses DST while in the real world we are not using it, or something. But I did 'fix' it by setting my timezone as GMT +8 instead of the actual +9.
That works

RefriedBean
 
Old 07-08-2002, 06:22 AM   #7
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Glad to hear you got it fixed.
 
Old 08-06-2002, 01:26 AM   #8
naz
Member
 
Registered: Aug 2002
Location: Malaysia
Distribution: RedHat
Posts: 58

Rep: Reputation: 15
The bug is with the forum/webserver, not on the client side - I'm in Malaysia (GMT+8) but I have to set it to GMT+7 to get the correct time.

Is the webserver not running on UTC? This could be the problem.

naz
 
Old 08-11-2002, 04:59 PM   #9
rsbecker007
Member
 
Registered: Dec 2001
Location: South Bend, IN
Distribution: Debian, Red Hat, LFS
Posts: 39

Rep: Reputation: 15
me 2!

I also have this problem. I am GMT -5, but the time wasn't correct. We don't have daylight savings here, but I changed my timezone since it would seem that the forum is on daylight savings or off by an hour...
 
Old 08-13-2002, 09:39 PM   #10
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 10,316

Rep: Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612
OK. It seems like the probelm is big enough that it is worth fixing. I am going to add a field to your profile that will allow you to choose whether the timezone you are in observes day light savings time or not. If it doesn't the time will automatically be adjusted for you.

--jeremy
 
Old 08-13-2002, 10:11 PM   #11
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 10,316

Rep: Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612
If you go to UserCP -> Edit Options you will now have an option that says "Use Daylight Saving Time". If you live in an area that does NOT use DST you would set this to no. You should then have the correct time regardless of whether or not the current time is DST (you may have to correct your timezone if you manually corrected for the problem). If you notice any problems with this let me know, quite a bit of code editing was neccessary. Thanks.

--jeremy
 
Old 08-14-2002, 01:06 AM   #12
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Rep: Reputation: 30
sorry jeremy but my time still has stuffed up, no matter if i select DST or not, i'm still using the tokyo time or whatever, in other words the +9:00 option, but i should be using EAST +10:00
 
Old 08-14-2002, 08:36 AM   #13
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 10,316

Rep: Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612
Sorry, I missed something. This will be fixed later. Thanks for the heads up.

--jeremy
 
Old 08-14-2002, 09:06 AM   #14
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 10,316

Rep: Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612Reputation: 2612
This should actually work now. Next time I will test before saying it is done

--jeremy
 
Old 08-16-2002, 03:12 AM   #15
RefriedBean
Member
 
Registered: Jun 2002
Location: N 37 33.327 E 126 55.650
Distribution: Gentoo, Slackware, OpenZaurus
Posts: 186

Original Poster
Rep: Reputation: 30
Thanks!!

It works great

RefriedBean
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 09:58 PM
my time is wrong and calender is also wrong Paxmaster Linux - General 6 12-16-2004 12:46 AM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 03:25 PM
my time is wrong~~!! yjwon6 General 3 09-15-2003 05:27 AM
my time is wrong~~! yjwon6 Linux - Software 2 09-15-2003 03:22 AM


All times are GMT -5. The time now is 04:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration