LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   LQ Suggestions & Feedback (http://www.linuxquestions.org/questions/lq-suggestions-and-feedback-7/)
-   -   Minor blog issue - use of HTML (http://www.linuxquestions.org/questions/lq-suggestions-and-feedback-7/minor-blog-issue-use-of-html-409153/)

vharishankar 01-28-2006 10:45 PM

Minor blog issue - use of HTML
 
I noticed that HTML tags when used in the blog improperly tends to affect the whole blog page and others' posts as well.

As an example, in the main blog view http://www.linuxquestions.org/linux/blog/Harishankar a single unclosed italics tag <i> by one person renders everybody else's posts in italics.

Just thought I'd let you know.

I've also filed a LQ bug report, just for convenience.

trickykid 01-28-2006 10:53 PM

HTML tags shouldn't even be enabled.. well, that's how the old forum was, but then again, we didn't have blogs either. But that's how html tags work, so it's not really a bug per se, it's more that users need to be educated on using html tags. ;)

titanium_geek 01-28-2006 11:33 PM

isn't there a way you can "close all tags"?

then it would just mess with the other people's posts etc.

titanium_geek

vharishankar 01-29-2006 02:08 AM

Quote:

Originally Posted by trickykid
HTML tags shouldn't even be enabled.. well, that's how the old forum was, but then again, we didn't have blogs either. But that's how html tags work, so it's not really a bug per se, it's more that users need to be educated on using html tags. ;)

HTML is only enabled in the blog mode. I think regular forum posts still use bbCode. I like to use HTML whenever possible, but unfortunately since the forum doesn't use a parser for HTML (unlike bbCode) it directly outputs the user input to the view (after stripping off disallowed tags of course). The idea of bbCode of course, was to have a kind of validation for formatting codes and not output HTML directly from user input.

Edit: I notice that the blog also has BBCode option...

jeremy 01-29-2006 11:03 AM

You can use bbcode or a select few HTML tags for blogs, LA's and articles. To the issue, first - http://www.linuxquestions.org/linux/blog/Harishankar now actually works (ie. it goes to your blog, which is where is should have gone all along). If you enter something about the closing of tags into the bug tracker, we can look into as soon as we clean some other things up. Thanks.

--jeremy

vharishankar 02-02-2006 06:26 AM

Already entered in the bug tracker
http://www.linuxquestions.org/questi...iew&vbug_id=63


All times are GMT -5. The time now is 03:04 PM.