LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices



Reply
 
Search this Thread
Old 10-25-2007, 02:00 AM   #1
checkmate3001
Member
 
Registered: Sep 2007
Location: Folsom, California
Distribution: Debian 4.0 (Etch), Debian 5.0 (Lenny), Ubuntu 8.04
Posts: 301

Rep: Reputation: 32
Turn off the annoying bell (pc speaker) in debian etch


The PC speaker 'bell' sound is incredibly annoying. Every time you use the tab-completion or do something vi doesn't like the darn thing beeps at you.

Well this is how I turned it off in debian etch.

Edit /etc/inputrc
Code:
vim /etc/inputrc
Remove comment-
Quote:
set bell-style none
or change to:
Quote:
set bell-style visible
Visible flashes the screen instead of making a sound. I find it MUCH less annoying and it still serves a purpose.

Then reboot...
should be gone.

I believe there are other ways - ways in which you configure your own kernel? I think there may be other files deeper in the system you can edit also.

Feedback appreciated.

Last edited by checkmate3001; 10-25-2007 at 02:03 AM. Reason: changed title for possibly better search rating (turned -> turn) (removed quotes around bell).
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 10-25-2007, 02:56 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
I don't think a "nice" bell is annoying, one with a decent sound. But the speaker-bell comes from h... Luckily turning that off is as easy as setting the PCM muted in your favourite mixer app, and saving changes. Of course this affects other speaker sounds than that, but I don't need it so it's all the same for me..

Nice story anyway, I might find it useful one day. Thanks.
 
Old 01-08-2008, 09:50 PM   #3
angryfirelord
Member
 
Registered: Dec 2005
Posts: 502

Rep: Reputation: 60
Or, you can simpy remove the pcspkr module.

Code:
rmmod pcspkr
Then
Code:
nano /etc/modprobe.d/blacklist
Add:
Code:
blacklist pcspkr
Your speaker has now been silenced.
 
Old 01-11-2008, 11:12 PM   #4
hondo
Member
 
Registered: Jul 2005
Location: norway
Posts: 198

Rep: Reputation: 33
i always use "xset b off" to turn off the annoying bell. works nice and immediately takes effect.
 
2 members found this post helpful.
Old 06-19-2010, 05:40 AM   #5
ukiuki
Senior Member
 
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,030

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Cool

I found it quite useful, edited inputrc and then did xset b off
worked like a charm !

Last edited by ukiuki; 06-19-2010 at 05:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
System Bell / PC Speaker mattydee Slackware 5 11-16-2007 09:51 PM
update Debian testing etch RC1 to etch stable cccc Debian 11 01-08-2007 11:02 PM
Beep/Bell in computer with no speaker crxssi Linux - Hardware 2 01-05-2007 10:01 PM
"set bell-style none" won't stop my internal speaker from beeping Lokathor Debian 7 11-26-2005 02:52 PM
Incredibly annoying pc speaker beep on error in MySql in Windows XP nazdrowie Programming 2 07-15-2005 02:26 AM


All times are GMT -5. The time now is 10:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration