LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices

Reply
 
Search this Thread
Old 04-14-2004, 11:09 PM   #1
freychef
Member
 
Registered: May 2003
Location: Montreal
Distribution: Slack, Libranet
Posts: 92

Rep: Reputation: 15
thinkpad 600e sound solution!


Ok, the thinkpad 600e is a pretty old beast by now, however lots of people are grabbing them for cheap on ebay. There have been many post on how to get the sound working on them as well, some with great success, some without.

I tried for weeks to get sound working on the damn thing without having any luck. BTW, I'm using Slackware 9.1 on this machine (stock) and it works great except for the aforementioned sound probs. I tried using different ALSA drivers but they would totally kill the machine (kernel panic). I read about a bazillion posts and howtos with absolutely no joy.

The other night I was messing around and (for the life of me can't remember where I got this from) edited my /etc/modules.conf as follows:

alias char-major-14 cs-4232
options cs4232 io=0x530 irq=5 dma=1 dma2=0

That's it, that's all. Saved the file.

Then as su : modprobe cs4232

Started the gui (fluxbox) and launched aumix. Adjusted the settings. Started XMMS using OSS, and picked a directory with some mp3's. Lo and behold - sound!

I'm no guru, in fact just a schmoe, but that's how I got this thing to work. Of course everytime I restart the laptop I've gotta use the modprobe command and adjust the mixer but hell it's better than what I had before which was SFA.

Hope this helps some folks out there.

Good luck.
 
Old 04-15-2004, 07:22 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
If your 600E behaves bad when you try to load the Alsa drivers I suggest you enter the BIOS (press Fn+F2 during startup, if I remember correctly) and choose to "initialize" the system. My 600E, which started freezing with Alsa half a year ago, started accepting Alsa painlessly after that.

The alsaconf has been updated to automatically detect a 600E and configure the Alsa sound modules properly. This is pretty amazing - I can actually run Jack and Ardour on my laptop now. But with 366MHz to play with it's not much fun anyway, but it works.


Håkan
 
Old 04-15-2004, 09:17 AM   #3
freychef
Member
 
Registered: May 2003
Location: Montreal
Distribution: Slack, Libranet
Posts: 92

Original Poster
Rep: Reputation: 15
Thanks hw-tph,

I've followed your posts here at LQ, but havent had much luck with them. Probably my fault. For now, I'll stick with using OSS until the next version of Slackware is released.
 
Old 06-21-2004, 10:46 PM   #4
pioniere
Member
 
Registered: Dec 2002
Location: Vancouver Island, Canada
Distribution: Slackware
Posts: 46
Blog Entries: 1

Rep: Reputation: 15
Fix didn't work, suggestions?

I have a 600E running Slack 9.1. I tried your suggested sound fix, but here's what I got when I ran modprobe cs4232

/lib/modules/2.4.22/kernel/drivers/sound/cs4232.o.gz: init_module: No such device
/lib/modules/2.4.22/kernel/drivers/sound/cs4232.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22/kernel/drivers/sound/cs4232.o.gz: insmod /lib/modules/2.4.22/kernel/drivers/sound/cs4232.o.gz failed
/lib/modules/2.4.22/kernel/drivers/sound/cs4232.o.gz: insmod cs4232 failed

Am I going to have to recompile the kernel to get cs4232 in there? Suggestions? Thanks.
 
Old 06-22-2004, 12:53 AM   #5
freychef
Member
 
Registered: May 2003
Location: Montreal
Distribution: Slack, Libranet
Posts: 92

Original Poster
Rep: Reputation: 15
What do you get if you do the following? -

as root:

insmod sound
insmod ad1848
insmod uart401
insmod cs4232 io=0x530 irq=5 dma=1 dma2=0

then launch aumix.

Anything?
 
Old 06-22-2004, 08:23 AM   #6
JazzMastaJim
Member
 
Registered: Jun 2004
Location: Deep in the woods of southern NJ
Distribution: Pendrivelinux 2008
Posts: 70

Rep: Reputation: 15
Congrats on getting the sound to work on your TP600e! That was my biggest -- and really, only -- frustration with mine. SuSE 8.1 kept insisting on using the wrong driver, but once I solved that, everything was fine. In fact, for the most part, my TP600e runs Linux better than it does Win98!
 
Old 07-04-2004, 11:00 PM   #7
luisdanielmc
LQ Newbie
 
Registered: Jul 2004
Location: Washington, DC, USA
Distribution: SuSE Linux v9.1
Posts: 1

Rep: Reputation: 0
How???

Hello out there!

HELP! HELP! HELP! Gettin' desperate here!!!!

I have a Thinkpad 600e running SuSE Linux v9.1 Professional and still cannot get the sound to work and it is driving me nuts! I read Jim's post where he got it to run under Suse 8 and I wonder how he did it? Each single time that I try to "probe" the card, the laptop freezes and that's it! (even with alsaconf)...

HELP! HELP!

Thanks,
Luis.
 
Old 07-05-2004, 02:46 AM   #8
JazzMastaJim
Member
 
Registered: Jun 2004
Location: Deep in the woods of southern NJ
Distribution: Pendrivelinux 2008
Posts: 70

Rep: Reputation: 15
I wish I could help you, Luis, but I set up my TP600e at least two years ago, so I don't remember the specifics. However, I do remember that the main problem I had was that SuSE kept trying to use the wrong driver for my sound chipset (which varies depending on which one of the several variations of TP600e you have). In my case, I had to determine which driver to use by trial and error.
 
Old 07-05-2004, 04:46 AM   #9
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
luisdanielmc, reboot your Thinkpad and enter the setup program as it boots (press F2 or something?). Find the "reinitialize" option and use it. Reboot your computer. Use alsaconf to configure your sound. Done.


Håkan
 
Old 07-20-2004, 03:49 PM   #10
jhalford
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
There is a special workaround for the debian woody stable ditro using kernel 2.4bf:
This is using everything which is already posted here and about 3 hours of troubleshooting with a wonder volenteer of debian staff:

I am posting this here, because this was one of the first sites which put me on the right track trying to figure out what was going wrong with my soundcard. The syptoms were simple: the first .25sec of a soundclip was looped. With KDE I didn't notice this unless I ran 'aumix' and played with the speaker volume, because the first .25 sec of the kde 2.2.2 loginsound was too quiet to hear. As remodie I ran 'rmmod cs4232' and 'modprobe cs4232' every time I booted before I opened kde. You can read about why this happens with the example from the IBM people:

The IBM people already know that there CS card is a pain in the backside: But thier info helped a little
http://www-307.ibm.com/pc/support/si...GR-4BP6Q6.html

OSS workaround:

1.delete /etc/modutils/sndconfig, sndconfig.bak, and cs4232 if you have them

2.(over)write '/etc/modutils/sound' with this:
*******************
alias sound-slot-0 cs4232
alias sound-service-0-3 cs4232
alias sound-service-0-0 cs4232
options sound dmabuf=1
options cs4232 io=0x530 irq=5 dma=1 dma2=0 isapnp=0 \
mpuio=0x330 mpuirq=5 \
synthio=0x338 synthirq=9
options opl3 io=0x388
options wavefront io=0x338 irq=9
**********************
This is good enough for the modules and works on the above distro with a IBM Thinkpad 600E

3.after replacing '/etc/modutils/sound', run 'update-modules'.


4.Get this workaround Demon and save it in your init.d directory

with:
cd /etc/init.d && wget http://WWW.sabi.co.UK/xirc/cs4232
it should be saved as at /etc/init.d/cs4232

or copy and paste:
*******************************************************
#!/bin/sh
# chkconfig: 2345 99 01

DAEMON="/lib/modules/`uname -r`/kernel/drivers/sound/cs4232.o"

test -f $DAEMON || exit 0

case "$1" in
start) echo -n "Restarting the cs4232 driver: "
rmmod cs4232
modprobe cs4232
echo "restarted."
;;
stop) echo -n "Stopping the cs4232 driver: "
rmmod cs4232
echo "stopped."
;;
restart|force-reload) echo -n "Re-restarting ATM ARP Daemon: "
rmmod cs4232
modprobe cs4232
rmmod cs4232
modprobe cs4232
echo "re-restarted."
;;
*) echo "Usage: $0 start|stop|restart|force-reload"; exit 1
;;
esac
exit 0
********************************************************
5. 'chmod a+rx /etc/init.d/cs4232' and then
'/etc/init.d/cs4232 start' and then play again and check if it the looping is gone.

(every user has to be able to execute and read this file)
I used an Mp3 and mpg123 to check my sound

6. now run 'update-rc.d cs4232 defaults 99'

Debian uses run levels 2,3,4,5 and they are equivalent. This inserts the cs4232 'daemon' in the last place for all of these run levels.
but the SYSV is a mess, don't worry, this worked perfectly for me. This is what the output looked like for me: (anyone with a thinkpad should have something identical, maybe with a different host name .
ls -ld /etc/rc*.d/*cs4232
Output for this command (looked like see below)
monkey:~# update-rc.d cs4232 defaults 99
Adding system startup for /etc/init.d/cs4232 ...
/etc/rc0.d/K99cs4232 -> ../init.d/cs4232
/etc/rc1.d/K99cs4232 -> ../init.d/cs4232
/etc/rc6.d/K99cs4232 -> ../init.d/cs4232
/etc/rc2.d/S99cs4232 -> ../init.d/cs4232
/etc/rc3.d/S99cs4232 -> ../init.d/cs4232
/etc/rc4.d/S99cs4232 -> ../init.d/cs4232
/etc/rc5.d/S99cs4232 -> ../init.d/cs4232

The S99 is the last space in the init.d sysV thingy apparently ... that is what this prefix S99 is all about


and we can check that it is there:
monkey:~# ls -ld /etc/rc*.d/*cs4232
lrwxrwxrwx 1 root root 16 Jul 20 21:03 /etc/rc0.d/K99cs4232 -> ../init.d/cs4232
lrwxrwxrwx 1 root root 16 Jul 20 21:03 /etc/rc1.d/K99cs4232 -> ../init.d/cs4232
lrwxrwxrwx 1 root root 16 Jul 20 21:03 /etc/rc2.d/S99cs4232 -> ../init.d/cs4232
lrwxrwxrwx 1 root root 16 Jul 20 21:03 /etc/rc3.d/S99cs4232 -> ../init.d/cs4232
lrwxrwxrwx 1 root root 16 Jul 20 21:03 /etc/rc4.d/S99cs4232 -> ../init.d/cs4232
lrwxrwxrwx 1 root root 16 Jul 20 21:03 /etc/rc5.d/S99cs4232 -> ../init.d/cs4232
lrwxrwxrwx 1 root root 16 Jul 20 21:03 /etc/rc6.d/K99cs4232 -> ../init.d/cs4232
monkey:~#

OK, that's perfect
it starts and stops that script last (priority 99) in all runlevels.


This Workaround was based on the Redhat workaround 'ported' for Debian Woody linux by !!!!!!blisssex!!!!!!!! on the Debian support IRC today. and written here by me.... today!

Thanks a lot blissex


Last edited by jhalford; 07-20-2004 at 04:06 PM.
 
Old 03-16-2005, 02:37 PM   #11
saxophobe
Member
 
Registered: Feb 2003
Location: Dallas, TX
Distribution: CentOS 5.3
Posts: 131

Rep: Reputation: 15
Question about this thread...

Hi all!

Due to the age of this thread, I'm not expecting much of an answer, but I thought I would post to ask my question anyway.

First, the keystroke to use at start up of the 600E to get to the Configuration > Initialization is the F1 key. At least it is on my system.

Next, I got sound working my first running the Initialization, then rebooting into root and running alsaconf and the default settings, then running a mixer like aumix or alsamixer, then running alsactl store.

The only problem at this time, is the fact that when I reboot, I loose these settings and have to do the entire operation again in order to get sound to work on my laptop.

Anyone have any clues on how to do this?

I would really appreciate any type of answer, even if it is "I don't have the foggiest!"

Thanks!

sax
 
Old 03-25-2005, 01:50 PM   #12
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
Quote:
The only problem at this time, is the fact that when I reboot, I loose these settings and have to do the entire operation again in order to get sound to work on my laptop.
alsactl store should store the settings you use. Just use alsactl restore to bring the settings you saved back. The alsasound init script should do this automatically when run with the "start" parameter (as it should be run on boot).


Håkan
 
Old 03-26-2005, 02:29 PM   #13
saxophobe
Member
 
Registered: Feb 2003
Location: Dallas, TX
Distribution: CentOS 5.3
Posts: 131

Rep: Reputation: 15
Hello Hakan!

I hope you are doing well since the last time we talked here at LQ!

With this distro, which I am going to stay with for a while, when I run an alsactl restore I get the following error:

alsactl: load_state:1267: No sound cards found....

Now, at this time, sound works fine with XMMS, but not Firefox, or anything else as far as I can tell. This is while logged in as a normal user, and su'ed into root in the terminal.

I have also tried recompiling the kernel with the options that I want, but I wasn't able to boot to the new kernel as the only kernel choice was my linux.old. I still have to figure out how to edit the /etc/lilo.conf file to give me the choice of either kernel.

In any case, I also have a theory that it may be either the battery on the motherboard of my system, or the fact that the laptop battery is dead, but I'm not sure.

In any case, thank you for responding! I appreciate your expertise and willingness to help fellow users! You have truly earned your title as Guru!

Take care, one and all!

sax
 
Old 03-26-2005, 04:11 PM   #14
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
Quote:
I hope you are doing well since the last time we talked here at LQ!
I am doing well, thank you. I hope you are too.

Quote:
With this distro, which I am going to stay with for a while, when I run an alsactl restore I get the following error:

alsactl: load_state:1267: No sound cards found....
Do you run the alsasound init.d script before you type alsactl restore?

The way it works is usually something like this: Alsa modules with their proper parameters are stored in a file that differs from distribution to distribution but do pretty much the same thing: It is the global Alsa configuration file. In Gentoo it is /etc/modules.d/alsa, in Debian it is /etc/modprobe.d/alsa (IIRC). What the alsaconf program does is set up this file to load the proper drivers according to your hardware.

The init script, usually called /etc/init.d/alsa or /etc/init.d/alsasound is used to start and stop the alsa system. When passing the "start" parameter to it, it loads the modules with parameters according to the configuration file and restores the stored mixer settings. With the "stop" parameter it will store the mixer settings and unload the driver modules. If I remember correctly, alsaconf calls the init script with "start" after configuration to start the Alsa system. This is what you should do at boot, or manually if you prefer to do it that way: /etc/init.d/alsa start
Most distributions come with a tool for specifying what init scripts should be active at what runlevels and create the necessary symbolic links to start and stop the services (using the init scripts).

If your distribution is Slackware or Slackware-based it probably doesn't use System V-type init scripts (like most other distros) but the BSD model instead. I'm not familiar with this at all so I'll let som Slackware user answer that.

It's been a long time since I used lilo but it was pretty easy to configure IMHO. Perhaps the Debian lilo.conf was unusually well commented? Anyway, I assume you know you need to run /sbin/lilo after making changes to /etc/lilo.conf since this is what installs the new boot block.

If you're not using an initrd this is pretty simple: Copy the new kernel (/usr/src/linux/arch/i386/boot/bzImage) to /boot/linux-${VERSION} (like "linux-2.6.11-ac2") and add another image entry - in addition to the existing one - in the lilo config file like this:
Code:
image=/boot/linux-2.6.11-ac2
	label=linux
	read-only
	root=/dev/hda5
Guru, no. But I'm working on it, and I've spent a whole lot of hours on my Thinkpad!


Håkan

Edit: Oh, and happy birthday!

Last edited by hw-tph; 03-26-2005 at 04:16 PM.
 
Old 03-27-2005, 09:51 AM   #15
saxophobe
Member
 
Registered: Feb 2003
Location: Dallas, TX
Distribution: CentOS 5.3
Posts: 131

Rep: Reputation: 15
Hi Hakan!

Thanks for the Happy Birthday! It was a happy one!

I tried running the init script manually, which in Slackware, or Minislack appears to be /etc/rc.d/rc.alsa start, but I get the following in return:

Code:
Loading ALSA mixer settings:  /usr/sbin/alsactl restore
/usr/sbin/alsactl:  load_state:1267: No soundcards found...
Loading OSS compatibility modules for ALSA
Anyways, what do you think about my battery theory? Also, the instructions I had for compiliing a new kernel left out the bit about running /sbin/lilo after making changes to the /etc/lilo.conf script. I had already added the new entry manually to display the new kernel, as well as the old one. I ran that and all my changes appeared after reboot. Thanks for that!

If you have any other ideas, please let me know. I will continue researching this issue, and will post back if I find anything.

Thanks again for your time and expertise!

sax
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: Sound on the Thinkpad 600E hw-tph LinuxAnswers Discussion 3 05-29-2009 04:18 AM
Fedora 2/Thinkpad 600e/Sound kms_md Linux - Laptop and Netbook 8 03-10-2006 06:25 PM
no sound with ibm thinkpad 600e pat travers Debian 14 10-18-2005 02:38 PM
no sound on thinkpad 600e qfesp2002 Linux - Laptop and Netbook 4 09-30-2005 11:22 AM
Sound on IBM ThinkPad 600E firejdl Linux - Hardware 1 06-19-2003 11:35 PM


All times are GMT -5. The time now is 07:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration