LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices

Reply
 
Search this Thread
Old 06-23-2003, 02:11 AM   #1
rmartine
Member
 
Registered: Dec 2002
Location: San Luis Obispo, CA
Distribution: Fedora Core 3
Posts: 618

Rep: Reputation: 30
Superkaramba .27 RedHat 8.0


Alright people.. this bugged the hell out of me and there was ZERO answer on google or anywhere I looked.

For those of you who were tired of the "This was compiled against libxml 205 you're using libxml 204" error here is how you fix it.

First run rpm -qa | grep libxml . If you see libxml 2.4.X you need to go here: http://xmlsoft.org/

You need these packages
libxml2-2.5.7-1
libxml2-devel-2.5.7-1
libxml2-python-2.5.7-1

To avoid the rpm circle of dependency hell.... install libxml2-2.5.7-1 like this.

rpm -Uvh libxml2-2.5.7-1 --nodeps
then install the development package, then the python package. You probably don't need those but since you're upgrading one why not the others.

Now try running make against Superkaramba 0.27 and that stupid error will go away.

Sheesh

Yeah yeah.. I usually preach again rpm but it's late and I'm feeling lazy... Now.. back to the new API calls... heheh
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
help for Superkaramba xandar Mandriva 1 09-24-2005 02:55 PM
Superkaramba adds2one Linux - Software 5 09-12-2005 11:57 AM
Superkaramba and QT fail66 Debian 1 11-22-2004 08:01 PM
superkaramba redhat 9 pld Linux - Software 1 08-26-2003 09:16 AM
Superkaramba on redhat 9 Born^Dead Linux - Software 4 08-21-2003 12:44 AM


All times are GMT -5. The time now is 05:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration