LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices

Reply
 
LinkBack Search this Thread
Old 04-12-2013, 11:30 PM   #1
angel'le
LQ Newbie
 
Registered: Apr 2012
Distribution: Gentoo, Arch
Posts: 19

Rep: Reputation: Disabled
Talking Solved poor video quality in Arch after updating Intel drivers


I was not able to run some games that require 3D graphics and closed instantaneously at being executed, also could not view properly video (lags).



The common error message I had was in games: ../../../src/mesa/swrast/s_renderbuffer.c:584: map_attachment: Assertion `srb->Map' failed.



I wasn't sure about this until I installed mesa-demos and runned glxgears. 

Reading the Wiki Arch https://wiki.archlinux.org/index.php/Intel_Graphics
 and choosing the SNA acceleration method I got working everything well.



Basically create a file /etc/X11/xorg.conf.d/20-intel.conf and append the following:



/etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "sna"
EndSection

Note: I was not able to see videos until I chose in vlc to take as default output X11 video and in mplayer command used "-vo X11" command"

Also edited as root /etc/mplayer/mplayer.conf which was blank adding: 
vo=x11 because local configuration file did not work.
 
  


Reply

Tags
arch, intel, lag, mesa, video


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
quality of video edited is poor any suggestions tkmsr Linux - Desktop 5 11-12-2010 07:35 AM
Poor video quality Chris Hansen Linux - Software 4 12-14-2008 03:12 PM
Very Poor Font/Image Quality after installing Nvidia Drivers Please Help DYNO Linux - Hardware 1 12-25-2004 02:17 PM
RH9, xmms, intel 845GL chipset, poor audio quality kbridger Red Hat 3 10-15-2003 05:58 PM
Poor TV Card video quality fourwood Linux - Software 5 09-16-2003 11:59 AM


All times are GMT -5. The time now is 12:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration