LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices

Reply
 
Search this Thread
Old 08-16-2009, 03:18 PM   #1
ocumo
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Rep: Reputation: 0
"QGtkStyle cannot be used together with the GTK_Qt engine" SOLVED


I thought I should share this one. Easier than I thought, but distracted me for a while.

I use Kubuntu 9.04 "Jaunty Jackalope" (just upgraded from Intrepid).

While troubleshooting something nastier, I found in ~/.xsession-errors several instances of the error message

QGtkStyle cannot be used together with the GTK_Qt engine

I noticed it appeared after launching a GUI program, like for example:

kdeinit4: preparing to launch /usr/bin/systemsettings ...or
kdeinit4: preparing to launch /usr/bin/konqueror

It seemed that it had to do with the visual style. It did. I had recently made some cosmetic changes to KDE. In fact, the offended action was: I had selected a different "Widget style" in "System Settings" -> "Appearance" -> "Style" the style... GTK+ .. DOH!

After changing it to "Oxygen" (any other more "QT ish" would do), the message did not appear again.

An easy one, folks, just to cheer me up while I have been fighting a really tough one... (I hold the story for another time) ;-)

Ocumo

Last edited by ocumo; 08-16-2009 at 03:19 PM. Reason: minor formatting change
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't open default font "fixed" (problem solved,it's so silly) jimmerlin Linux From Scratch 1 11-24-2008 08:24 PM
Solved-"xine was unable to initialize any audio drivers" beachboy2 Linux - Hardware 5 09-18-2007 01:24 PM
SOLVED: Trying to "reverse engineer" a calculation: any number hackers out there? drkstr Slackware 22 08-01-2006 01:01 AM
Proposed solution for "status" (aka "problem solved") indicator demerson3 LQ Suggestions & Feedback 12 04-08-2006 02:15 PM
"perl Makefile.PL" complains about cc & gcc (self solved tip) Raptor Ramjet Slackware 2 09-13-2004 02:24 PM


All times are GMT -5. The time now is 12:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration