LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices

Reply
 
Search this Thread
Old 11-29-2012, 02:19 PM   #1
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 5,995
Blog Entries: 5

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
Oracle runInstaller won't load on RHEL6 with Exceed


Posting this in the hopes it will help someone else:

We had recently installed two RHEL 6.3 systems with Oracle GRID. On doing so we had used a Windows 7 machine running Cygwin/X for displaying X windows back to the desktop and PuTTY with ssh tunneling enabled for initial login. We had no problems using the Oracle runInstaller GUI on that desktop.

After completion of this the DBA went to his own desk which is running Windows XP with Hummingbird Exceed 7.0. He is using SecureCRT rather than PuTTY to open initial session to the RHEL6.3 system. When he attempted to launch runInstaller for Oracle DB 11.2.0.3 it gave 3 messages as if it was going to load but then returned to command prompt without error but the GUI didn't come up. We had verified xterm from the RHEL6.3 system DID come up so we knew X back to his desktop was working.

On doing further tests we found that we could launch the very same runInstaller (which was on an NFS mount) from any RHEL5 system but could NOT on either of the RHEL6.3 systems we had just installed nor on an earlier RHEL6.1 system we tested. The issue therefore appeared to be a combination of the user's desktop (likely Exceed) and RHEL6.

We attempted to launch the initial session on the Windows XP box using PuTTY instead of SecureCRT but this didn't make a difference so it wasn't the SecureCRT that was the problem.

We also realized that in fact the runInstaller was launching and staying active as a background java process on the RHEL6 machines. Running lsof -p against the pid of that process showed it was in fact connected back to the Windows XP desktop machine so it appears the issue was that Exceed couldn't display it properly when coming from RHEL6.

On searching for this I found various people had had the problem but the usual comment found was "RHEL 6 isn't supported for your version of Oracle". That may have been true for those versions but we had specifically verified the version we were running is now certified on RHEL6 before we did the GRID install. Finally I did find one post where the author saw exactly the same as we did and he noted that running xming or mobaxterm it worked properly which confirmed our suspicion the issue was Exceed itself. (Especially since it had worked on Cygwin/X on the other machine.)

Since Exceed 14 is the latest version and we were running Exceed 7 I decided to get the later version (we are running licensed copies so I had to get authorization for the non-demo download from vendor Open Text who had bought Hummingbird some time ago.) On installing that on both the Windows 7 box and the Windows XP box it successfully displayed the runInstaller on launch from the RHEL6.3 servers.
 
  


Reply

Tags
hummingbird exceed 7, open text exceed 14, oracle runinstaller error, rhel6


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing RHEL6 using Oracle Virtual box having Win 7 as base OS arora.linux Linux - Newbie 2 05-31-2011 06:49 PM
Exceed/Exceed 3D performance under OpenSuSE 11.2 HGPilot Linux - Newbie 3 08-05-2010 03:41 PM
Installing Oracle 9.2: runInstaller gives Segmentation Fault deanbrown3d Linux - Newbie 3 06-21-2004 09:39 PM
runInstaller problem for installing Oracle 8i in Linux Wasim Haider Linux - General 8 07-28-2003 11:09 AM
Oracle Installation / runInstaller error ultraman Linux - Software 9 05-31-2003 05:47 AM


All times are GMT -5. The time now is 04:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration